OTAA joining issue


(Surendar) #1

Hi all,

I have tried registering 4 devices which have been already registered by another application for testing(as of now deleted) I have created a new application now and I am trying to join the 4 devices into my new application. I can see the join request message in the TTN gateway and TTN Application. But the devices are not joining the TTN. How shall I rectify this?

Can anyone help me with this?
image


#2

this is the previous post you deleted.

’ Im using lg01, I cannot see any uplink in my ttn using the example given online. Anyone can help??
I now trying another coding to upload data from dht11 to ttn, but most of the coding use serial1 and im using a simple arduino uno and lora shield, any recommended coding online I can use to upload my sensor data to ttn?? ’

  • So you are using a dragino LG01 gateway ?
  • Did it worked before you changed the application name ?

(Ud Lo Ra) #3

If so, likely OTAA is not possible: https://wiki.dragino.com/index.php?title=LoRa_Questions


(Pendleto) #4

Yes…I can verify that OTAA doesn’t seem to work with Dragino Hat (even if it is running as a node and not a gateway). You get the same behavior as described above: JOINs requests but no accept. Some other problems with the hat: the frequency hopping doesn’t seem to work very well, and the GPS is very slow to get a position fix (even with an external antenna).

I hope they can fix these issues in future releases, because the HAT itself is a good form factor and price point. It does work fine in ABP mode.


(Surendar) #5

Hi,
That is not me.

I am using the gateway called cloudgate. Yes, it worked in the last application. when i deleted the application and created the new application and added the same devices to the new application its not joining the TTN.


(Arjan) #6

We’ll need many more details.

In TTN Console:

  • Did you delete the devices from the application before you deleted the old application?

  • Did deleting the application give you any warning about the existing devices?

  • Which of the details are the same as in the previous registration: DevEUI, AppEUI and/or AppKey?

  • Did registering the devices in the new application give you any warning/error about an existing DevEUI?

  • Does clicking the OTAA Join Requests in the gateway’s Traffic page (orange icons) give you any more details about what might have gone wrong?

And as for the devices:

  • Did you change anything in the devices?

  • Can you program the devices yourself? (Like to change the AppEUI, AppKey or even the DevEUI.)

Related: How can I reuse hardcoded AppEUI and AppKey after I deleted an application?


(Surendar) #7

Thank you for your reply

Yes i have deleted the device before deleting the application. I did not get a error while deleting the devices/application.
DevEUI is same the AppEUI and AppKey is new given by newly created application.
While registering to the device to the new application id does not give any error and in gateway traffic also i could not see any error.

I have option to change my AppEUI and AppKey.

Now i got one device connected to the new application but i didn’t do any changes. For 1 hour it was requesting for the join request and now i see join request accepted and i can see the data in my Application.

But, why it takes 1 hour to join the TTN application?


(Mid Walesha) #8

Using a single channel gateway?


(Surendar) #9

No its not a single channel gateway.


(Surendar) #10

Dear Team,

I have created an application and I have added two devices. But my devices do not join the network. But on the gateway traffic, I can able to see the join request and join accept message but on the application side, I didn’t receive any message. I am using EU frequency and EU handler for the application and the gateway.
image .

How shall I resolve this?