Packet REJECTED


(Jdsilvapereira) #1

Hi,

My local_conf.json in my multitech conduit is:

"SX1301_conf": {
	"antenna_gain": 5,
	"chan_FSK": {
		"bandwidth": 125000,
		"datarate": 50000,
		"enable": true,
		"if": 300000,
		"radio": 1
	},
	"chan_Lora_std": {
		"bandwidth": 250000,
		"enable": true,
		"if": -200000,
		"radio": 1,
		"spread_factor": 7
	},
	"chan_multiSF_0": {
		"enable": true,
		"if": -400000,
		"radio": 1
	},
	"chan_multiSF_1": {
		"enable": true,
		"if": -200000,
		"radio": 1
	},
	"chan_multiSF_2": {
		"enable": true,
		"if": 0,
		"radio": 1
	},
	"chan_multiSF_3": {
		"enable": true,
		"if": -400000,
		"radio": 0
	},
	"chan_multiSF_4": {
		"enable": true,
		"if": -200000,
		"radio": 0
	},
	"chan_multiSF_5": {
		"enable": true,
		"if": 0,
		"radio": 0
	},
	"chan_multiSF_6": {
		"enable": true,
		"if": 200000,
		"radio": 0
	},
	"chan_multiSF_7": {
		"enable": true,
		"if": 400000,
		"radio": 0
	},
	"clksrc": 0,
	"lbt_cfg": {
		"enable": false,
		"rssi_target": 160
	},
	"lorawan_public": true,
	"radio_0": {
		"enable": true,
		"freq": 867500000,
		"rssi_offset": -162,
		"tx_enable": true,
		"tx_freq_max": 870000000,
		"tx_freq_min": 863000000,
		"type": "SX1257"
	},
	"radio_1": {
		"enable": true,
		"freq": 868500000,
		"rssi_offset": -162,
		"tx_enable": false,
		"type": "SX1257"
	},
	"tx_lut_0": {
		"dig_gain": 0,
		"mix_gain": 11,
		"pa_gain": 0,
		"rf_power": -6
	},
	"tx_lut_1": {
		"dig_gain": 0,
		"mix_gain": 13,
		"pa_gain": 0,
		"rf_power": -3
	},
	"tx_lut_10": {
		"dig_gain": 0,
		"mix_gain": 15,
		"pa_gain": 2,
		"rf_power": 16
	},
	"tx_lut_11": {
		"dig_gain": 0,
		"mix_gain": 10,
		"pa_gain": 3,
		"rf_power": 20
	},
	"tx_lut_12": {
		"dig_gain": 0,
		"mix_gain": 12,
		"pa_gain": 3,
		"rf_power": 23
	},
	"tx_lut_13": {
		"dig_gain": 0,
		"mix_gain": 13,
		"pa_gain": 3,
		"rf_power": 25
	},
	"tx_lut_14": {
		"dig_gain": 0,
		"mix_gain": 15,
		"pa_gain": 3,
		"rf_power": 26
	},
	"tx_lut_15": {
		"dig_gain": 0,
		"mix_gain": 15,
		"pa_gain": 3,
		"rf_power": 27
	},
	"tx_lut_2": {
		"dig_gain": 0,
		"mix_gain": 9,
		"pa_gain": 1,
		"rf_power": 0
	},
	"tx_lut_3": {
		"dig_gain": 0,
		"mix_gain": 10,
		"pa_gain": 1,
		"rf_power": 3
	},
	"tx_lut_4": {
		"dig_gain": 0,
		"mix_gain": 12,
		"pa_gain": 1,
		"rf_power": 6
	},
	"tx_lut_5": {
		"dig_gain": 0,
		"mix_gain": 10,
		"pa_gain": 2,
		"rf_power": 10
	},
	"tx_lut_6": {
		"dig_gain": 0,
		"mix_gain": 11,
		"pa_gain": 2,
		"rf_power": 11
	},
	"tx_lut_7": {
		"dig_gain": 0,
		"mix_gain": 11,
		"pa_gain": 2,
		"rf_power": 12
	},
	"tx_lut_8": {
		"dig_gain": 2,
		"mix_gain": 12,
		"pa_gain": 2,
		"rf_power": 13
	},
	"tx_lut_9": {
		"dig_gain": 0,
		"mix_gain": 13,
		"pa_gain": 2,
		"rf_power": 14

But I receive this in the log file:

09:14:00  INFO: [down] a packet will be sent in "immediate" mode
09:14:00  ERROR: Packet REJECTED, unsupported frequency - 869525000 (min:0,max:0)

Why ?

Thanks.


(Jac Kersing) #2

This should be in global config, not local. And for TTN you need to download that global config from TTN.


(Jdsilvapereira) #3

Yes,

I’m trying to edit the Original global_config… but i need to remove “global_config_src” ? If not, after restart the service global_config is replaced.

Imagine that I need to use ttn-pkt-forwarder like the original of multitech. What is the file to edit the url to the server ? local ? global ? ttn- ? multitech_over… ? ?


(Jac Kersing) #4

Device specific settings should be in local_conf.json. General network settings in global_conf.json.

You should never need to edit global_conf.json.


(Jdsilvapereira) #5
Note: LoRa packet
src/jitqueue.c:305:jit_enqueue(): ERROR: Packet REJECTED, already too late to send it (current=1923102710, packet=1923047468, type=0)

##### 2019-01-21 16:54:55 GMT #####
### [UPSTREAM] ###
# RF packets received by concentrator: 1
# CRC_OK: 0.00%, CRC_FAIL: 100.00%, NO_CRC: 0.00%
# RF packets forwarded: 0 (0 bytes)
# PUSH_DATA datagrams sent: 2 (434 bytes)
# PUSH_DATA acknowledged: 0.00%
### [DOWNSTREAM] ###
# PULL_DATA sent: 12 (100.00% acknowledged)
# PULL_RESP(onse) datagrams received: 3 (545 bytes)
# RF packets sent to concentrator: 0 (57 bytes)
# TX errors: 0
# TX rejected (collision packet): 0.00% (req:1, rej:0)
# TX rejected (collision beacon): 0.00% (req:1, rej:0)
# TX rejected (too late): 100.00% (req:1, rej:1)
# TX rejected (too early): 0.00% (req:1, rej:0)
### BEACON IS DISABLED!
### [JIT] ###
# INFO: JIT queue contains 0 packets.
# INFO: JIT queue contains 0 beacons.
### [GPS] ###
# Invalid gps time reference (age: 1548089695 sec)
# no valid GPS coordinates available yet
### [PERFORMANCE] ###
# Upstream radio packet quality: 0.00%.
# Upstream datagram acknowledgment quality for server "XXX SERVER 1 XXXX" is 0.00%.
# Upstream datagram acknowledgment quality for server "XXX SERVER 2 XXXX" is 0.00%.
# Downstream heart beat acknowledgment quality for server "XXX SERVER 1 XXXX" is 100.00%.
# Downstream heart beat acknowledgment quality for server "XXX SERVER 2 XXXX" is 100.00%.
# Downstream datagram content quality for server "XXX SERVER 1 XXXX" is 100.00%.
# Downstream datagram content quality for server "XXX SERVER 2 XXXX" is 100.00%.
# Downstream radio transmission quality for server "XXX SERVER 1 XXXX" is 100.00%.
# Downstream radio transmission quality for server "XXX SERVER 2 XXXX" is 100.00%.

### [ CONNECTIONS ] ###
# bridge.eu.thethings.network: Connected

# Semtech status report send.
##### END #####
16:54:55  INFO: [TTN] bridge.eu.thethings.network RTT 236
16:54:56  INFO: [TTN] send status success for bridge.eu.thethings.network

I think that downstream is ok, but upstream is allways 0…


(Jac Kersing) #6

TTN protocol does not use those stats.