Problem claiming gateway


When I try to claim my TTIG gateway I get the following error.

Submit failed
Request to failed

Any suggestions.

Gateway EUI 58-A0-CB-FF-FE-80-19-E1


That seems to be a transient error on the upstream API.

Which cluster are you claiming the device? How many times did you try?

Cluster was

I have tried a few times.



We are facing the same issue with 3 TTIG gateways but in the Australian cluster (

The gateways EUI are:

When we submit the following error appear: Submit failed
Request to failed

Here is the error details:

  "code": 10,
  "message": "error:pkg/deviceclaimingserver/gateways:verify_gateway_claim_authentication_code (could not verify gateway claim authentication code)",
  "details": [
      "@type": "",
      "namespace": "pkg/deviceclaimingserver/gateways",
      "name": "verify_gateway_claim_authentication_code",
      "message_format": "could not verify gateway claim authentication code",
      "correlation_id": "1573134a437e4ca391f174442cbf089b",
      "cause": {
        "namespace": "pkg/errors",
        "name": "request",
        "message_format": "request to `{url}` failed",
        "attributes": {
          "op": "Post",
          "url": ""
        "correlation_id": "ed86b1ea53034cd5b61cfbdb81e5bb48",
        "code": 2
      "code": 10

Can someone help us with ideas to fix this issue?
Is the first time that we see this happening.

Best Regards.

I still have the same problem.

I have tried to claim my gateway with the web console and with tti-lw-cli a few times over the past 24 hours. I am getting the same error as posted above by suportemetosbrasil.



Same here with NAM1 with several different TTIG

:thinking: Double and treble check that you have used correct Wi-Fi code (used for claiming) havent see a problem for a while but I recall once when I did it was misread/mistype of code - my eyes aren’t what they used to be and small/esaily confused code :wink: (Actually also double and treble check GW EUI whilst at it!)

I can reproduce the error. Investigating it.

1 Like

Hi, we are students using TTN for the first time and we got that claim problematic aswell.
We have bypassed the problem by creating a new gateway without EUI and after we go to general setting and add the gateway EUI that way. It seems to work but we are not sure to have recovered the claim on the gateway. We are not sure about the importance of the claim to use the gateway, if you can explain it to us it will be great. Thanks in advance for your help and your time .

Hi @arthur_deuker given

I would recommend patience and hold off until officially fixed vs attempting a work around that may break or not be effective/stable and may cause further problems down stream. These kind of (claiming) issues usually solved in hours/days vs weeks/months :slight_smile: The Force is strong with Krishna :wink:

Basically TTI/TTN systems use the credentials you provide to interrogate a 3rd Party database to effect the claim…the links or the system occationally hick-ups and needs someone to kick, stroke or attack the server with a light-sabre… trying to circumvent may risk incorrect population/interrogation of that server/db, perhaps meaning that when GW subsequently does checks for updates (daily?) on CUPS etc. they may fail or brick… as I say patience…

1 Like

The root cause has been found. We are working on a fix.

1 Like

Hi there,
we want to use a TTIG but have the same problem when we try to claim the device.
Do you have any news on how long we have to wait until it will work again?
Best regards

1 Like

The fix should be ready to be deployed today. I’ll get back to this thread when done.


Did you read the message above yours? It promises there wil be a message in this thread when the fix is active.

1 Like

Please do not delete posts that take the rest of the thread out of context, thanks.

I was able to claim the gateway now.

I can confirm claiming is now working and my gateway is claimed and connected.

Thank you for sorting it.


We’ve deployed the fix and seems like claiming is back. Thanks for reporting.