RAK 5205 tracker


(Pat Molloy) #57

What DEVEUI are you getting ? My device reports 60 C5 A8 FF FE 00 00 00 but the sticker says 60 C5 A8 FF FE 6D 00 7E

Perhaps DEVEUI needs to be globally unique? And that is what provokes my error message?


(Pat Molloy) #58

Great!! Thanks for this info … I will try now :slight_smile:


(Kastayou) #59

In my case the dev eui from the terminal output and the sticker are the same.


(Pat Molloy) #60

Ok, I cannot get it to accept AT commands. I am using putty … the at_dev_eui … is not echoed to the screen.

Do I have to set any special end-of-line characters ? Half duplex etc? Set any jumpers?

Manual says …

at+dev_eui=60C5A8FFFF1C****\r\n

for example … so I enter four “*” characters after the DEVEUI and then press enter?

Sorry … have tried lots of combinations, none work!!


(Pat Molloy) #61

Success. Up and running on TTN now … used this sofrware as termnal (on windows 10) to issue AT commands https://www.compuphase.com/software_termite.htm with these settings and it all worked fine …

image


(Pat Molloy) #62

Incidentally I don’t know what those asterisks are in the manual, but they are NOT required.


(Kastayou) #63

I am not familiar with putty as a console terminal.
I am using linux, but on windows, I used to like the terminal software called Tera Term (open source)

after each command you need to send a CR (carriage return) + LF (line feed). This is why you have the \r\n at the end of the example.
The way to enter the CR + LF depends on the software you use as a terminal. You can usually configure your software to automatically send CR + LF when you press enter.

So you need in fact only type this: at+dev_eui=60C5A8FFFF1C****
And you need to replace the stars by your real dev eui.

I think the correct value for your device should be the one on your sticker.
But the most important is that the dev eui that you are setting on your device matches the one you have entered on TTN when you registered the device.


(Pat Molloy) #64

Thanks so much, I should probably have used linux too, but was all plugged into my Wndows laptop.

Help invaluable … all working now, incl Cayenne.

Cheers!


(Kastayou) #65

Are you able to get the GPS coordinates?


(Pat Molloy) #66

Yes, once the antenna was connected and had a decent view of the sky the GPS data started flowing … and also appeared correctly in Cayenne

OTAA Join Start...
OTAA Join Success
latitude: 51.457207, longitude: -0.219332 , altitudeGps: 30
Bat: 3806mv

image


(Andreas58) #67

Module works fine, took a while before I could connect it to TTN by means of the at commands.
Can anyone tell me which payload format to use in TTN? I don’t get any readable data.


(Kastayou) #68

The payload format is cayenne LPP.

The module I received was delivered with firmware version 1.1.6 which use one set of AT command
refer to this post for the applicable AT command:

The latest firmware available on the RAK github is version 2.0.0.2 which use a different set of AT command

I am currently not able to modify, through the AT command, the interval at which the data are sent (bug in the firmware ??). the default interval value does not respect the TTN fair use policy.


(Andreas58) #69

Thanks for your answer. I’am using firmware 2.0.0. at the moment.

KR.


(Kastayou) #70

Please note that they have released two different firmwares that output v2.0.0.0 on the console.
One of the 2.0.0.0 version has a bug and can only send confirmed messages which will quickly violate the TTN fair use policy

For the other 2.0.0.0 version, I am not sure if by default the node is sending unconfirmed messages or if you need to manually change the parameter


(Afremont) #71

Has anyone been able to compile this from source? I’m using Eclipse, and I’ve made pretty good progress, but I’m still having some issues that look a lot like actual errors in the github source. I’m using the latest available code. Unfortunately, there are no Makefiles, or project files other than Keil. I’m stuck at a compile error where a source file is obviously referencing an undefined symbol. It would appear that the github contents pushed up a few days ago weren’t exactly a working combination. :frowning:


(Abhishek2101) #72

Hi

has anybody used RAK5205 device ? just wanted to know what IDE is used for programming, which language and if there are libraries available ?


(Steven Tang) #73

it is coocox IDE From ST . please check this document .
RAK5205_User_Manual_V1.4.pdf


(Jeff Uk) #74

For the V1 811 Tracker Rak used the CoIDe, but for the RAK5205 its now based on Keil MDK (V5+?)

Manual now at Rev 1.5/Rev 1.6

Code base here

If you are struggling contact fomi @ rak

If you want to get up and running quickly there are demo binaries (for HF & LF Bands here (with STM Flash utility). Put jumper into Boot mode and power up device to access then when flashed change jumper back and re-boot using Uart utility to interact with device per manual to configure and then join TTN :slight_smile:

Good luck :+1:


(Afremont) #75

I really wish Rak would consider anything other than keil, even eclipse. Keil development tools cost an absolute fortune. Rak’s solution seems to have been to put a serial number cracker utility on GitHub. :frowning: That very much disappoints me.

As an alternative, perhaps creating an mbed os board would be a good solution. Even a basic, but workable, gcc makefile setup would be nice. I have not succeeded in compiling the release using gcc due to syntax errors in a module and difficulty in determining command line requirements. I am now pursuing the possibility of getting both devices working with mbed. Mbed appears to contain a viable Lorawan stack and the os supports deep sleeping.


(Jeff Uk) #76

The cracker was supposed to have been removed/hidden…do not use as it is a) against copyright/license and b) virused! (Trojan) :wink: I did let Rak know about (b)

Would agree wrt alternate to Keil - the lite version sadly is limited to (IIRC) 32kB file where as even the basic RAK811 tracket and now the Rak5205 come in around 80-105kB…they are looking at gcc going forward I understand…