RAK 831 Raspberry Pi Zero 915MHZ TTN not connected

Hi, I am trying to connect to TTN my gateway, I have the RAK 831 Developer Kit in 915mhz, i am using the raspberry pi zero w and the original rak to raspberry converter board, I have followed 2 tutorials, this one: https://github.com/ch2i/LoraGW-Setup/tree/15f56e03546c6c5885b58259db64c0fa10af1250
And the one that is in RAK’s page: https://downloads.rakwireless.com/en/LoRa/RAK831-Pilot-Gateway/Firmware/
Non has worked for me, I registered in TTN, but never seems to be connected.ttn%20not%20connected

I also registered my Json file in the Github repository.

I would like to know if someone can help me to connect it to TTN, I´ve been reading and I think that is a problem with the Reset Pin or with the 915mhz band.

Thanks in advance guys!!!

1 Like

hi Sebas
Are you from Argentina too that are using 915Mhz AU band? Or from where?



1 Like

Hi Hugo, I am from Honduras, here we use the 915Mhz band.

1 Like

i am from Argentina, and we use AU915 too, welcome! Sure we can exchange experiences on AU915.


1 Like

Hi Sebas,
I am also having the same problem with the Status saying not connected. I am using a Dragino LG-02 in the U.S. with 915mhz. There isnt any information to give me a clue as to why I am no connected.

1 Like

For sure Hugo, we can exchange experiences, but I still can´t connect the gateway to TTN, I’ve followed several tutorials, do you have the RAK 831?

Hello Mrspringgs
I almost bought the Dragino LG-02, but I read some forums that it is a bit difficult to connect it to TTN, have you contacted the Dragino support? https://www.dragino.com/support/require-support.html ,
maybe they can give you some information.
I would like to help you, but I have not worked with Dragino’s stuff.

Hi Sebas
I have currently in use two gateways, both Kerlink, 1) ifemtocell 2) iBTS.
I don´t have experience with RAK, but can help with my experience on Kerlink.
You need to configure the SPF (Semtech Packet Forwarding), configure address for network server, select the apropiated network server for AU915 (meshed-router) and use the adecuate console for such router, that is not the standard console (I learned about this detail today, until today I was using a combination of two routers and the standard console, but last week that stopped working)
PLease check this post Meshed-handler - #10 by Samhain
in detail.

Do you have configured (added) the gateway? See some activity ? Some packet received?
Do you know how to check log files from the gateway? to debug, is very important to check log files, in kerlink, there are log files in the embedeed linux that show all activities…

Tell me know more about your advances and problems.


I can see that you are trying to use US915, probably you need AU915, the frequency plan is not the same, and .json file differs, i make the same mistake initially.
What endpoints are you trying to connect? I used RN2903 from microchip and requires an special firmware to use AU915!!! Not the standard firmware from US915.
It´s very important to have all in the same frecuency band… Check with MAC commands what frequencies are using, enable the correct channels, check all at details, details counts!

I am using the US915 .json file too, I configured the gateway to use the US915Mhz in TTN.
Right now I am just trying to connect the RAK831 Gateway to TTN, I am not using a node.

Ok, I see.
And yes, I have configured the gateway, but how do you check log files from the gateway?
I use sudo tail /var/log/syslog to check activity, but only shows me some GPS activity.
I think that is a SPF configuration problem, how could I check this configuration?

This applies to kerlink, but if is linux based, may apply to RAK


1 Like

You will first want to ensure that the process is correctly running. Depending on your system, you can use ps , ps -a or ps -A to display all the running processes. It will return a list of processes, with their PIDs:


admin@gateway:/# ps -A
  PID TTY          TIME CMD
    1 ??       00:00:00 init
    6 ??       00:00:00 poly_pkt_fwd
    8 pts/0    00:00:00 sh
   10 pts/0    00:00:00 ps
1 Like

Ensure that DNS is correctly configured, i remember a issue due DNS not configured, then the gateway cannot resolve the router address so SPF does not send any UDP Packet.

PLease check this post too Kerlink iFemtocell - connect to TTN? - #20 by hmullerenersa

1 Like

Hi @sebasretes! I’m your country neighbor :slight_smile: Greetings from El Salvador!

On this page we have a summary of several configurations working for the AU915 BandPlan. From small 1-Channel gateways to the RAK-Based multi-channel configuration. On this page you can find the configuration we are using on two of our Access Points here in San Salvador. Take a look on the global_config.js and local_config.js section:


On The Things Network console make sure that:

  1. Frequency Plan is: Australia 915MHz
  2. Router: Please use ttn-router-us-west (keep reading to know Why)
  3. Remove the marks from “Automatically update gateway” and “Beta Updates”

We are not using Meshed because Central-American countries route most of it’s Internet traffic through USA. It doesn’t make any sense to add network latency going around the world.

On the Network Side. Make sure that your DNS is working AND make sure that there is no any kind of firewall blocking the port 1700 in any direction.

Hope this works! :slight_smile:

1 Like

Thanks for your help hackerspacesv, we are almost neighbors :smiley:.
I will try it in a moment, I will explain if it works for me.
Thanks again and greetings from Honduras!!!

Thanks for your help Hugo!!!, I will read it and will check the configuration.

I will tell you in a moment if I make it work.

1 Like

Hello again guys.

I followed the RAK’s tutorial:

After edit some code, I made it!

The RAK firmware is used for RPi with eth0, I am using a Rpi Zero W, what it means that I use wlan0 instead of eth0. So, the gateway ID can not be generate correctly.

I did some changes in /opt/ttn-gateway/packet_forwarder/lora_pkt_fwd/update_gwid.sh
I change this:
GWID_BEGIN=$(ip link show eth0 | awk ‘/ether/ {print $2}’ | awk -F: ‘{print $1$2$3}’)
GWID_END=$(ip link show eth0 | awk ‘/ether/ {print $2}’ | awk -F: ‘{print $4$5$6}’)

for this:
GWID_BEGIN=$(ip link show wlan0 | awk ‘/ether/ {print $2}’ | awk -F: ‘{print $1$2$3}’)
GWID_END=$(ip link show wlan0 | awk ‘/ether/ {print $2}’ | awk -F: ‘{print $4$5$6}’)

Basically just eth0 to wlan0.

After that I edited /opt/ttn-gateway/packet_forwarder/lora_pkt_fwd/local_conf.json
Changed the gateway_ID to the one that I have in TTN.

After that, my gateway seems to be connected:

Here is the thread in RAK’s forum and the people who helped me: RAK 831 Raspberry Pi Zero 915MHZ TTN not connected - #11 by sebasretes - RAK831 - RAKwireless Forum

I am very grateful to you, thanks guys @hmullerenersa @hackerspacesv


That good!!! @sebasretes that you could find that configuration detail and that our collaboration has served you, and you already have it working. Thank you for documenting the solution, maybe in the future, when I try the RAK products, use this thread :slight_smile:

1 Like

Wow great!

I was thinking that you were using a normal Raspberry Pi.

It’s supposed that the generated address is just a way to generate a unique identifier using the MAC address. However it’s not necessary that the MAC address match with the interface used.

In my case for example the router is connected thru WiFi but the MAC was generated using the Ethernet address that is not being used.

Obviously the problem was caused because when the Ethernet device was not found the script couldn’t change the line and generate the address.

May be we need to add a auto-detection of the available network interface to fix the address generation script. Thank you we would going to add this to our address generation code. :slight_smile: