RAK2245 - LoRa Concentrator modules


RAK has a new serie of LoRa Concentrator modules.

RAK2245 96Boards IoT Edition

RAK2245 Stamp Edition

RAK2245 Pi HAT


design guide comparison RAK831 & RAK2245 series

(Kenyu) #2

RAK2245 compare to RAK831, we improve lots of features which developer met in previously deployment. SX1301 is quite hot so the heat sink on the module is very key. Also, “improves its sensitivity” I was meaning that other gateways have limited range due to interfering signals increasing noise and reducing the SNR of the nodes signal. By adding an extra SAW, the interference is lower and the gateway can hear the node. To a person who does not understand RF, they see this as a more sensitive receiver.

(Digiheart) #3


I am currently testing this model with the HAT version for the Raspberry Pi. Has anyone get the GPS working? I am getting the following error:

WARMING: [gps] read() returned value -1

Also, I can’t get any NMEA data from the I2C port.


did you install this software ?

(Digiheart) #5

Yes I did,

I even tried multiple times with fresh raspian lite

There are some bugs with that software that I can’t understand.

(Kenyu) #7

Do you mean you try the RAK2245 or RAK831? @fomi

(Digiheart) #8

The RAK2245

(Fomi) #9

Hi, @digiheart
I’ve used the source code https://github.com/RAKWireless/RAK2245-LoRaGateway-RPi-Raspbian-OS on RAK2245+RPi for testing, and got the GPS data successfully as follow:
Please check the red line information, they are GPS data, and ignore the green line error information.
BTW, i’ve just updated Github to remove these additional error information, you can check it again.

(Digiheart) #10

Hi fomi,

Thank you for the help.

I installed a fresh Raspbian and tested the latest commit, and I can confirm that some of the errors during installation are gone and that the amount of warmings is way less. However I still can’t get valid coordinates. I have all antennas plugged in and the device is standing by the window. Here is the output:


Any suggestion?

(Jeff Uk) #11

Dont know if it will help but whilst struggling to get quick fix and consistent/stable location lock on RAK5205 trackers (same/similar GPS chip?) over last few days @paulb called out fact I was inside near window (with low K glass treatments etc.) that might be screwing with timing/multipaths etc. When I took outside all fast and stable…perhaps try same with your GW or at least if GPS on long lead get ant outside window whilst testing?! :wink: Good Luck!..

(Digiheart) #12

Thank you for the advice, however I tried to put the gateway and without any success. Still invalid coordinates

(Fomi) #13

Hi, @digiheart

Have you open the i2c interface according to the Github readme:

If you have done that, i think that you can reduce the rate of i2c and try again.

(Fomi) #14

You can do as the following steps:

step 1. Check the GPS connection as follow:

step 2: Modify the /boot/config.txt file as the following content to reduce the i2c rate:

Then, restart the GW and check the GPS data.

(Fomi) #15

I’ve just updated the Github repo to add a folder for testing GPS fuction.
You can check it.