RAK811 recv=6,0,0


(Hdechelard) #1

Hi All
I’m very much a noob with TTN so please forgive my ignorance. I have 4 RAK811 nodes all of which have been upgraded with the latest firmware. 1 of them connects to TTN via the Hamilton Victoria Australia gateway with ease and the others which are set up exactly the same constantly return at+recv=6,0,0 errors. Every now and then I can see that TTN has received a response from one of the RAK811’s but this is rare. If I try to send a test message I get an Error1.

I have been trying to get this to work for nearly 2 weeks now and assume the problem is a setting but I have no idea what setting it could be.

Thanks in advance for any help you might be able to give.

Heinz


#2

how are the rak811’s connected… to what processor… what code/ frequenciies/ gateway type ect ect.

  • did you check the antenna’s (switched from te 'working ’ one
  • did you register them as 4 different nodes in an application

(Hdechelard) #3

Hi BoRRoz. Thanks for getting back to me so quickly. Please see my responses below:

  • how are the rak811’s connected: As standalone modules to PC via USB

  • to what processor: They are rak811 LORA shields supposedly able to be used as standalone nodes.

  • what code/ frequenciies/ gateway type ect ect.:

    • Code: No sure what you mean by this. I am in the Australia region
    • Frequencies: Should be 915 to 928MHz
    • Gateway type: Multitech community owned
  • did you check the antenna’s (switched from the 'working ’ one:

    • Will do but would think it unusual that 3 out of 4 are faulty.
  • did you register them as 4 different nodes in an application:

    • Yes

Your thoughts?


(Hdechelard) #4

If it helps here is the a link to the RAK11 devices that I have:

https://www.aliexpress.com/item/WisNode-LoRa-Open-Source-Hardware-module-test-development-board-compatible-Arduino-can-be-used-as-a/32789125486.html

H


#5

you cannot use exact the same AT instructions for all 4 nodes … I’m a bit busy at the moment… get back later tonight on this


(Gijs Mos) #6

If the error 1 you mention means at+recv=1,0,0 it means STATUS_TX_COMFIRMED. Which actually means that you did a confirmed uplink transmit which was acknowledged by the network. So no error.

Unless you mean error code - 1 immediately upon entering the at+send command. This means a parameter error in the command.

The error status at+recv=6 you are getting means STATUS_RX2_TIMEOUT. My best guess is that you did not get a confirmation for some reason.

Probably best to switch to unconfirmed first. This means use at+send=0,,. The first parameter means unconfirmed. If all goes well you would expect a at+recv=2,0,0 back. This means that the RAK811 completed a transmit.

And if you have access to the gateway’s console message monitor, you should see the messages coming in.

If that works you could go back to confirmed.

If you want some more help you could capture the command/reply stream (keys masked) for the working and a failing module.


(Hdechelard) #7

BoRRoZ you were right, it was dud aerials. With the aerial from the working node the other 3 connect with no problems. Will follow up with RAK.

Thanks BoRRoz and gmos for your help with this.

H


(Phil Wilko) #8

I am using a RAK811 using simple at+ commands to connect to TTN using OTAA. I have also got the same error recv=6,0,0 when trying to connect to the gateway.

I think, from reading the AT manual, that 6 is STATUS_RX2_TIMEOUT
If I try to continue on and attempt to at+send I just get ERROR-5 which is CODE_NOT_JOIN

I have tried a few antennas.
The gateway is fine and my other nodes connect to it OK.

The region is AU915 and I have flashed the region firmware

Does anyone have any ideas?


(Jac Kersing) #9

Check if your application receives the join request. You are connecting to the network, not to a gateway (LoRaWAN <> WIFI) so the application should show some activity.


(Phil Wilko) #10

No, the device is never seen by the application on the Console.

As the configuration up to this point is only the APP EUI and APP Key, I think the problem may be in the regional frequency settings.


(Hdechelard) #11

Try upgrading the firmware to: RAK811_V2022_AS923.bin