Rak811 Tracker Board

RAK also publish the open source project for rak811 as :https://github.com/RAKWireless/RAK811_LoRaNode

1 Like

Thank you for the links

Finally we have RAK811 support in PlatformIO out of the box :slight_smile: testing later, its been on and off this for months and months - one for 16kb and one for 32kb versions


1 Like

There appears to be Arduino support for RAK811 in the Arduino Core for STM32 (by STM) mentioned here: https://github.com/stm32duino/Arduino_Core_STM32

Which could possibly be combined with Arduino LMIC.

Has anyone tried developing for RAK811 with the Arduino framework?

I’ve been trying for weeks, close but it freezes on init() - there is an error with the core pins too, I need to post the fix

This may possibly help:

Regarding: #ifdef ARDUINO_ARCH_STM32
Check if ARDUINO_ARCH_STM32 is defined by the Arduino Core STM32 or that you will have to use a (slightly) different to check

Tried, and tried and re-tried - there is a pin mapping incorrect in the core setup which i need to pass on, but i just cant get past it freezing - tried those interrupt fixes, I will post some finding I found here over the next few days

I have not checked myself but is ARDUINO_ARCH_STM32 defined when using Arduino_Core_STM32?

The RAK811 Tracker Board is a board with RAK811 module with additional sensors and GPS.
The RAK811 module internally contains a STM32 MCU and SX1276.
The RAK811 tracker board definition in the Arduino_Core_STM32 core contains pin definitions for both the SX1276 inside the module and for the sensors and GPS on the board (external to the module).

Do you know of any documentation (other than Arduino_Core_STM32) where the internals of the RAK811 module and its STM32/SX1276 pin mappings are described?

I would like to be able to use the Arduino core with a RAK5205 tracker board.
Do you know if the RAK5205 Tracker Board is identical to the RAK811 Tracker Board (just a name change), or would a new board definition need to be created for the RAK5205?

I believe the RAK5205 is still build around the RAK811 module - but the tracker boards are not identical at all, the core RAK811 module is the same in terms cpu/lora bits so I think it will have the same issues I am having with the older tracker board



It’s strange that multimeter’s display indicates uA while the the selection switch appears to be in the temperature measurement position. :thinking:


that’s a great achievement ! :+1:

@ bluejedi
could be the knob out of position on this Chinese multimeter :sunglasses:

Sure, but the “out of position” issue makes one validly question the reliability of the measurement.

I have already seen big annoucement from RAK saying that they provide low power nodes (eg annoucing their new RAK5205 tracker going down to 14uA).

The measurements I have done and documented to RAK show a power consumption of 1.5mA and they did not provide any feedback or answer.

So for me, I will pass.

with their latest firmware ?? I doubt it because it’s a beta

with their latest firmware ?? I doubt it because it’s a beta

All the information are in the link to the post I have done in their forum.
But the answer is no, not with their latest beta firmware.

They have announced that their RAK5205 tracker node can go down to 14uA.
It is written in their datasheet and clearly mentionned in their aliexpress shop


So far, the product is not inline with the spec and no explanation or feedback from RAK has been provided since end of March.

So when RAK is announcing a new beta firmware being able to reach low power, I have a trust issue with that.

But I really hope that I am wrong

just try it… that wouldn’t hurt ?
If I have a product and the manufacturer comes with a firmware update, that improves the product, I install it… :sunglasses:

I have completed your sentence :smiley::smiley:

If I have a product and the manufacturer who demonstrates interest into answering their customer feedback comes with a beta firmware update, that supposedly improves the product , and plenty of time, I install it…

I spent too much time and effort on their products. I will eventually start again once it is really confirmed that they can achieved low power operations.

just released the V3.0.0.1 version firmware for RAK811:
and the new document:

In this version, we add the LoRaP2P mode.
You can see what’s the difference in the ChangeLog file:


i have old WisNode board with STM32L151CB (not STM32L151CB-A)
Flash size 128K but RAM only 16K (from 20000000 to 20004000)
So RUI_RAK811_V3.0.0.3.H.bin can’t start because stack pointer set to 20008000.
Also SysTick timer not disabled on jump from bootloader to application.
Can RAK developer publish source codes so i can change for my strange RAK811 ?

P.S. If i change 20008000 to 20004000 firmware works.