Reclaim Gateway

I have the Indoor gateway and I acidentally deleted my gateway and now I can’t get it back into the system.

I tried to claim it again, but I only get the message: “Gateway with ID eui-58a0cbfffe804e38 already exists. Please try using a different ID”

What to do?

Chant the error message until the penny drops that you have control over the ID and you can make it anything you like, something like:



Or gateway ID something like this


Then you will be good to go.

Thank you - didn’t see that. It worked :slight_smile:

1 Like

Hi. I’m a TTN newbie on the second day of trying to get my TTIG to connect. I followed along with your YT video and ended up doing a manual gateway claim process which at some point told me to contact support - so here I am.

My first help reference had me append “FF FE” to the end of the EUI so that’s how it appears in the gateway ID. I’ve since changed the EUI in the General Setting tab a few time as I floundered about - it’s now in the middle, bytes 4 & 5. I relaunched the gateway claim process, this time using the EUI and AP pwd which reports that my gateway is already claimed.

What worked: I accessed the AP, entered my Wi-Fi SSID & pwd, “Save & Restart”. the TTIG connected to my Wi-Fi and is sending UDP & TCP data, but the TTN Gateway Overview page has never shown and indication of a connection. I screen-captured all of the data from the AP access and am confident I have all the correct text.

I tried using the CLI (> ttn-lw-cli gateways claim authorize 58A0CBFFFE80xxxx) to allow me to reclaim it, but I always get “commands:unauthenticated (not authenticated with either API key or OAuth access token)”, even when using --api-key xxx… with an all rights API key I created and copied from the Overview page. I see from the man page that the api-key field is supposed to be a hex string - mine key is hex, and quite long.

I can DM or post the EUI (your call). FW ver 2.0.4, purchased Nov 2022, Adafruit. Thanks for any assistance you can render.

Do you have the error message as there are many many possibilities!

This forum is mostly volunteers who don’t have access to the TTN systems, so the “your YT video” isn’t any of ours, on here, the TTN community forum, it’s all ‘us’.

The written documentation is the key source of info to refer to - links bottom right of every console page - without knowing which video you looked at it’s hard to know if it’s up to date.

That said, it looks like you’ve got it registered - the gateway status is not real time but you should see various attributes filled in on the general settings. You will only see some action if you have a device sending uplinks - do you have a device?

EUI’s aren’t secret as they are transmitted in plain text at some point. For a TTIG the WiFi password aka Claim Code is confidential. For a device only the AppKey need be kept secret.

If we have the gateway EUI we can use the gateway status lookup to see more information. Or you can search the forum for the details and try it yourself.

I’ve not needed to use an API key to use the CLI - again the docs explain about setting the region and logging in for the first time to setup credentials (via Oauth) - and the program is a static Go app so doesn’t come with a man page - what were you referring to?

Thanks for the quick response.

My EUI is 58 A0 CB FF FE 80 3E C1. I have end devices and will proceed with getting one on-line ASAP.

Here’s the “man” page for the cli command: ttn-lw-cli gateways claim | The Things Stack for LoRaWAN

The video was on the “The Things Network” channel, posted 6 months ago - there are probably some key points that I missed early on. Adding Your First Device and Gateway in The Things Stack - YouTube

FWIW I’m still fuzzy on the relationship between the Frequency Plan / LNS / region / and gateway server. I assume that Freq Plan implies the region (US for me) and the LNS / gateway server are set via URI. Also should I avoid US “FSB 2 (used by TTN)”. I’ve tried a different FSBs with no obvious difference. I don’t think this is the source of my problem and I’ll sort it out over time - after I get the end device going.

FYI, man page is a rather specific *nix command line help system, you’ve linked to a web page in the documentation.

The frequency plan is a legal thing - you use the one for your country. Whilst you can pick any region (data centre) you like, the nearest is best, that’s where a LNS is run and you use the gateway server for the region you’ve picked.

Until you have a device operational there’s no point trying to debug the TTIG as it may well be just peachy, just waiting for something to talk to it.

Try not to over think too many of the details or your head will start to hurt, just go with the flow, the rest you will pick up over time.

Ah, good info. My device is not plug-and-play so I’ll be delving into that for a while. Many thanks for getting me moving forward!