Recreate deleted device

I have an application in which I deleted a device. Now I need to add that same device back. However, communication never starts. I see from several forum posts that this is a common problem. I tried to re-register it using the CLI with a new Appkey, but still nothing.
Can somebody help me?



Re-adding a node should work without any issue if you handle it like a new node. So don’t try to recycle the previous AppKey, just add a new node with the same DevEUI and have TTN generate the new AppKey. Then make sure to program the node with the new AppKey (setting the AppEUI to make sure it matches won’t hurt either).
If you perform these steps, what happens? Does your node provide debug output you can check? Do you own a gateway close (but not too close, at least 3 meters away) to the node so you can check if the node transmits the OTAA request?

Is it required that TTN generate the AppKey? When I re-added the device I just changed the last digit in the old key.
Well, nothing happens. The sensor (Elsys ERSCO2) blinks orange which tells me it tries to join the network.
I have to indoor gateways in our offices and when i go to the TTN console and look at traffic and search for the last four digits in the DevEUI, I get nothing.

I also tried resetting the configuration of the sensor and create a new configuration for it. Same result.

Did you have TTN Console already open while the node tried to join? (The gateway Traffic page won’t show anything it received before you opened that page.)

I’m quite sure you should see all valid LoRaWAN packets in the gateways’ Traffic pages in TTN Console, even if TTN does not somehow know the devices. (It also shows packets from other network providers. I don’t expect traffic to be silently hidden from the gateway Traffic page if TTN runs into some error when handling a previously known device.)

I had the console open yes. How long interval is the join request? Also, do I need to check both gateways’ Traffic tab or is one enough?

Between requests? That depends on your device, I guess.

One should suffice, as all gateways in the neighbourhood should receive and forward all valid LoRa radio transmissions they receive. Checking the other as well won’t hurt, of course.

Right. I just wrote a new configuration and rebooted the device. Still nothing. triplechecked the keys too.

Even if the keys don’t match you should see join requests from the device in the gateways traffic page. Do you see any join requests at all? (Lightning arrows)

No. Nothing in the traffic log of (one of the two) gateway(s). I typed the 2 last hex numbers as search criteria, left the screen open, rebooted the device and waited. Nothing.

Just to ask the obvious: was it working before you deleted it? Sounds to me that the device is not transmitting any OTAA Join Request, despite the LED apparently tells you it is. This is then unrelated to any registration with TTN.

Elsys says:

All Elsys sensors are equipped with NFC (Near Field Communication) for easy configuration with an Android phone. With our application “Sensor Settings“, you can change sample rate, data rate, encryption keys, triggers, activation and much more.

That might help.

Last two hex numbers of what? The device address will change on every OTAA attempt so filtering on that will not work.

1 Like

Also, one can filter on Join (disable uplink and downlink by clicking those):

traffic filter

on the EUI that is written on the device.

I will have another go tomorrow when I’m back in the office. I’ll update you on my findings. Thank you very much so far :slight_smile: