Removal of Gateway EUI on TTN

Dear forum members,
Good day! I need assistance urgently as this is my first task in my first job post graduating.

As a jr IoT engineer, I have been working on the Peplink Balance 20X gateway to be registered on The Things Stack Community Edition (TTS CE), which I have registered before for testing (POC) purposes. Upon completing the testing, I deleted the gateway to use it on another LNS platform.

I noticed that I am still not able to get the gateway registered on any other LNS. I suspect the EUI of my Peplink gateway is still being held by the TTS CE and has not been released yet. I even reached out to TTI support and they informed me that I need to seek assistance in the forum.

Could any of you please kindly assist me on how to get it removed from the TTS CE?

I have attached the screenshots of Peplink Gateway EUI and the error of the gateway
already existing in TTS CE. Your assistance is highly appreciated.

Thank you.

Dear @BoRRoZ ,
I read that you have helped similar problems like this before, could you kindly help me out too.

Gateway Exists

1 Like

Per the docs, if it was deleted from TTN then the EUI will available. It’s still in the database on the AU cluster using AS_923_2. So the first thing to do is to see if you can login to the account you used to move it to the new account.

Per forum search on this almost weekly topic, can you check if an alternative ID works - the error message seems a generic - it’s usually more informative.

If you can copy & paste, provide EUI’s, Id’s etc in text so that no one has to try to read it from a screen shot.

There is no connection to any other LNS of any brand, make or location so this isn’t an issue.

When was @BoRRoZ post on the subject? And when did he last access the forum?

@thiveya Rob is no longer active on the forum, and has not been a Mod for several years now, so dont expect a response. His last post was back in Jan and he was last seen back in May - which was when he used the Forum PM facilities to reached out to me to say that sadly his personal circumstances meant he was dis-engaging permanently and would likely delete his account ‘soon’ (though not done yet I note).

Dear Nick,
Good day to you! Thank you so much for helping me out, I really appreciate it.

I have tried the method you mentioned, which is to try it in a new account, unfortunately I’m getting the same error Nick. Below are the error details I have been getting:-

“code”: 6,
“message”: “error:pkg/util/store:id_taken (ID already taken, choose a different one and try again)”,
“details”: [
@type”: “”,
“namespace”: “pkg/util/store”,
“name”: “id_taken”,
“message_format”: “ID already taken, choose a different one and try again”,
“correlation_id”: “a9c9936df15747a1a14547c468f982c4”,
“cause”: {
“namespace”: “pkg/util/store”,
“name”: “already_exists”,
“message_format”: “already exists”,
“correlation_id”: “345b0beea3fa4ae9aa210465b792c0a7”,
“code”: 6
“code”: 6

And I realize you have mentioned about the database still being on the AU cluster, could you please guide me on how I could get it completely removed from the AU cluster, Nick? I have pasted the EUI here in case it would come in handy for you to help me out.
Gateway EUI: 0016C001F10E348A
Gateway ID: eui-0016c001f10e348a

Please do let me know if you need any more details that can be of use to you. Thanks in advance Nick! :slight_smile:

Could you please please please please search for this message on the forum and check the suggested solution? This question comes up almost every week.

In the TTN console ID is a freely chosen field, that has no relation to the gateway EUI apart from it being populated with ‘eui-EUI’ by default. You can use anything you want, like this-is-my-gateway-located-at-wherever (choose something meaningful to make life easier).

I never said account - I said ID, as in gateway ID - the message you originally posted just doesn’t ring true so it would be useful for you try adding the gateway with a different ID.

As @kersing mentions, the error message says ID already taken and you’ve listed the gateway ID so we know you know what a Gateway ID is …

I think this is a drink less coffee situation.

Any & all logs need to be formatted with </> for readability please.

Dear @kersing and @descartes,

Thank you so much for your feedback, it was a coffee situation. :slight_smile:

I got mixed up between gateway EUI vs gateway ID. Issue is resolved now.

Thank you.