REST Api 404 Errors

Hi, I’m getting started with the rest api on our TTI Tenant. We hope to use the api for provisioning.

I used the Gs (Retrieve gateway connection statistics) as my first endpoint, and it worked! I thought I was off to the races, but I am having a terrible time getting the other endpoints to respond.

I am using an API Key will full access for A&A.

To sort prove that is working I attached a screenshot of a Gs.

I have tried all the the following which come back with 404 errors like the uri is incorrect. I have to be missing something very basic. I apologize for any rookie errors, I’m sure if someone can show me what I’m missing I’ll be good.

Please post screenshots when you can post the text. Screenshots are a lot harder to read (especially when using a dark theme with dark lettering) and are not searchable.

Thanks, I posted the uris in text above the picture. I’m sorry the screenshots are hard to read, I’ll try to fix that.

Here is the response to: (same error for all uris above).

Also easy to find, but here is a link the rest api docs: Routes | The Things Stack for LoRaWAN

    "message": "not found",
    "details": [
            "namespace": "proxy",
            "attributes": {
                "flags": "NR",
                "cluster": ""
            "correlation_id": "e143a471-e13a-4498-adeb-29d784649c65",
            "name": "404_route_not_found",
            "message_format": "not found",
            "@type": ""

I seem to have found a solution that I hope will be useful to anyone else in North America getting started with the http client.

In the troubleshooting section mention is made that " the Identity Server component of The Things Stack is hosted only in the eu1 cluster"

So the base uri changes based on what you are doing, such as

As a suggestion if anyone from TTS would see this, it would be nice to mention this upfront in the documents. Perhaps even mention what calls use the identify server for ease-of use. Just a thought.

Unlikely to occur unless you post an issue on GitHub - that’s the procedure.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.