RisingHF gateway shows connected, however TTN console indicates that gateway was not activated

So, I’m tring to connect a RisingHF Gateway with RaspberryPi and after several attempts I’v managed to make the device communicate, and I know this since I’m being able to see the comm messages being shown and the tcpdump command show all the traffic.
BUT, TTN Console does not show my gateway as active.
So, is there any specific configuration anywhere to activate it?

The packet_forwarder version is 2.2.0

1 Like

Have you registered it?

https://console.thethingsnetwork.org/gateways/register

Yes, off corse.
Otherwise I wouldn’t even see it as ‘not activated’.

I’m using TTN’s packet_forwarder fork - https://github.com/TheThingsNetwork/packet_forwarder - with the RisingHF and didn’t need anything special.

Did you use the “bridge” method when registering it and does “Gateway EUI” match what the gateway shows?

When I try to use TheThingsNetwork fork, it shows the version 2.1 for the packet fowarder and the message that it could’nt initialize the concentrator.
Only with the versions 2.2.0 (Semtech Packet Forwarder) and the version 3.1.0 (Lora-net fork) I can initialize the concentrator and connect to TTN, but the 3.10 is not supported, so I’m using the Semtech one, with the configuration files altered to point for the TTN network.

And yes, I registered as bridge gateway.

That could explain it, I’m using poly_pkt_fwd which only exists on the TTN fork. Not sure if TTN currently works with the standard lora_pkt_fwd in 2.2.0, maybe not.

I don’t have any problem using the TTN version with RisingHF though, so suggest a re-check of your configuration especially that you are powering it correctly and you’ve set the correct RESET pin in the initialisation script - those tend to be the most common ‘can’t start concentrator’ issues.

Well, I’ve tried the poly one because the configuration file appeared to be way more complete, but it also couldn’t activate the concentrator. And since the script to reset the concentrator work for the standard packet_forward, I assume it shoud work for the poly too…

Anyway, from yesterday for today the status changed. it says now that its active but not authenticated. I’ve followed a fórum topic and added the “servers”: [{…}] instruction to my configuration file, but still not authenticated…

That’s all fine then, there isn’t any public way to authenticate the gateways yet - TTN is working on it.

It doesn’t affect communication in any way.

Hi ,I have bought RHF0M301 and successfully connected to LORIOT but have problem connecting to the TTN network.
Can you please help me with the steps .

@ prudhvi

yes we know you have a question… be patient

I’m having this same issue.

Hi, I’ve also had a lot of trouble getting it up and running. Could you please explain your steps to get the RisingHF gateway connected to TTN?

Did you solve your problem @brady_aiello?

No, I have not.

Has the problem resolved @brady_aiello

Yes! Thank you!

Hi, may i know how you solved the problem? Cause i also stuck to connect the gateway to the ttn, it almost 2 month please help me.

You have resurrected a 4 year old thread. TTN has gone through a major transition from V2 to TTS(CE) aka V3 in that time. What problem(s) are your seeing, what have your done, how have you configured your equipment, what software are you using, which TTN cluster and freq plan are you connecting to and using, what do local GW logs show, etc…details details… we cant guess :wink: