RN2903 AU firmware


(Radhoo) #21

I did. They seem to be waiting for something on their turn too. I should have received something, at least this is what they said, so all they could do was to ping again.

I also reached directly to local Microchip RO contacts / friends as high as the CEO. Seems this (the AU915) is handled in Australia and no reply comes from there.

My customer even called Joseph, his number can be found online, who instead of sending over the HEX file instructed to contact Microchip RO again, or offered his assistance in doing the upgrade. He also added:
“In the future we hope to have an Australian module … in which your developer in Romania could order an Australian version (June 2018 we hope). Part No RN2903A-I/RMSA10 : Also someone with experience will need to configure the product to the local Australian LoRaWAN network it is connected to…”

This is such a big waste of time.


#22

Wow, that sucks! I’ve got a bunch of RN2903 modules that I bought ages ago and that I really need to get working for AU now that I finally have my TTN gateways. Hopefully I don’t have to go through this much crap to get it sorted out.


#24

Just a quick update to say I got in touch with Joseph at Microchip, and he was incredibly helpful. After a long chat on the phone, I made up a pogo pin adapter and had my TTN Uno up and running in minutes. Also updated some of the original RN2903-095 modules I had. It does help that I am an Aussie embedded developer that alreadyt does a lot of work with Microchip parts.

If anyone is in Sydney and needs a module reprogramed, contact me and I will try help you out - but I can’t share the files.

Unfortunately I had an early version of the LoRa Mote board that updated fine via USB, but it soon died (overheated) after I started configuring it with keys and channel mask. Not sure what happened, but I don’t think it was related to the firmware. I’ve got some of the newer revision Motes on the way from the USA, along with some of the newer RN2903A modules.

I’ve also got some Sodaq LoRaONE boards, and Joseph warned me not to program them via the pogo pins. The RESET line that carries programming voltage is directly connected to one of the Atmel mcu GPIOs, and the high voltage on that pin can kill the mcu. We need to use the firmware updater tool from Sodaq for that, but the include files must be updated to use this newer AU firmware.

It is worth noting that if you can’t do the beta/NDA thing, the Sodaq updater does include an earlier release of the AU firmware that may tide you over till there is a public release.


TTN Uno - RN2903 firmware upgrade
(Craig) #25

I noticed the RN2903A-I/RMSA103 had turned up in Microchip Direct, but I didn’t know what it was. The datasheet made no mention of variant RMSA103. Microchip Direct call it the South America version. As I understand it, Brazil & Peru share the same Frequency plan - 915 - 928 MHz


#26

Yes, Joseph from Microchip mentioned that this “SA” model will be the one that also supports Australia.

I imagine there is a big “opportunity” in South America that has driven this as an orderable part, although not yet available. Even the RN2903 datasheet isn’t available currently on the Microchip website, so I’m guessing it is still in a state of flux.


(Mauricio Jancic) #27

Hello Everyone,
The RN2903A-I/RMSA103 has a firmware that supports AU915 as per the regional spec v1.0.2 RevA. This version should be the one that has DR0 with SF10.
We are not using later versions of AU915 yet because it uses SF12 and that would exceed the dewelling time of 400ms which is standard in most countries in LATAM.

AU915 has been chosen as the de-facto frequency plan for all the countries south of Mexico due to many of them having restrictions on the 902-915 MHz bands.

RN2903A-I/RMSA103 is undergoing certifications in ANATEL (Brazil) and will be commercially available once we have the certification. 

Should you have any questions about LoRa in LATAM don’t hesitate to contact me.

Kind regards,
Mauricio Jancic
Artimar Ltda.


(Smi) #28

Hi Guys,
can anyone post link to the AU915 version of the firmware to reflash RN2903?
Thanks


(Craig) #29

Now that it is July, is there any update on the AU915 version?


(Junting Zhu) #30

Tried with Sodaq’s firmware and that works pretty good with TTN UNO/NODE.

Hope this may help.


(Helioz) #31

AU firmware is located here:

If using the PICkit 3 to load firmware via ICSP, the PIC inside the RN2903 is a 18LF46K22 (at least on my LoRa Mote board).


(Lachlan Etherton) #32

Here’s the place I found my firmware, and it worked for me. If you download it, the hex is located in Binary > combined