RN2903 AU firmware


(Jmswu) #1

Hi guys

Does anyone have a RN2903 AU firmware, I got two of the RN2903 motes, but they come with the US firmware.

Cheers

RN2903 Mote
http://www.microchip.com/DevelopmentTools/ProductDetails.aspx?PartNO=DM164139


Extracting Data from TTN to my Server
(Paul Stewart) #2

check with @Maj or @szecso , they should be able to help you out.

cheers
Paul


(Jmswu) #3

Thanks for your reply @Paul_Stewart, I have contacted Microchip, they are going to sort this out for me.

Cheers.


(Inditn) #4

Hi, could you please tellme if microchi has solved it an how? We need the firmware for AU too. Many thanks. Martin


#5

Hi, I opened a support ticket with Microchip like 2 or 3 weeks ago and have not received an answer yet. Has anybody got the firmware from Microchip before?


(Jmswu) #6

Hi @jnavarro @inditn, sorry for the late replay, microchip actually reflash my motes with AU firmware, it's a limited release. The guy told me it's the same as the US one except the shift the frequency.

However, I tested it multitech gateway, and the adapted data rate was not working at the time. I emailed the guy about this and I have not received any reply yet (as of today). We really need the adapted data rate feature.

We are using multitech xDot now. Their support is great.


Lost for options on connecting
(Andrew Maggio) #7

Unfortunately Microchip have still not released their AU firmware yet. We are all waiting patiently (or impatiently) for this to happen and I understand it will still be a while.

Multitech mDot/xDot have had AU firmware available for almost a year now.

ADR is only implemented in EU at the moment, but looks like it's coming soon (hopefully). See https://github.com/TheThingsNetwork/ttn/issues/619.


Helltec board on AUS915
BIG ESP32 / SX127x topic part 1
(ahaw021) #8

mDot's are a great alternative

fairly low learning curve and behave as expected :smiley:

Andrei


#9

For anyone who is waiting for info on how to upgrade the TTN Uno’s RN2903 firmware (e.g. for Aust), the process is pretty simple. No specific hardware is needed - the RN2903 documentation makes it clear the product can be updated via UART i.e.DFU over UART:

  • from the TTN library, load the “Pass Through” sketch to your Uno. This sketch simply passes COM port commands direct to the RN2903 module (which is very handy if you want to send commands to manually set your LoraWAN parameters)
  • from the Console, check the current board version e.g. sys get ver (which on the TTN Uno will likely return 0.9.5)
  • then download the MicroChip Java Updater program ( from Microchip or http://www.virtualbreadboard.com/download/LoRaDevelopmentGUI_v1.0BetaJC.zip?)
  • run the Java Updater and select Scan Com Ports so it detects your board
  • select the Board and activate the DFU (Device Firmware Update) tab
  • use the Browse function to locate and select your new firmware
  • run Update Firmware
  • if after the update you see “f f” activate the “Bootloader” checkbox and run it again
  • cycle the power and check the unit is now reporting the new firmware
    If you want to test the process, you can update your RN2903 to version 1.0.3 which is available for download from Microchip (Follow Software link in Documentation section on http://www.microchip.com/wwwproducts/en/RN2903)
    I am waiting on confirmation as to whether the AU firmware is now available to the public (it is being used in MDots) and will post an update on the exact version and the upload link once I have it…

Getting Badgerboard to work with TTN
#10

Just a quick update for anyone following this discussion. The AU915 firmware for the RN2903 is still in Beta and should be formally released in Q1 of 2018. It is currently only in the hands of a limited number of testers. In the mean time, if you want to update your nodes, please contact MicroChip’s Aust Field Sales Engineer by email to Joseph.Goldburg@microchip.com to discuss your project and organise a copy. I will run the upgrade next week and post an update on the results. An AS923 release will also be forthcoming.


#11

After receiving the RN2903 AU firmware from Joseph of Microchip Aust, I ran the upgrade on the TTN Uno. I can report that the upgrade ran smoothly (this is the Bootloader version so you must select the Bootloader check box on the Java updater) and the Uno is now feeding data happily to my Rising HF Gateway.


(Mmoreira) #12

Hello Peter, Could you please share the firmware you recieved from Microchip?, i need to update my RN2903 firmware for it to work on AU band. Thanks


(Don W) #13

Hi all
As a newbe to LoRa…
Is the AU software required for use in Australia?
(i.e. what is different about it)


(Joey) #14

The 900MHZ RF Band

US 902 -98MHz uplink channel 0 = 902.3MHz
AUS 915 -928MHz… uplink channel 0 = 915.2MHz

Hence channelisation is different


(Radhoo) #15

I also need it, do you have the HEX file? Everything else is in place: https://www.pocketmagic.net/rn2483-rn2903-firmware-upgrade-guide/


(Radhoo) #16

Can anyone help me with the RN2903 AU HEX? I tried contacting Microchip but no answer. I need this asap

Thanks


(Joey) #17

With the limited bandwidth, Joseph can only really support Microchip customers in the Australia and New Zealand regions. Other international customers should contact their local regional Microchip distributor or Microchip at http://www.microchip.com/distributors/SalesHome.aspx


(Radhoo) #18

Thank you Joey, did that already. Hope to have a reply from either parts soon. I only need the HEX. I’m past due the shipping date with a month already.


(Radhoo) #19

Limited bandwidth or not, I don’t think it takes Joseph or anyone else more than 2minutes to send a HEX file.

Sorry, this is just poor support from Microchip, and the people involved are a bit irresponsible. I’m sure there are better alternatives to the RN2903, we’ll probably just change the design and be done with this madness.

I am very disappointed.


(Jac Kersing) #20

Have you logged an official support case with Microchip? Last time I did for (EU) firmware I got a copy within 2 days.