Running ic880a-gateway -> git error

I’m trying to install a Gateway based on RAK831+Rasperry Pi3+ and adapter board with GPS. I successfully configured internet access, enabled SPI and cloned IC880a-gateway.
Unfortunately, when I run sudo ./install spi, I get the following error after providing the registration data:

The Things Network Gateway installer
Version spi
Updating installer files…
Already up-to-date.
Gateway configuration:
Detected EUI B827EBFFFE****** from wlan0
Do you want to use remote settings file? [y/N]n
Host name [ttn-gateway]:ttn-gateway
Descriptive name [ttn-ic880a]:uio-001-rak831
Contact email: jd********
Latitude [0]: -0.17266803
Longitude [0]: -76.47357637
Altitude [0]: 2800
/opt/ttn-gateway /home/pi/ic880a-gateway
/opt/ttn-gateway/lora_gateway /opt/ttn-gateway /home/pi/ic880a-gateway
error: pathspec ‘legacy’ did not match any file(s) known to git.

The same error (error: pathspec ‘legacy’ did not match any file(s) known to git.
) appears if I select “yes” in the setting file option.

I appreciate if someone has had the same error and found a solution for it.
Thanks in advance!

some (working!) tutorials

and these are the specialised topics for your set up

( is GIT installed ? sudo apt-get install git )

Thanks BoRRoZ for your reply. I’m using the pre-installed Raspbian 16GB SD card I got with the gateway, maybe there is something not working correctly with it. I have installed git and it is functional (at least with other packages).
As per your suggestion, I will create a new SD from scratch following the steps of the tutorials you provided and update the post with the results once I have done it.

1 Like

I made a Raspbian image from scratch and the error of is not longer present… and the Gateway work now. Conclusion: if you find problems setting up the ic880a-gateway service using the supplied image from RAK Wireless, just do a new one following the steps described in the tutorials. Just bare in mind that on those tutorials is not mentioned that the reset pin must be changed from 25 to 17 in the file.

good news ! :grinning:
which tutorial did you finally use ?

Hi @BoRRoZ, I used this: . What is missing is the configuration of the reset pin from 25 to 17, but I don’t know if this an universal change for all RAK831 or just the ones with the interface board with GPS module.

1 Like

Hi! I had the same issues today with some new Rak831s that we just got, so I wrote a short guide on configuring the Rak831 + RPi and a little utility program to quickly replace configurations. Check the Gateway conf section at for the guide.

The program is really trivial: it just copies global_conf.json for a desired band and overwrites local_conf.json options with the given flags, but it’s quite handy if you need to configure a bunch of gateways with some defaults like I did. A more complete program to handle everything from raspi-config to complete installation would be better, but hey, it’s something for now.


I mentioned before that the Gateway was working, but that was not true. I was lost for several hours as I got a few messages from my nodes, but after some time communication stopped. I noticed that in the TTN gateway traffic I received a few messages in the 867MHz band with a very low rssi although the node/gateway were a few cm away. My local configuration should be US915 (somehow the gateway captured 915 messages when it was configured in 867).

I solved the problem by changing global_config.json file in /opt/ttn-gateway/bin with the contents of file US-global_config.json ( A similar problem is found here RAK831 config issue?

Disclaimer: I don’t know if making this change affects something else (i’m new with this stuff), so any advice from the community is highly appreciated.