Self-hosted TTS V3 Open Source and AWS IoT Default Integration

I have a self-hosted TTS V3 Open Source in AWS EC2. Self-generated Certs. With default EC2 domain name ( It seems to work fine. I can create users, create applications, create gateways, create devices. My Basic Station gateway is connected and my devices are landing data into TTS. Now I am trying to install the AWS IoT Default Integration, but the CloudFormation fails as follows:

Received response status [FAILED] from custom resource. Message returned: Dial Application Server at "ttn-v3-as:///": connection error: desc = "transport: error while dialing: dial tcp: lookup []( no such host"

That is from installing the Enterprise edition of the CloudFormation. I have successfully installed the Community edition of the CloudFormation for my Community account and application in the past. So I hacked that template to point to and tried to install that. Then I hit this error:

sending status failed: Dial Application Server at "ttn-v3-as:///": context deadline exceeded

I am uncertain what’s going on. It seems the error is related to service discovery and DNS SRV records: Networking | The Things Stack for LoRaWAN

My stack config file has no elements for gRPC configuration: General Options | The Things Stack for LoRaWAN

I suspect that the configuration documentation possibly neglects to cover this part of the setup for self-hosted solutions. And that even if it did, I perhaps can’t do it unless I own the domain. Can anyone point me in the right direction?

The AWS IoT Integration is not supported in The Things Stack Open Source. For self-hosted setups, it is only available with The Things Stack Enterprise as documented. We did make the integration available in the hosted offerings: Community Edition and Cloud.

Thanks @johan .

Hey, I’m still getting the same error. I am on hosted, community version. As I last read, it was supported. How can i find the tenant and cluster ids so I can manually see if they exist and pint it to a dns problem from the azure side? Or is there a new version of the template?

The tenant for TTN is TTN.

What do you mean by cluster ids?

If you can find the information, then it exists - it would be rather meta to find the information and then test to see if it exists and find it does not exist.

Have you referenced the docs - they lag behind any changes by about 12 hours, so can be considered up to date. If it has instructions there, we can reasonably expect them to work.