SenseCAP M1 Gateway to TTN

I’ve just been through this and got it working - ask me anything.
Things I found:
These PIN numbers worked for me:

SX1302_RESET_PIN=17     # SX1302 reset
SX1302_POWER_EN_PIN=18  # SX1302 power enable
SX1261_RESET_PIN=5     # SX1261 reset (LBT / Spectral Scan)
AD5338R_RESET_PIN=13    # AD5338R reset (full-duplex CN490 reference design)

I didn’t see this step in the instructions on the Github page but it seemed to be required:

./ start

The strangest thing was that I decided to copy the correct json config file to a new file just called “global_conf” and when I ran the packet forwarded script with this as the filename it sprang into life.

Anyway, as I say - happy to help as this thread is quite stale now.


1 Like

Just remembered - I also added a random EUI generated by a web page I found. I added this to both the TTN portal and to the config file near the end.

The reset pins match the ones which work for me. So I assume that the different pins mentioned by others are for different PI hats. My hat looks like the one on the manufacturer’s site.

Did you also get the error “TLS server certificate verification failed”? I had to download up-to-date certificates into

Unfortunately, I haven’t written down all the steps necessary to get it working :frowning: