Single Channel Gateway part 2


#87

http://www.anarduino.com/product.jsp

no I've made a mistake.. these modules don't come with a 1276 :roll_eyes:

maybe this one ?


(Neliz) #88

Hi people,

Question (I am a bit of a newby):

I just have installed https://github.com/tftelkamp/single_chan_pkt_fwd on my Raspberry Pi 2 with an adafruit RFM95w unit connected to it.
I have changed the server to the ttn eu server( 52.169.76.203 ).

After running the programm on my Pi I receiver:

pi@raspberrypi:~/single_chan_pkt_fwd-master $ ./single_chan_pkt_fwd
SX1276 detected, starting.
Gateway ID: 00:00:00:ff:ff:00:00:00
Listening at SF7 on 868.100000 Mhz.


stat update: {"stat":{"time":"2017-09-01 14:54:34 GMT","lati":52.16229,"long":4. 49891,"alti":0,"rxnb":0,"rxok":0,"rxfw":0,"ackr":0.0,"dwnb":0,"txnb":0,"pfrm":"S ingle Channel Gateway","mail":"n.vanetten@thingstechnology.nl","desc":"TestThing "}}

When I try to register my gateway id (as forwarder) under ID : 00:00:00:ff:ff:00:00:00. I receive a message at the register page of TTN that there is allready a device registered under this id.

Anyone has a clue how this can be and how I can solve this?

Thanks in advance!


(Arjan) #89

That's not okay for a unique ID.

See https://www.thethingsnetwork.org/forum/t/some-help-with-eui-for-wifi-only-raspberry-pi-single-channel-gateway/6720/9 (and previous and subsequent posts about eth0 in that topic).


#95

Compiling the 'Things4U' ESP8266 Single Channel Gateway v4 gives an error message. How to fix?

Hardware used:
* RFM95W adapter board (HopeRF RFM95W adapter)
* NodeMCU v1.0 ESP8266 board (ESP-12E 4MB flash)

Software used:
Things4U ESP8266 Single Channel Gateway v4.0.8a (Things4U ESP-sc-gway v4)

Downloading and compiling the software 'as is' gives the following error message:
"ld.exe: firmware.elf section .text' will not fit in regioniram1_0_seg'"
It appears that the software does not fit because too large.

I tried to disable the 'gatewaynode' feature in ESP-sc-gway.h (default enabled) hoping it would make the code footprint smaller but this did not solve the issue.

// Defines whether the gateway will also report sensor/status value on MQTT
#define GATEWAYNODE 0

I similarly tried to disable the 'UDP gateway management' feature (default enabled, not Lora compliant) but this also did not solve the issue.
Is this UDP management interface documented somewhere?

// Define whether we want to manage the gateway over UDP ... NOT LoRa and NOT LoRa Gateway spec compliant. 
#define GATEWAYMGT 0

Disabling the WifiManager in ESP-sc-gway.h (default enabled) did solve the issue (compiles successfully) but this also disables the WifiManager feature.

// Allows configuration through WifiManager AP setup. Must be 0 or 1					
#define WIFIMANAGER 0

It appears unusual that the software would not compile with it's default configuration.
How to compile successfully with WifiManager enabled?


(Jprttn) #96

Hello,
I am trying to use the same software (things4u 4.0.8a) with Dragino LoRa Bee which seems to be very similar to your setup.
Arduino: 1.8.2
board: nodeMCU 1.0, 80 Mhz, (4M / 3M spiffs or 4M / 1M spiffs - does not matter)
Programmer: "AVRISP mkII"

if WIFIMANAGER is set to "1" then I get "collect2.exe: error: ld returned 1 exit status"

I need to switch off WIFIMANAGER, GATEWAYNODE and GATEWAYMGT to compile correctly.

That leaves WWW server working but the Access Point mode is disabled (i tried to shorten the
MAX_STAT table but that didn't help either).

What is the value of "#define PINOUT" in your setup?
What tools have you used to solder RFM95W on your HopeRF (XBee) breakout board?
Does you gateway work in a stable way?


(Jprttn) #97

Very nice module but it cannot be programmed as a gateway directly (no WiFi).
As far as I understand not all Ra-02 pins are not available on the header, for example DIO0 <-> D7 (IRQ) seems to be absent...please correct me if I am wrong.

PS. I ordered it anyway...


(Gume) #98

Hi,
I have a single channel GW made from a Wemos ESP8266 device. Once it worked, but now it does not. The GW receives the LoRa frame and creates the UDP packet, however TTN does not receive it. Is the TTN port still available? What is the correct address/port? (Somewhere I read that it is discounted. Is that true?)


(Gry Kyo) #99

I am not experienced but have you reset the frame counter for your node in your console? If the frame count is < last frame count displayed in the node console overview TTN ignores. Somebody may wish to confirm this and also that this is in ABP node configuration as a security strategy?

Garry


(Sequitur) #100

I ordered mine from bsfrance: works like a charm! I’m using the IBM lmic library which I had to strip a bit to get it into 2K of programming space. Using ABD to connect with The Things Network. The board is 100% compatible with the Adafruit Feather Lora board, which costs 3 times more. Great value for just under 15 Euro’s!


#101

yes it works great… but I don’t get it under one mA in sleep… did you ?


(Sequitur) #102

I have not yet tried that: just received the board last saturday…


#103

I used my regular kitchen oven lately to solder an ESP-WROOM-32 module onto an adapter board and it went very well. All without using a fancy reflow oven (pins were soldered later manually).

ESP-WROOM-32 with Adapter 600x478


(Jprttn) #104

It looks very, very neat. I will try it myself just for the fun of it.
Can anyone point me to a breakout board for sx1276 module?
I have found an sx1278 breakout board on tindie which may work for sx1276 (or not?):


Apart from that I cannot find anything…


#105

@mw12554 Maarten can you comment on this (above):

https://www.thethingsnetwork.org/forum/t/single-channel-gateway-part-2/5999/95?u=bluejedi


#106

With all respect for the work done, but committing code that breaks is bad practice.

Both single channel gateway implementations below give errors during compilation in Arduino IDE v1.8.4.
(And even more issues in PlatformIO but latter probably due to my limited PlatformIO experience.)

https://github.com/things4u/ESP-1ch-Gateway-v3.0 and
https://github.com/things4u/ESP-1ch-Gateway-v4.0


#107

I used a custom pin configuration because I wanted to add an SSD1306 OLED (I2C) display for showing status messages. That did not yet workout however because I ran out of of available pins/ports.

Hallard’s board connects RFM95W’s DIO0, DIO1 and DIO2 all to a single ESP8266 GPIO port (with diodes, using a separate diode per DIOx port). I don’t have Hallard’s board but I may give that a try myself. I read somewhere (can’t remember) that this is not an ideal situation however.

Andres Spiess has a version of the software that already includes support for SSD1306 display, but is based on the much older things4u v1.0 version: https://github.com/SensorsIot/ESP-1ch-Gateway

Hardware used:

(I did solder the RFM95W module onto the adapter board manually.)

Update:
I succeeded to get both version 3 and 4 of things4u ESP single channel gateway working with PlatformIO.
Including the ‘Hallard’ pinout. Connecting DIO0 and DIO1 via diodes to a single GPIO port, which left D1 and D2 free for the display.


(Arwed) #108

Hello,
while trying to build a SC gateway for development purposes only, I encountered an issue when connecting an ESP8266 to an RFM95W with the following software: https://github.com/things4u/ESP-1ch-Gateway-v4.0
I followed the readme and chose a “COMRESULT” pcb layout.

My connections are the following:

RFM95W ------> ESP8266
DIO 0/1/2 from RFM to D1/D2/D3 esp
G from RFM to G esp
SCKfrom RFM to D5 esp
miso from RFM to D6 esp
mosi from RFM to D7 esp
NSS from RFM to D8 esp
3.3V from 3.3V

The problem is that it can receive any packet (and forward to TTN), but is unable to send anything back (so OTAA will fail).
Can anybody spot my flaw? Maybe the RFM95W is different to other LoRa-modules available?

Cheers,
Arwed


(Marssystems) #109

In order to have the gateway send downlink messages on the pre-set spreading factor and on the default frequency, you have to set the _STRICT_1Ch parameter to 1. Note that when it is not set to 1, the gateway will respond to downlink requests with the frequency and spreading factor set by the backend server. And at the moment TTN responds to downlink messages for SF9-SF12 in the RX2 timeslot and with frequency 869.525MHz and on SF12 (according to the LoRa standard when sending in the RX2 timeslot).


(Arjan) #110

…but for LMiC, disabling uplink frequencies might not affect the downlink frequencies, in which case you need to ensure the frequencies as commanded by TTN are used by the node, just as usual in LoRaWAN.


(Arwed) #111

Hey,
I can follow your thoughts but unfortunately it doesn’t make a difference with my gateway. Still searching for the problem

Cheers,
Arwed