Sodaq Explorer Join Request Denied and Accepted after few minutes


I am new on this and hope someone can help me to solve this issue.

I am following the LoRa Academy course of Semtech and using a Sodaq explorer board and trying to connect it to nearby gateway. I am using sketch sendOTAA. On the serial monitor I get message repeatedly:
Sending: mac join otaa
Join not accepted: denied
Check your coverage, keys and backend status.

The request can be seen in the TTN live data console, and after several minutes (10-20) the request is accepted. After this it keeps working normally.

Is there anything i can do to fix this issue?

I am located in Delft
While adding my device i selected the following settings: MAC v 1.0.2
PHY V 1.0,2 REV B and the reccomended band for europe 863-870 Mhz (SF9 for Rx2)


The network does not tell you that an OTAA is unsuccessful, there is simply no response when there is something wrong with the request. The firmware is incorrectly announcing that the request is ‘denied’.

More likely, you have a problem with coverage / signal strength.
So either the join request is not heard by the network, or the join accept is not heard by the device.
Eventually the round-trip is successful, so your keys are OK.

Have a look at the RSSI and SNR values, if RSSI is close to -120 dB your connection is very marginal.
Check your device antenna, it should be an 868 MHz antenna (not some random wifi antenna). The antenna should point up. Possibly you are simply too far away from the gateway, or positioned in a bad way (e.g. large mass of metal between you and the gateway).

Thanks for clarifying this.

Since i can see the join request at TTN console and the RSSI was sometimes close to -120, i think the end node does not heard the reply from the network.

I tried taking our the board outside my window and the connection was in few tens of seconds.

1 Like

Is there a way i can set the SF to 8 or 9 so i can send and receive message easier?
Right now i am trying to send down link messages but it takes several minutes to received properly.

For typical nodes (class A) downlinks can only be sent in response to an uplink - you put in a request to send a dowlink, but it sits waiting until the node next uplinks.

My issue is different. I have schedule the downlink message; however, it is not received by my end node after several uplink message have been sent (several minutes). So i guess it is related to the marginal link connection to the gateway. Currently, it is using SF7BW125 RSSI -120 SRN -2.8.

So i wonder if it possible to set an SF of 8 or 9 to improve the communication.


If you have ADR enabled in the node’s own configuration (not its registration with TTN) it should adjust automatically.

If you don’t have ADR enabled, you’ll have to figure out how to configure your node to use a different spreading factor - it’s not a radio command you can send to it, you’d have to do something locally.

Thanks. I know what you mean but i am just starting and no idea how to check or implemented.

But now i have a better idea of what to check.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.