[solved]RN2483 - Problems after wakeup from sleep

i am using RN2483 module (57600 baud) and put it into sleep mode with command sys sleep 36000000 (sleep for 10 hours). After 3 minutes i want to wake the module up with sending a break with 0x55.
(here i put the Rx line to low for 300µs followed by transmitting 0x55). The module respond with ok and all seems good. Then i transmitt a few data to ttn - this also works fine.

But after transmitting, i put the module again in sleep mode but this doesnt work. It seems that the module hanged. Enclosed the image of waking up procedure.

What is your firmware version ?
RN2483 or RN2483A ?

It is RN2483A

‘hangs’ after the second ’ sys sleep 36000000 ?

No, i send a break condition before time of 36000000ms is over. Wakeup is ok. But if i want to put the module again in sleep mode it hangs.

straight after transmitting… no delay ? and ’ mac tx cnf ?

after transmitting (mac tx uncfn), i am waiting 200ms. Transmission is successfully reveived by ttn.

a mac resume after forced waking up ?

no, i did not send the command mac resume. Is this command necessary?

I’m not 100% sure (it’s a while that I worked with this module) but it could be resetting the timer(s)
I assume you’ve installed the latest firmware

I tried to insert a resume after wake up and before new sleep call, but the behavior is the same.

ok sorry… :thinking:

and the uart is available ‘normally’ … how is the RN2483A connected / communicate ?
instead of sending more data, can you send a non Tx command ?

Yes, i communicate with an STM32 MCU over UART and also over USB/UART with the PC. No problem as long the module is not in sleep mode

Here is my code for waking up the modul:

void wakeupRN2483(void)
MX_USART2_UART_Init_28800(); // 28800 Baud
/********************** RN2483 wake up *********************/
if (HAL_UART_Transmit(&huart2, byte080, 1, 50) != HAL_OK) // low signal 226µs at least

  MX_USART2_UART_Init_57600();			// 57600 Baud


  if (HAL_UART_Transmit(&huart2, byte55, 1, 50) != HAL_OK)		// send 0x55


After wakeup and during sending next sleep command i got an strange answer like the scope image shows…2019-10-08_21h34_21

To summarize the whole thing again:

  1. Sending sensor data to ttn server (every 3 minutes) over hours -> OK
  2. Put device in sleep mode with sys sleep 864000000 -> OK, current consumption -> OK
  3. Wake up from sleep mode with pull the Rx line to low for 300µs (57600 baud) and sending 0x55 for auto baud rate detection -> OK
  4. Sending new sensor data to ttn server -> OK
  5. Put device in sleep mode with sys sleep 864000000 again -> NOT OK - the module response with FE 1E 1E 1E E6 … during command sleep is sending (see scope image above):disappointed_relieved:

The modules version is RN2483 1.0.1 Dec 15 2015 09:38:09

that’s one of the first production modules (with hardware faults) … latest is the rn2483A with 1.05

old topic

ok, that means i can throw it in the waste basket?

I don’t know if this IS related to your problem ( I have this module somewhere, I could try to emulate (tomorrow).

did you try to start all over ?.. a sys factoryRESET (the famous helpdesk tip… switch off/on :upside_down_face: ) / flash newer firmware

  • found the comm. toolshiny now the old module itself


I can try a factory reset tomorrow…

1 Like