[solved] Sandbox LoRaGo PORT Gateway on resin.io, ResetPinNo. needet


(Jens) #1

Hi

This week i got an LoRaGo PORT Gateway.

I wana run it with resin.io. But for correct configuration i need the Pinnumber for reset.

Could it be Pin 12 like this pic show : The LIBRARY basement part 4 .

There was a backplane between RasPi and the GW-PCB.

Someone runs the GW under resin.io and can help?

Regards


#2

That’s pin 12 of the concentrator. Their website seems to suggest they will supply a schematic once you have bought it, if you have a schematic of the backplane, I should be able to work out the raspberry pin pin number. Then assuming that your using jpmeigers resin image, you can set an environement variable for: GW_RESET_PIN to the appropiate pin.


(Jens) #3

Hello

You mean that? : http://sandboxelectronics.com/?p=2669#Resources

What i found is that installationscription for TTN with TTN-ZH.


(Jens) #4

Hmmmm…
When they describe to setup an IMST 880a,… What is the Standartresetpin there? With or without an Backplane?


(Jac Kersing) #5

Have you tried with the default? Skimming the instructions I did not see anything about changing the Zurich script which I think is set up for the default. (Default does not require setting it)


(Jens) #6

Hello @kersing

Thanks for reply. But is this the way with resin.io?

Regards


(Jens) #7

Ahhhhhhhhhhhhhhh! I think i have it!

Pin 22 !

Find it here! :smile:


(Jac Kersing) #8

Yes, that is why I suggested it.


(Jens) #9

Check!

GW runs! and is online :tada:

@jpmeijers
Needed GW-Resetpin for the Sandbox LoRaGo PORT Gateway is Pin 22


(Jens) #10

@kersing
Btw.: GPS is running too! (/dev/ttyAMA0)

Have a nice day :smile:


#11

I ordered myself one of these LoRaGo PORTs. I can confirm that the default reset pin (22) is the correct one for this board. I however do get that it takes a few tries before the concentrator successfully starts. I also had to bring the SPI speed down a bit using:
SPI_SPEED = 1000000

Regarding the LoRaGo PORT kit, I am impressed by how easy it is to plug everything together and on top of a raspberry pi. I was even able to reuse an existing Pi that had a Linklabs shield plugged on top of it.

One issue that I encountered was that the u.FL to SMA cable that I received was not the correct type. I got a u.FL to SMA-R (reverse polarity) cable, and the antenna is SMA. So the antenna can not be connected to the board. The antenna itself is also not that great at 868MHz. So if you are planning to get one of these boards, order your own u.FL cable and a proper antenna.


(Jens) #12

Hello @jpmeijers

Hmmmmm… My µFL to SMA + Antenna was correct.

But an issue for me, i contact Sandbox Electronics and ask, what type of module was on PCB? Answer: SX1308. Not for outdooruse. :confused:

Regards


#13

The number of times I’m getting the “ERROR: [main] failed to start the concentrator” messages are increasing. In the meantime util_spi_stress -t 4 runs without an issue. This is with the Zurich setup according to the official LoRaGo PORT documentation.

I’m confused why the SPI test is fine, but the concentrator does not want to start. I’ve even tried multiple Raspberry Pi 3’s.


(Jens) #14

@jpmeijers
Start a new thread, with own/other topic?

Make it easier to find. :slight_smile:

Greets