[solved] TTIG setup problems

I’ve got a new Things Network Indoor Gateway (from the excellent thingsconference on tour Reading in fact), it appears to be sending data over my wifi network but I have a rapid green flashing led which I believe suggests it can’t connect to LNS server. I’ve registered the EUI with my TTN account.

Additionally I couldn’t get the indoor gateway to associate with an old SKY broadband ap/router – i suspect that could be an ESP8622 related problem (I’m just ignoring this for now and using my main ap).

Finally apologies if there is an existing topic for this, but I did look around but anything else seemed to be closed or merged into a huge topic.

Hi Olx,

right now I have the same issue. It keeps blinking fast in green. However the Access Point says “Device Connected” and the management page of the access point says ~100kByte transmitted but only ~400 Byte received. So something is strange here…

I’m facing something very similar I believe. I bought a TTIG-915 unit way back in March but I only recently got around to trying to set it up. I got it on the WiFi, registered the GW in TTN, but it refuses to connect the CUPS server I think. It just keeps fast blinking green and then occasionally goes to the red/green flash.

I went to my router and tcpdumped the traffic. It does a DNS lookup for “mh.sm.tc” and then tries to connect to the returned IP on port 7007 but it looks like nothing is listening on the server side.

I’ve tried a “curl -Iv https://mh.sm.tc:7007/” from a few servers around the internet and the CUPs server just seems down to me.

I’ve searched around the forums and saw some TTIG debug logs that mentioned “s2.sm.tc” and I even tried to do a DNS override on my network to force “mh.sm.tc” to a “s2” IP address and that got further, but did not ultimately work. https://s2.sm.tc:7007/ does seem to have a server listening at least.

Maybe we have an old firmware and they have moved the CUPS server infrastructure or something? That is the only thing that I can think of.


Well… this is at least a bit of information and more important: debugging information. Thank you for your work @quietfiber .

Big question is of course: How to continue from here? Any ideas?

I was hoping for some official input from someone from the TTN given this is a commercial product. – If there’s any docs on what the server should return we could setup a clone and poison our DNSs to resolve to the clone (depending on how well it does certificate checking for the https). Equally if TTN has paid smtc to provide service then TTN should be able to kick the manufacturer.

I was hoping using the TTIG would be quicker than building my own gateways!

Meanwhile my TTIG is online, shows as connected and also received a few packets. So maybe yours is working now as well?

1 Like

Yes, I’d just noticed it was online – came to post here and see that you’ve found the same. Presumably someone has poked something at the other end.


Hahaha, yeah mine is online too and mh.sm.tc:7007 seems back online now. :man_shrugging:

1 Like