Submit failed Invalid value of field session.keys.nwk_s_enc_key.key

Anyone seeing “Submit failed Invalid value of field session.keys.nwk_s_enc_key.key”
For some reason a recent update has changed the class of some devices from C to A.
Setting them back cause the error.

I also tried to changed the AppKey on sensor that had gone offline to a new one same error.
So it looks like any change to LNS root & session keys also creates the same error.

Wonder if I’ve missed something this happening on community and hosted editions.

Any thoughts? Thanks

Not seen any of this but then it’s a huge surface area so apart from the real core functions, stuff popping up that no one else has come across is pretty likely.

There is effectively only one person on the console mods so he’s pedalling hard to keep up with the rest.

Is this web console or CLI? The CLI is generated from the Protocol Buffers definitions and processed via the server changes, so you may find the CLI is more in sync ie less likely to be out of step aka work.

Nick on web console was going to try CLI next.
It coincides with the web console not being able to show an join error when Appkey is mis configured.
So your hunch about it being in that area is a good one.


Hmmm this sounds like a serious issue, what was the update that changed Class C devices to Class A?

Sorry no it was me having a senior moment!!
But there was an issue

So it looks like any change to LNS root & session keys also creates the same error.

I’m getting the same/similar error: invalid value of field session when editing device in the End Device → General settings → Network Layer section.
Performing no changes and hitting the Save Changes button causes this so there is something that has changed in the form.

Anyone else seen this?