Sx1302lorawan gatewey hat

Hi guy , I hope you all doing well…
I’m new to lora , I’m trying to make make a gateway based on sx 1302.
There is a fault . I can’t start concentrator. Please have a look and let me know what is wrong :expressionless: many thanks. P


Is the correct Reset pin assigned for the concentrator - often the case that wrong pin is called where ‘failed to start the concentrator’ is called out…what is full hardware and software/firmware build? Who’s SX1302 HAT?

Use raspi-config to turn on I2C …

That’s waveshare hat

Ok I’ll try

Still the same

I did all instructions from Build a Packet Forwarder | Helium Documentation

And only changed for EU868

Um, we aren’t the Helium network, you would be better served finding one for TTN …

thanks I’ll have a look

or the hat is not compatible with rasberry pi4 8gb? what you think?

Basic concentrator mode uses only the SPI and a GPIO, that will work.

Access to GPS (if even present) might be more tricky, but that’s not actually needed for most purposes.

You were specifically asked for the identity of the “hat” and have failed to answer that question.

thanks for help … this is SX1302 LoRaWAN Gateway HAT by Waveshare

Have you tried using their instructions which are written for TTS - which this is, being TTS CE aka TTN v3 …

1 Like

Your startup script is driving the wrong GPIOs. Please see the waveshare documentation and cross reference against the pi gpio header documentation to find the correct reset and power enable pins.

If you are using Semtech sx1302 code it will also want to talk to the temperature sensor and you will need I2C enabled for that. Code with the temperature sensor code removed (for example for a RAK2287 which has none) wouldn’t need I2C but only SPI and the reset (and enable) gpios.

thank you so much! I’ll try it and I’ll let you know .

how to correct those errors? i thing that’s last two:)
ERROR: failed to set SX1250_0 in STANDBY_RC mode
ERROR: failed setup radio 0

Probably by fixing the wrong GPIOs?