TEKTELIC Communications KONA All-in-one Home Sensor

The 7 bits NwkID is already included in the DevAddr, which is why a TTN DevAddr always starts with 0x26 or 0x27. So, there is no need to set anything else.

(For ABP, the DevAddr is hardcoded; for OTAA the DevAddr is derived from the Join Accept.)

Four additional “received messages” counted on one of the rooftop gateways within the past two days… which suggests that it may be functioning ok… just not seeing much LoRaWAN activity in the area (I doubt that the uplinks were from the KONA device).

Today I need to spend much of the day about 150 meters from the base of one of those buildings that has a TTN gateway on the rooftop. No line of site and it’s on the far edge of the roof from where I am now. I brought the Kona device with me and was surprised some hours later to see this below appear about an hour ago… I don’t know how to interpret it. That definitely is the device in the bottom of the join data… And the device is no longer flickering which it had done continuously for close to a week since I pulled out the plastic tape from the battery. I haven’t yet seen any gateway traffic though.


A little more action. I see now by opening up each line using the arrow on the left edge of each row that the item at the bottom in this picture was a join request, the next item up the list was a join accept. The next item was traffic from a non-TTN network (Senet). The top item is for TTN. I wonder if it might be my device that has been successfully given a new devaddr starting with 26? Or would that be someone else’s TTN device?


Later: While I was still at that location, I subsequently, every half hour or so, waved the Kona device around and saw corresponding traffic at the gateway.

So… next I’ll need to figure out how to translate the uplink payloads into sensor data that I understand. And will start with the decoder that @eggfriedrice kindly referenced on Jan 21 in this thread.

You can tell the current DevAddr from the device’s Overview page in TTN Console. Also, it might have shown in the orange Join Request in the screenshot, when scrolling to the right. (It surely does that when looking at a Join Request in the application/device’s Data page.)

1 Like

Can I connect this device to TTN and see temperature from the internet?

If yes, on which website could I do that (see temperature data)?

“Can I connect this device to TTN and see temperature from the internet?”

If you are in the U.S., you should be able to use the device (Tektelic producte code T0004885) that I linked to above (Feb 25) to connect to TTN, presuming there’s an active TTN gateway within range, and then see temperature data using the TTN console.

I don’t yet know how easy it would be to have the traffic forwarded to a site like Cayenne to have a better dashboard for remote monitoring. https://mydevices.com/cayenne/features/lora/

If you want to be able to do it soon, you might consider instead using The Things Node, which I’m confident integrates relatively easily with a dashboard like Cayenne’s.

And if you’re not in a hurry, perhaps wait for the TTN generic node.


to set up a TTN application one has to enter the following details to the form:

  1. Application ID
  2. Description
  3. Application EUI
  4. Application ID

With the sensor KONA All-in-one Home Sensor I did get the following data:

  1. Product code
  2. Serial Number

Could you please help me out by matching those details to each other!? Thanks a lot!



A device is registered to an application. So, first create an application; this does not (yet) use any of the values provided with your sensor so just use whatever you like. After creation, go into the application’s settings and select “EUIs”:

Next, add a device to that application. While doing that:

  • DEVEUI goes into Device EUI
  • APPKEY goes into App Key; first click the pencil icon again
  • APPEUI is selected from the dropdown (as entered in the application above)

Product code and serial number are not used.

Hi. I have successfully registered a Kona Micro gateway to TTN (us-west.thethings.network). Successfully registered a Kona Home Sensor and Kona PIR sensor. When I start the sensor OTAA the first time, it attaches and sends a payload. But then I don’t get any more traffic unless I reset the sensor. What am I missing that is keeping the data from the sensor to keep being sent to TNN?
I only changed the basic constructs in the gateway via KonaFT [added gateway_ID, changed server address, added aes_key].

Thanks in advance.

Hi at all,

I just got my first Tektelic smart room sensor.

Al I have is a box and the sensor.
No link, no data about codes, nothing.
So I don’t know how to register the node in TTN.

Is that normal or is there something missing?

Regards - Mat

Hi @avaonis, I use Tektelic KONA sensors.

The sensors are pre-provisioned by Tektelic with a DevEUI, AppEUI and OTAA AppKey.
You need to get these 3 items of information from the vendor.

Then you will be able to register the device on a TTN application.

If it is the same device that I have you will also need to pull out the plastic spacer that keeps the battery isolated during travel and storage.

Hey @avaonis

If you ordered the device from Connected Things you should have an email of details from us, if not, drop us an email and we’ll resend.

Hi eggfriedrice,

many thanks for your reply.
You are right. In future I will read my mails first :slight_smile:
regards from Germany


I’ve recently bought one of these and have set it up with TTN. It works fine in there but I am trying to connect it to cayenne to get some useful info out of it & I don’t seem to be able to. There aren’t many steps so I’m not sure what I’ve done wrong/can do differently to make it work…so:

  • I’ve selected “add device” from there I’ve selected the “LoRA” box
  • I select TTN & then scroll through the various devices and select "Tektelic KONA All-In-One Smart Home/Office Sensor (2019)
  • I enter the DevEUI. Activation mode is “already registered” (can’t be changed). In Location the only option is “device doesn’t move” in Address I enter the postcode I’m at. I press “Add”
  • The dashboard appears with a pointer on the postcode I’ve entered and nothing else. No option to add widgets - nothing.

I also tried this by selecting “Tektelic Home Sensor” from the device list - some other widgets do appear on the dashboard but no option to do anything with them or add new ones (plus they don’t seem to relate to any data my little box is collecting).

What am I doing wrong?!

** Since I started writing this another device has just appeared in my device list! I certainly didn’t add it. I seem to be able to add widgets to that but when I try to it says “device is offline restart your device to add widgets” (or something to that effect.

I’m very confused… I thought this would be straightforward!! Any help appreciated :slight_smile:

this is more a cayenne question .
start with the cayenne tutorials here

From that I assume you have

  1. created an application from the console
  2. added your device to the application
  3. checked to see if traffic/payloads arriving in the applications ‘data’ tab?

Before heading off to set up Cayenne all too often I see folk skip another step…

  1. go to application ‘integrations’ tab and add an integration - in this case mydevices/cayenne ? :thinking:

Have you set that in place?


Hi Taraxa-US are you able to get sensor working. I’m also trying to setup the Kona Home Sensor and facing the similar issue. Payload is only sent at the beginning, after that data from the sensor comes random or as specified in the specs in 1 hour. I tried to update transmission rate using the TTN downlink with the byte a0 00 00 00 1e. However, this is also not working.

Kindly let me know if you were able to resolve this.

I’m also facing the similar issue.

Kindly let me know if you were able to resolve this.

I have a number of the Tektelic Kona Home sensors deployed. They are sending data back via TTN but don’t seem to receive any downlink packets which are needed to configure the devices.

On my ChirpStack instance the downlink works perfectly and I am able to configure the same devices.

The downlink and the subsequent response are sent on port 100. On TTN I see the downlink being sent in the console but never see a response from the device. On ChirpStack I see the downlink and response immediately.

I think it is an issue with sending the downlink rather than the response not being received as the device behaviour does not change after sending config on TTN. On ChirpStack the behaviour change is instant.

Does anyone have any ideas what might be going on?