Tektelic sensor device - Join Server failed, MIC mismatch

Something went wrong with the migration of my Tektelic Kona Home Sensor device. Device is manually created in V3 with the same keys. In V2 Appkey was changed afterwards to avoid problems. However, I now get the message Join Server failed…MIC mismatch, even after removing from V2.
I’ve seen some posts on the forum that suggest generating a new AppKey but that doesn’t help.
What can I do now? Delete from V3 and recreate?

With ‘manually’ do you mean:

  1. ‘manually created in the console’ using the LoRaWAN Device Registry option?, or
  2. created in the console using the ‘Manually’ option?

If 2. then try to redo registration using 1. instead so that required settings will be configured correctly automatically. This requires the current device to be deleted first and a new device-id for the re-registration.

MIC mismatch errors may be caused by incorrect (mismatch in) network layer settings.

My Kona Home Sensor devices (T0004895 Rev D) use the following network layer settings:

LoRaWAN version: MAC V1.0.2
Regional Parameters version: PHY V1.0.2 REV A

I’m in the EU868 region:
Frequency plan: Europe 863-870 MHz (SF9 for RX2 - recommended)

When registering a device using the LoRaWAN Device Repository option the correct network layer settings should be configured automatically.
(Be aware that changing network layer settings in the console after the device has been registered may be possible in the UI but then not be effective. Not sure if that issue has been fixed already.)

When registering a new device in the console (using the device registry) be aware of the following:

The Tektelic ‘Kona Home Sensor’ was rebranded to ‘Smart Room Sensor’ so this is what should be selected.

In the ‘Model’ list Smart Room Sensor entries will show up TWICE:

Smart Room Sensor - Base
Smart Room Sensor - PIR

Smart Room Sensor - Base
Smart Room Sensor - PIR

The first instances currently allow only hardware version ‘D’ to be selected, the second instances allow only older versions to be selected.

Also see: Migrating Tektelic Smart Room Sensor devices to V3

Hi bluejedi,

Thank you for your attention.
I had already read your original post and indeed chosen: Register end device:
“From the LoRaWan Device repository”
I’ve deleted and re-registered a few times with the original (V2) AppEUI and DevEUI and new AppKey but I keep seeing the message: Join Server failed, MIC mismatch

That AppKey has been programmed into the device as well? If not you will keep seeing MIC mismatches.

You will need to register with the original DevEUI, AppEUI and AppKey that were provided with/for the device, same as used for V2 (so no new AppKey).

The only thing new you need when registering a device (again) is a new device-id.

I have no idea, I’ll have to figure that out but if so, won’t the cached AppKey be removed from the backend when I remove the device from the console?

I already did that but same result

Have you verified the correct byte order when entering keys?
IIRC there was some difference between V2 and V3.

I think that was in V2? …I migrated my other devices through copy and paste …I thought :thinking:

Me too.

Maybe it was not when registering but when copying keys in the console from already registered devices to be used in end device source code. So probably not relevant here.

Problem solved.
Error in the AppKey. Device was already removed from V2 but luckily I found the original keys on my server.
AppKey is indeed programmed into device.


Thank you for the support

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.