The Things Gateway (backers edition)

Does anyone have technical data on the origional kick starter gateway? I have one here that I bought under the impression that it was new but it turns out that it’s not and it doesnt seem to work properly. It stops working after a few hours. I have access to a test engineer’s lab at an electronics producution facility as well as the technical knowledge and background. I found the schematics for this gateway online but I need some more in depth information. Something like a test procedure or troubleshooting guide, even a list of the test points and what signals should be measured on them? I cannot even find a description that explains the combination of flashing LEDs that I am seeing. Can anyone get me proper in depth documentation? I am willing to sign an NDA if need be.

Most of the information you are asking for is on the TTN documentation site (don’t forget to look at the FAQ and Status LEDs in the left navigation bar). Some of it will be at GitHub and a lot (including complaints of it not being stable and disconnecting) can be found on this forum by using search (magnifying glass top right on the page).

I have seen these sources. The explaination of the LEDs does not include the combination I see happening. I’ve reseated the print and swaped the power supply. I have the schematic and PCB designs too. I need something a bit more technical though. The device boots up and comes online, it sends and revieves data but after what seems like a random period of time it just goes offline. I see a USB port here, can that be used to spy on the inner workings and see error messages or do I need to use the serial connector? The documentation I am seeing is consumer level stuff and covers the expected working parameters of the device, not the strange. Does TTN Industries have someplace where they can be sent to for repair? I’m in The Netherlands (ZuidLimburg)

I have spent two evenings reading the forums and seeing much frustration from many others who have problems, what I don’t see is solutions. I mean min runs for a while then does the same that a bunch of other people say. Led 1&2 with the 3rd flashing then reboots. If I unplug it for a bit then it will boot up and come online in a couple minutes. It will keep running for a few hours, then plop. it’s gone again. Sounds like a lot of the post I see. Are there solutions though?

The schematics and sources are available, surely you can’t get more technical than that. There is no maintenance manual or anything like it.

The USB port was meant for future expansion or custom firmware. The first never happened and I am not aware of anyone releasing custom firmware. The development environment and firmware building blocks are to hard to master for casual developers and the hardcore developers on the forum decided not to invest time (and money) in this limited platform.

You need to use the serial port for debugging.

Are you using WiFi? If so you could test if the unit works better using a wired connection.

Yes, that is basically is it. There are users without issues and a small (but vocal) group with issues and it seems those issues never have been resolved. From what I recall my unit worked fine with wired internet, WiFi not as much. I’ve got better gateways so mine basically has been in its box since 3 months after purchase. That might tell you something… (may-be contact your seller and return it as not fit for purpose if that’s still an option)

No, I am running it wired. I am sure I have a 3.3v serial port dongle somewhere. I’ll put it on there and see what I can see. I bought it of someone on marktplats (you know the one?) so it’s a bit of a hassel to go back complaining, I mean he sold it was “new in the box” but the actual purchase date was 2015 and delivery in 2018.
I was thinking maybe those first runs had some sort of known issues or component changes along the way that fixed the reported problems. So there are no real deap dive technical documents like what signals should be found when measuring the test points? Or revision on the BOM making later models more reliable? Maybe there is someone from the things industries that hangs around here?
I can pop it under the microscope at work in the lab, I’m thinking there is something up with the manufacturing or that some components should be changed. Hopefully I can get it working. I did notice one chip gets hot… i mean too hot to hold my finger on if thats a real test… it was the big chip on that daughter board.

Thats the SX1301 - the Semtech LoRa Baseband chip - and yes it gets warm, also the heart of the system :slight_smile:
Mine run fine from day one and apart from occational power outages (from which it seems to recover well) or a couple of BBand outages due to a dodgy router at the time, it has run without a murmur for 3 years now, (Handled ~3.3Mu uplins so far) so guess you are just unlucky! I do seem to recall that a few folk had joy after removing and reseating the daughter bd when seeing something similar to yourself… might be worth a try but dont remove/re-insert too often as I think the connector has limited life cycle for that.

AFAIK there haven’t been revisions, by the time the device was finally ready for the market technology had moved on and there were better solutions. This gateway was part of a Kickstarter that got things started and the other gateways probably wouldn’t have been there if that Kickstarter had not been but it’s design was a compromise from the start.
Would be good if you can find anything for those with the same ‘brick’.

it was the big chip on that daughter board.

It looks like documentation on the LG8271/LG9271 concentrator board is available, so one idea might be to remove that and try to graft it onto another host (perhaps for initial bench tests, a raspberry pi, but better something more robust with multiple hardware UARTs). It seems like it uses a delegation-over-UART scheme, and the code for interacting with it appears to be here:

I sliced the pad in two that glues it down, squezed the plastic tabs together and gently removed it. Inspected the pins and pads, they all look find. Replaced the board… rince and repeat. It ran for about 6hrs before it went down. I looked at the schematic and noticed it looks to me like the power input can handle AC or DC and be between 4.5 and 30V so I put a 6V supply on it. It ran for almost a day and when it stopped it didn’t reboot or drop off TTN, it still said it was connected but when I tried to connect my node it would only register the join but not accept the data. After cycling the power it was okay again. Made me suspect something in the PSU circuit but I will have to print it all out and go through it with a fine tooth comb. For being built on a budget this supply circuit seems really expensive. Was it an inhouse design team or farmed out?
Oh Wait… this label on the board… TWTG (formarly tweetonig) that’s a fab here in the netherlands. I wonder if they are the makers here.

Realistically that sounds a lot more like a software state problem than a hardware one.

The other thing that would be interesting would be to run a packet sniffer on a router it’s plugged in through; and see if there’s any correlation to something like DHCP lease renewal or upstream network burbles. In theory you could also watchdog it there - no backhaul chatter for a bit, hit the reset.

I do need to leave it unplugged for a while, if i just cycle the power it doesn’t come back up. When I first got it on the origional 12V supply it would run for an hour, two tops then konk out.

My other (DIY-Pi) gateway stays running but I don’t run them at the same time cause they are next to each other. It’s a residential setup but the GW is on an HP office connect switch with POE, the Pi runs on POE and eventually this GW will too once I get the 12V splitter.

The gateway has a DHCP reservation and resides in the DMZ, I did this later trying to make sure it was able to get to the web.

I will get the serial port dongle on there asap and log it until it konks out.

I can think of a half dozen ways to shut it off for a while when it konks out but it will eventually stop working if it is a hardware issue. If it was software then I think everyone would have a problem.

Known issues with this gateway -I had 2, sold one of them- is the LoraWAN module connection inside, check it, clean it, make sure the module is seated firmly.
Second issue is bugs in older firmware, try to update it, auto-update online mostly fails because it reboots before update is finished, you can also write the latest firmware on sd-card and insert it in the gateway. Check the github repo for instructions and files

Hi,
Thanks for the pointers… I have reseated the module, it didn’t help. I also updated the firmware, and tries the stable and beta versions, online enabling and disabling firmware updates also had no effect. these things were done right away before I posted. I found these solutions in the forum already beforehand.

I can tell you the gateway has now been running without any issues for two and a half days, this is the longest is has been stable. I left it open and put a fan infront of it… So my initial theory that it is hardware look to me to be the most likely.

This one was ordered in 2015 and delivered 01-2018 so I am guessing it was an early model. I was a design and test engineer for over a decade and I have very never seen a device BOM stay the same for the entire life of the design. Something was changed, there is a manufacturing error, or some component is physically broken. I still have some friends at the manufacturing plant I used to design for so I will ask one of the test engineers to have a closer look.

I have a few ideas of which part(s) it could be just looking at the design and schematics but if lowing air over the board stops it from crashing then I think it is safe to say it’s not a case of reseating the module or doing an update. I would be interested in hearing if others have one that doesn’t work right if they could try what I did too.

I have the gateway too. I also submitted several PR to the firmware with various stability fixes (see Pull requests · TheThingsProducts/gateway · GitHub) but they didn’t sparkle enough interest in the maintainers so I am running my own compiled firmware. The gateway automatically restarts after 24 hours, except of that it is running pretty stable, you can see from this graph:

Screenshot from 2021-02-18 13-24-40

Considering the interest from maintainer, I highly doubt it will ever work with v3

How do you monitor this? I would like to monitor mine as well.

I agree it is not really motivating to see how contributions are trated.

I can confirm that this piece of hardware runs fine with V3.