The Things Node USB


#1

Got The Things Uno and The Things Node in the last weeks.
The Uno is detected as Leonardo and can be programmed by the Arduino IDE as expected.
The Node is not detected as an USB device. I get alyway the message “USB device not detected”. There must be something wrong with the USB description. Any ideas?


(Arjan) #2

Where/how are you trying to use it as an USB device? (Where do you see that error?)


#3

I placed 3 AAA batteries and connected the Node via USB cable to my W10 PC. I expected a COM device in the Device Manager but got the message that the USB device could not be detected.


(mbsnl) #4

#5

Configuration as shown in the video
Konfigration Node

But after connecting the USB the device is not dtected properly.


(Mark Terlien) #6

I have a similar problem on Windows 10. I tried on Ubuntu and same problem, Node is not recognized and does not appear in port list in Arduino IDE. Is it a matter of missing drivers? Which drivers have to be installed? Or there is something wrong with my Node? Blue light is blinking when I move node, so it seems to work OK.


(Arjan) #8

That’s a different problem. But it’s well documented in the documentation:

If you don’t see a port that identifies as Arduino Leonardo make sure The Things Uno’s power LED is on and check the cable and USB port you have used. On Windows, you might need to install drivers. See Arduino Troubleshooting for more suggestions.


(Pfiadi) #9

I was able to flash my TTN node the very first time to get the EUI. When I tried to test the basic example the node was no longer detected as a known USB device. Any idea what went wrong? Tried both Win7 and Win10.


#10

that’s typical 32U4 behavior.

The simplest solution is to enable verbose messages while uploading in the Arduino IDE under file/preferences

verbose

and click the node’s reset button when the lines that begin with ‘PORTS’ start scrolling past.

resetbutton32u4

That will force the bootloader to restart and open a new USB connection while the IDE is looking for a board to do exactly that.


(Pfiadi) #11

Thanks. But in fact this did the trick as windows was always showing me an unknown device … see section ‘Bricked’ here https://www.thethingsnetwork.org/docs/devices/node/troubleshooting.html

Sorry for not properly searching first …


#12

A post was merged into an existing topic: TTN NODE central


#13