The WORKBENCH part 2


#149

Huawei%20B315S-22%20-%204G%20LTE%20router

interior Huawei B315S-22 - 3G/4G fall over LTE router right click/view image for BIG


(Jezd) #150

On the verge of ordering my ‘CurrentRanger’, just hoping someone will give us a review/feedback first :slight_smile:


(Jeff Uk) #151

Dont use it myself but know they are available in wide rang of territories from Lithuania to the Caribbean! and are often locked to a specific Celco/SP so make sure it is suitable to use with your chosen SP or is confirmed as 'unlocked’. You can find many listed on ebay new or 2nd hand, locked or unlocked etc. prices seem to range for <£120GBP to >£200…a bit high for my purposes…good luck - look fwd to hearing how you both get on with them on the forum :wink:


#152

tnx Jeff… I know what you mean.

The first one I bought on eBay was an ‘unlocked’ one from Russia… didn’t work.
This one I bought here in NL, and after a phone call with the seller, just to be sure, ordered one.
Worked without a problem on RPI gw / RAK 831 :sunglasses:

You have to be more carefull regarding the SIM card you put in that box… at least if you are a hobbyist like me.


#153

that’s for @Charles … he’s the review specialist :wink:

(I don’t have him yet)


(Jeff Uk) #154

The other problem I have seen and frequently hear of - esp where cheap phones & modems/routers from China & Far East is concerned - even some ‘named’ brands - is that not every 2G/3G/4G device supports all frequencies used in all global territories - quite often a device might support 3G or 4G bands in its home country but then not support when used in another area…perhaps that was prob with the Russian unit you bought? Even when there is support in theory for a country if the specific SP you then buys service/SIM from doesn’t have a license to operate in the specific supported bands you can still find it fails or has limited coverage where there is only a limited set of supported bands…it can be a nightmare judging and getting it right! :wink:

In UK we currently use bands 3, 7 & 20 for 4G so we have to look for devices covering all or part of that set to be sure…

A useful explanation here (similar questions will apply in other territories so hopefully gives a steer to all of what to look for) :-

Specs for specific devices often found here:

https://www.gsmarena.com/

And more/similar advise here:


#155

took me also a while to find a prepaid data only 3g/4g sim in NL without monthly subscription(s)

nl - https://wereldwijdwifi.nl/simkaarten/europa_simkaart/ (I have this one)


#156

CH2I-pizerogateway
https://github.com/hallard/RAK831-Zero

x1089

x1090


#157

Damn Charles! Now I’m $120 plus shipment poorer. Thank you for helping me to loose money so quickly :slight_smile:

Waiting for CurrentRanger


#158

I suppose I am the lucky one. I bought several Xiaomi phones directly from China and never had any issues in the U.K. One was in Chinese and had to be flashed with an English speaking firmware.


#159

sdcardprob

huh ???

spend some time yesterday on the CH2I PiZero gateway, so I made a backup SD card image when everything worked.

brand

Today I want to edit some things but from a cloned SDcard, I’m a linux noob So things go wrong regulary :sweat_smile:, and I wanted to write that image to a spare 16 gb card.
No way… etcher (and SDimagewriter) won’t let me… 25 mb ‘short’

After some searching I found that it’s never wise to expand your card automaticly (that’s why @Charles don’t like it I think :wink: ) and that not all cards have exactly the same size.
Also I read to many problems from people that starting to edit partions and all other kind of hocus pocus, so I just ordered a new 16 gb card and see what happends tomorrow :sunglasses:


(Tony Smith) #160

@BoRRoZ, you will find Win32DiskImager will work. It checks the file and when the file is larger than the SD card it checks the backend of the file and if it looks blank it will advise its safe to write to the SD Card. (There is an issue with Win32DiskImager in Win10, the o/s doesn’t like writing to hardware like an SD Card. You need to open Windows PowerShell (admin) and start Wind32DiskImager from the command line.)


#161

he nice…didn’t know that… but, I can’t select the drive (see picture) I have version 0.9.5


(Tony Smith) #162

@BoRRoZ Yes, you will get that error message in Etcher, but not in Win32DiskImager


#163

ok tnx… will try :sunglasses:

  • update

nope2

didn’t work with 0.9.5

yes1

latest version has an extra option

yes2

writing went OK… but unfortunately PiZero won’t boot with this card :sunglasses:


(Tony Smith) #164

How Odd!!! Wonder why that is? Do you have any other type of Pi other than a Zero? Can you read it in a Linux based machine?


#165

you mean… one that works like a 'normal RPI ? uhhhhhh … I’ll find one :sunglasses:, they all have ‘something’ … like a touchscreen / SSD / gateway ect.
I don’t have a working linuxbox at the moment

x1093

’ bad superblock ’ :roll_eyes:

x1094


(Tony Smith) #166

Errrr, I have never seen that before. (problem that is) Since the first pi was released I have written hundreds of SD cards and never had a problem. Actually I did have a problem with one card. Could not get a Pi out of a plastic case, so used a screw driver as a lever. Forgot the SD card was still inserted and broke the card in two. Now that one didn’t work :joy:


#167

LOL…

my best guess is that the card is broken ( duh :wink:) so tomorrow i’ll try again with a new one

sdcardinv


(Gry Kyo) #168

G1
G2

You have to love how easy this is (coming from somebody never formally taught any programming). Next task is to see what latency is like round trip from device, via TTN to NodeRED. I feel an upgrade coming for my shed alarm. Out with WiFi, in with LoRaWAN once I can process a node packet before the RX window closes. me thinks yes…