Things Node Newbie

100% newbie here, trying to explore LoRaWAN and I have just bought a thingsnode to play with. I am going through the things network tutorial (How to: The Things Node Activation - YouTube), but it asks for board selection of a spark fun micro, which i cant seem to find on the list in my Arduino IDE, even after downloading lots of templates. Having decided to plough on by selecting Arduino Uno…? I get errors even trying upload the ‘device info’ sketch, related to Serial1,

/private/var/folders/d4/4bd0lls56fn40by_fsrdrh1r0000gn/T/.arduinoIDE-unsaved2022121-13990-sm45nr.lj2jc/DeviceInfo/DeviceInfo.ino:3:20: error: ‘Serial1’ was not declared in this scope
#define loraSerial Serial1
/private/var/folders/d4/4bd0lls56fn40by_fsrdrh1r0000gn/T/.arduinoIDE-unsaved2022121-13990-sm45nr.lj2jc/DeviceInfo/DeviceInfo.ino:9:22: note: in expansion of macro ‘loraSerial’
TheThingsNetwork ttn(loraSerial, debugSerial, freqPlan);

Is this because i haven’ selected the correct board? Or something else…?

help … thanks

If by ‘a thingsnode’ you are refereing to the Things UNO then despite the name IIRC its actually a Leonardo based board…and not actually a UNO!

If you need help Forum search is your friend - use correct terms and descriptors when searching and you will find troves of info to help newbies. Much will relate to connecting to old V2 TTN but device level info still fine and will get you going and help is there for use with V3. If indoubt read the documentation - linked at bottom of each console page :wink: Home | The Things Stack for LoRaWAN

Hi - many thanks for the response, this is the device:, hence i just tried to followed the tutorial word for word…
I have tried a few searches in the forums - with not much joy at the moment… :(…

I see from link and following the YouTube link what you have is the Things Sensor Node… a bit confusing having two nodes described as Things Node I know :wink: what does searching Forum for this turn up?

Nothing unfortunately , :(. From what i understand, i need to access the board in the sensor node to update it / get it to run commands, but even the most basic of commands is failing due to:

/private/var/folders/d4/4bd0lls56fn40by_fsrdrh1r0000gn/T/.arduinoIDE-unsaved2022121-13990-dgearh.hq4z7/DeviceInfo/DeviceInfo.ino:3:20: error: ‘Serial1’ was not declared in this scope
#define loraSerial Serial1

Which i am guessing is because i cant select the correct board in my Arduino IDE…?

Yes. You need to add the Sparkfun boards to the Arduino IDE. Go to:

Other instructions on how to get started are on:

The TTN console will have changed but the Arduino stuff is still the same.

1 Like

Oh my days - that worked a treat ---- so many thanks …
Sketches uploaded fine — now for connection to my app and i get
‘send join command failed’ : response is not ok: no_free_ch. :slight_smile:

This was answered in the other thread you raised on the same subject.

The tutorial is for a Things Node.

Instructions are provided in that tutorial on how to add the spark fun micro to the Arduino IDE.

Again many thanks – this is my confusion for which there is a simple answer i am sure.
The tutorial that i was following: How to: The Things Node Activation - YouTube @5mins , shows an easy connection through to the applications console; yet the other tutorial talks about creating a gateway? So my newbie question is do i need to create / have a gateway - apologies if that is a really daft question - i assumed that, as per the tutorial, since i was connecting the sensor through my laptop that i didnt need one…?

LoRaWAN communication requires a LoRaWAN gateway. If there is one close to where you are experimenting you don’t need your own. Otherwise you need one.
The laptop connection for The Things Node is for programming purposes.

1 Like

thanks - will go shopping for one (cant see one near by) …