Things Outdoor Gateway - TTOG part 1

This topic is for technical info / questions about TTOG
TTOG-topicheader
The Things Outdoor Gateway (TTOG) is an industrial, outdoor and fully compliant gateway.

Features:
LoRaWAN 1.0.2 compliant
Supports up to 16 channels
3G/4G backhaul supported
Option support wide frequency range from 470MHz to 928MHz
Supports LBT (Listen Before Talk)
EU868, US915, AS923 and CN470 versions available.
IP67 waterproof
Dimensions: 230 x 200 x 68mm
Weight: 2.05kg
Power voltage: 55VDC/0.6A via PoE adapter

SET UP
teardown

currently available here:
EU 868 version: https://connectedthings.store/gb/lorawan-gateways/the-things-outdoor-gateway-868-mhz.html
US 915 version: https://connectedthings.store/gb/lorawan-gateways/the-things-outdoor-gateway-915-mhz.html

The Things Outdoor gateway arrived via Fedex today.

The gateway gets an IP address via DHCP, so the IP address written in the docs is likely not the one your gateway will be on. The gateway also does not have a hostname.local on which one can access it, so best is to log into your network’s router and see there what the IP address is.

Logging on to the gateway with admin:admin lands on a “Provision” page and it’s unclear if one is supposed to do anything here.
Screenshot%20from%202019-05-21%2019-57-22

In the menu there is no “Packet Forwarder” option which the documentation says one should go to.

SSH is open on port 22, but the login details are nowhere to be found. Clearly the gateway is running OpenWRT, but the default username/password does not work.

So currently I am a little lost and unsure how one is supposed to configure this gateway. Anyone any idea?

My first batch unit runs Ubuntu and after a firmware upgrade does show a (slightly?) different web interface. As it is deployed on a 4G connection I no longer have access and can’t provide a screen shot…
The password for root access should be ‘browan@{last 6 hex ‘digits’ of MAC in uppercase}’

The new batch also requires a firmware up(down)grade. After that I get the same Ubuntu 14.04.1 using browan@{last 6 hex digits of WAN/ethernet MAC}.

I have the same issue that I lose ethernet access to the gateway when LTE is configured.

You still have Ethernet access on a fixed address.

1 Like

Yes, I should have read the docs better. The gateway is indeed accessible on 192.168.11.10. I logged in and switched it to DHCP client now. Will see how that goes.

An issue I’ve running into after the firmware upgrade is that my browser constantly wants to go to:
http://<ip>/cgi-bin/provision.cgi
even though I type in http://<ip>/ in the address bar. It seems like the previous firmware had a 301 redirect which my browser remembers. I can’t find a way to clear that from the cache.
Workaround:
Access the web interface from an incognito browser.
Go to the full login page URL: http://<ip>/cgi-bin/login.cgi

Updates:

  • It seems like LTE is automatically disabled when one change the Ethernet to DHCP client.
  • When the gateway is on ethernet and you plug the (non-poe) ethernet cable out, the packet forwarder of course stops forwarding packets. When the cable is plugged back in after a couple of minutes the packet forwarder forwards packet again. It therefore seems that the packet forwarder restarts automatically when the internet connection is lost and restored.
1 Like

I just filed this issue on the Balena board support repo:

It seems like Yocto support already exist for the SoC used in the gateway, so hopefully someone knowledgeable with Yocto and Balena can make use a BalenaOS build for the gateway.

1 Like

Did you have to enter a provision code, if so, where did you get it?

Also, where did you find the file that you used to upgrade/downgrade the system firmware? Currently my Gateway is running on Version 3.04.09, and do not have the packet forward option in the left menu as seen in the docs.

I’m keen to get a look at these and compare to other outdoor units or self builds…when will they be available to buy? I keep checking RS site but no presence yet! :frowning: @wienkegiezeman

Hi @LagCompensator

I filed a support query with Connected Things and they responded with the following:

You should be able to access the web GUI using user/pass = admin/admin

Use the firmware update to upgrade with this file:

https://connectedthings.store/files/WAPS-232N_LW_OPDKGUIForGeneric_3.09.99_3952121863.tar.gz

Once you have done that you should see the packet forwarder config options.

You can also SSH with:

root / browan@[The last 3 bytes of MAC(uppercase)]
Example:
MAC: 1c:49:7b:aa:bb:cc
SSH password will be: browan@AABBCC

1 Like

My TTOG doesnt respond to any network communication. Any help or firmware file to fix my problem?
I’m sure the thing is wired correctly, and I have an DHCP server, but even that isn’t giving out an IP adress.

could you solve it ?

I contacted connectedthings,

My TTOG was shipped with a very old firmware. After a day of work I managed to get some ethernet working and have SSH access now. After that I did not have any time to test any further.
If i have a solution I will try to post it here for other people having similar issues.

Bottom line, if i knew this beforehand I would have gone with a different gateway like RAK because that is based on a stable openWRT

I’m sorry to hear that… seems that they are still working on perfecting the firmware and that you was a very early buyer.
firmware problems/updates are known to all companies… even RAK :wink:

Sad to hear your experience is that bad.

I’ve got a unit from the first batch and after a quick firmware update it has been up and running (using cellular connectivity) without any issues for weeks now. If I need another out of the box ready outdoor gateway I would buy again without hesitation.

I am not able to extract this file, getting error message with it. Any idea what to do? My gateways firmware version is 3.04.09. I also do stuck in the provision code window. And do not have the mentioned configuration page for packet forwarder :frowning:

I had the same issue trying to extract the archive on my Linux computer. But I uploaded it anyway to the gateway via the web UI and the upgrade worked.

My TTOG was configured for LTE about two weeks ago. I just realised it stopped forwarding packets a couple of days ago because the 4G connection failed. A power cycle does not solve the issue. The 3G/4G log is attached.

3G-4G LTE Log.txt (3.7 KB)

So I decided to enable DHCP on ethernet, which disables 3G/4G. Then I enabled 3G/4G again by specifying an APN name. All this was to make sure all the mobile settings are correct. After applying I can’t access the gateway on the fallback IP and it doesn’t request an IP via DHCP. Even a power cycle doesn’t bring the gateway back :frowning: (wrong IP settings on router)

The gateway is now accesible on the static 192.168.11.10 IP and I can log in. The web UI however still indicates that 3G/4G is not connected.

image

On the sim card provider’s website I can see the sim card has data and that there was a data session today. A couple of KB’s of data has been used. But no packets are forwarded to TTN.

@jpmeijers Thanks for your kind hint! That’s exactly, what I suffered from! I did an upload of the tar.gz-file now and firmware update worked fine! System is updated to version “opdk-1.00.17” now and up and running! Thanks again!

My current firmware version is now:
opdk-1.00.17

Is this the latest formware, because in the filename i read 3.09.99.
If this is the case than the gateway is now up and running.

If i try to use the web-upgrade on the downloaded 3.09.99 firmware i get an " * Invalid firmware file." error