TTGO T-Beam 1.1 success with TTN ?

Hi

After having played with some Heltec boards with success, I try now to use the TTGO T-Beam 1.1 board but I completely fail whatever code I use. I never get indication in TTN Console that it sends something (green LED there still displays last status of previous Heltec boards I played with before). Anyone has been successful with that board in 868 mode (EU) ?
One of the last code I have used is that one: https://github.com/kizniche/ttgo-tbeam-ttn-tracker that looks to be good from what I have seen in some other threads but no success at all for me ! I get well indication that GPS is locked and that it transmits LORA data on the OLED display but nothing arrives on TTN Side :frowning:I have tried both OTAA and ABP mode but same !
Any clues what’s might be the problem ? out of a defective board ? I got some confusions also about radio chipset used in it (I have tried SX1276 and SX1262 but not better !

Thanks for help/ideas/suggestions :wink:

Vincèn

did you pay attention to this point: “Edit arduino-lmic/project_config/lmic_project_config.h and uncomment the proper frequency for your region.” ?
If not, the T-Beam might transmit in the wrong band. If you have a SDR-Receiver or a Spectrum-analyser verify the used frequencies.

@vincen
I too have so far been unable to get a TTGO T-Beam 1.1 to connect to the TTN network so I am very interested in this topic. Most likely it is due to my mediocre understanding of networking concepts and networking coding in general but I am learning slowly and will get there eventually.

I have two of these identical boards and have had them communicating with each other as peer to peer LoRa units so that pretty much proves that they are both functional, hardware wise. I have also managed to get both to connect to the GPS system as Mappers so that was a huge achievement for me.

I am currently studying the ins and outs of the TTN system, applications, mqtt, decoding etc and when I have that sufficiently understood I will try the T-Beam 1.1 end nodes again.

Meanwhile I can now send a device simulation and receive and decode that on my own custom app via mqtt so that side of the data flow is now working nicely.

I also have my own Gateway so that is another possible source of issues.

@vincen Let me know if you achieve success.

Having the same problem here too with TTNMapper. I have checked that the LORA is enabled and it says it is transmitting but my gateway isn’t logging any packets. Double checked the device and app EUIs appkey and the LoRa pinouts and all seem correct.

I think it might be the lmic.h library as I can get the lora examples to work. Is there simpler source code for a tbeam to TTN example than ttnMapper?

With three T-Beam 1.1 work very good and stabile with this Paxcounter project:

It contains several “addons” as ttnmapper Integration or Corona Warn App counter or several sensors like bme280/680 and Integration with opendata projects.

It is active devoloped and good prepared for the T-Beam 1.0 and Up.

I managed to get the T-Beam and the kizniche library working of ABP, so in principal it should work. Once connected, I noticed the deveui being printed to the console and the one being shown in the gateway log were flipped. Still even after I unflipped one of them it would connect but not upload. Basically the handshake procedure keeps failing on OTAA