TTGO T-Beam topic

I don’t think this is the problem about gateway. Because the gateway connection and extend is the second step. I should register and find the results of my device in TTN firstly. So I think the problem is now on the registration or some configuration I have not modified. But I cannot find it.

Errr you may wish to do some reading up on the way ttn/lorawan works, nodes are not tied to gateways and simply broadcast to any gateway that is listening - first thing I would ask is that you have a ttn gateway setup and listening and the ttn console saying this too.

Does you ttn gateway setup look similar? Last seen is being updated?


I have checked that the problem is that the local gateway is turned down with some unknown reason. Now my nodes is working well. Thank you.

By the way, I have to link a tipping bucket rain gauge sensor with my TTGOTBEAM board. Could you please give some advice?

Thank you.

I have the T-Beam T22_V1.0 and use the PAX counter software. It joins TTN succesfully but the gps does not work. I have read that the gpio pins changed from:
GPS_RX_PIN 12 to 34
GPS_TX_PIN 15 to 12

I changed the ttgobeam.h to:
// GPS settings
#define HAS_GPS 1 // use on board GPS
#define GPS_SERIAL 9600, SERIAL_8N1, GPIO_NUM_34, GPIO_NUM_12 // UBlox NEO 6M
//#define GPS_INT GPIO_NUM_35 // 30ns accurary timepulse, to be external wired on pcb: NEO 6M Pin#3 -> GPIO34

but it doesn’t see any sats. Is there something else I have to change? The GPS does work because I have 2 ttgo-beams and with the default software it does get a gps lock.

Hi, I am new here. I received some of these new boards and when I power it on, I get no WiFi signal. Normally SoftRF should be preinstalled and working, GPS Led is blinking but no WiFi signal. Does anyone has an Idea how to get this t-beam running like the earier ones?
I have an older t-beam where softRF is working fine.
Thanks in advance

what is the date on the board under the T-Beam T22_V1.0 ?

why dont you try some basic debug code on the gps pins first, sometime the info supplied is not accurate - maybe use the gps output straight to debug

Which paxcounter version did you try?
Is “Sat000” displayed on top left in display?
Please post photo of the t-beam board here.

Note: Paxcounter code currently does not configure the gps chip in any way, it just uses the default setting. If some other program reconfigured the gps NEO chip (e.g. forcing it to protocoll UBX instead of NMEA) paxcounter gps code won’t work.

meanwhile I am pretty sure that outofthebox there is no SoftRF installed as with the older t-beams. Does anybody know If the current version runs with it or what needs to be changed?

Does it mean that you’ve got V1.0 board delivered and it does not have SoftRF firmware been pre-installed ?

V10 (a.k.a. V1.0) is substantial rework over older V05-V07 revisions toward deep sleep current reduction. Each major component (ESP32, GPS, LoRa, I2C) is now under control of dedicated PMU IC (AXP192).
This board is expected to come with 1.0-RC6+ version of SoftRF firmware that I’ve sent to LilyGO in late June of 2019. RC6+ is able to run on this board revision properly.


"Official" support of the board will be available in RC7 binaries of SoftRF firmware. Same as before, the binaries will be deployed on the SoftRF Releases GitHub page.
Those who do not want to wait - just build the firmware by yourself from most recent snapshot of the source code.

More details about difference between V07 and V10 are located here and there.

STL files of the SoftRF Prime MkII enclosure:

1 Like

The exact version is T22_V1.0 20190612. See the below schematic:

GPS TX=34, RX=12. I try to dind these pins but cannot find them on the schematic. Are those internal pins or do I have to connect the ttl usb cable direct to the neo-6M chip?

I tried the latest version:

I selected ttgobeam.h in the platformio.ini as the halfile. Than I edited the ttgobeam.h so that the pins correspond with the documentation:

The version is T22_V1.0 20199612.
Sats : 00 is displayed on the oled. There was a firmware on the board wich got a gps fix with 5 sats. Than I reprogrammed it with the code in the sketch. Is there a way I can read the chip? I can’t find pins 12 and 34 on the pinout scheme.

Yes, I ordered 2 t-beams from 2 different suppliers and both dont have softRF preinstalled…I can see the GPS data over usb but no SoftRF available…I am pretty dump regarding flashing this device because I never did that so far…and I told friends of mine at the local airfield (I am flying myself) about t-beam and they ordered them as well without SoftRF…so I am in trouble now :crazy_face:

It is not a big deal… A lot of SoftRF builders have done that successfully.

  1. take this file
  2. and follow these instructions

Ask your seller why the firmware was not pre-installed and copy the answer onto my e-mail address.

This forum is probably not the best place to ask questions about T-Beam & SoftRF. Use this Gitter community instead.

Looks like you swapped RX(12) and TX(34).
Try to swap it in ttgotbeam.h

That was the first thing I tried. It seems that the gps chip does not start. If I put another working firmware on it the red (gps) led starts blinking. With the paxcounter the red never starts to blink. I think it has something to do with the tinygps library

Folks, you are losing each other’s time…
Just as I said above:

Does this picture have more sense to you ?:


And, once again, use this resource to update your existing T-Beam source code to run on V10 (V1.0) revision of the board.

1 Like

As far as I am aware TinyGPS (itself) does not read or write data to the GPS, it just encodes characters that are sent to the library.

Cannot see how the library can somehow control the actual GPS between working or not working.

HI, can you share your ttgobeam.h ? I´m struggling on TTGO talking to TTN, thanks in advance

I added the axp power board code to the ttn sketch and now the gps is powered on. TTN gets the coordinates from the T22 V1.0 board. I will put the code online today but don’t know how github works, first have to figure that out.