TTIG Gateway PONGS error

Hi
I have some strange behavior on one TTIG Gateway. Any idea what is that error?
The TTIG No.2 works normal.

pong

So The Things Stack sends Websocket “Ping” messages to which the gateway should respond with “pong”.
If the gateway doesn’t, that’s a sign that there’s a connectivity issue with the gateway. If the gateway misses too many pongs, the network will disconnect it.

Is the internet connectivity of the gateway stable?

I will check the network.
Thanks for direction.

Hi gravi,
I have the same issue with my TTIG: is there any solution available ?

It was the Wi-Fi network problem. I bring TTIG home and it was OK from the start.

1 Like

Do you have any recommendations how to configure wifi router?
I have a Fritzbox and for a while the TTIG worked…but then the difficulties.
Maybe a firmware update changed something!?
Do you have any recommendations for the router settings?

Hi @NoHaWan I’m guessing you are in Germany? I have one of my TTIG’s deployed in Hamburg area also via a Fritzboz and every 3-6mo the ISP tends to try and run a firmware update in the early hours - usually it borks internet connection totally rather than just limiting ports or services but I find we then have to roll back the update! Then all good for general use and TTIG comes up ok. Have a look at your firmware updates in the console of the Fritzbox and see if your problems started around the same time…if it did roll it back and complain to your ISP about quality of update (I hear others have similar issues!) and maybe one day they will listen. BTW given these issues I dont trust ISP/Router/Security and then have another firewall set up as an onion layer behind it just in case :wink:

Thanks Jeff-UK!
Yes I am in Germany… sorry for my limited English competences:-(
Your suspicion with the firmware of the Fritzbox is a reasonable explanation!
A roll-back seems for me not a good strategy: several of them closes vulnerability issues!
I will contact AVM to see if they have any recommendations.
What I have discussed with an expert today is the usage of a powerline adapter. This could be also a reason.

I disconnected the power line adapter yesterday…so the traffic of the TTIG is now direct linked with the FritzBox WiFi…no change! Next step is the interaction with AVM (FritzBox).

I have now the answer from AVM: they say that there is no known issue with the Fritzbox software and the TTIG.
I have also given full access for the TTIG in the Fritzbox (exposed host).
This did not change anything. AVM stated, that with this (not recommend due to safety) all possible software restrictions would be eliminated…so another hint, that the problem may not be the internet router.
Is there anybody in the TTN community able to support?

The two most obvious tests are:

  1. Try the TTIG on some other network, ie don’t use your ISP & Fritzbox - which may mean you have to go to someone else’s office / house.
  2. Try the TTIG on your home network using a different router which you may have to borrow.

This will figure out which of the three items is the culprit.

Re

Easiest option is sometimes to just tether the TTIG to your mobile phone at same location, and if that doesnt work move to another location further away (1-2km?) and try again - that will tell you if its your network and also help eliminate any local environmental issues…

Absolutely, but sometimes the mobile network has restrictions - so if it works, that’s great and you can move on to test 2. But if it doesn’t work, try a normal connection.

I have in the meantime tried several things:
I used another TTIG which I bought a time ago…first same behavior with fast green blinking. After installing CLI and following the claiming procedure it is working!!!
So the Fritzbox should not be the problem for the first TTIG!

Nevertheless I tried the following:

  • tried to get a connection via a local hotspot with my mobile…no change: fast blinking
  • tried another WLAN (my neighbor was friendly enough to support this test)…no change: fast blinking
  • I deleted the gateway and claimed it with a new ID…no change: fast blinking.

So I have not any glue what I can do in addition to solve the issue!??

Any further recommendations are welcome :-))

Perhaps if we page @KrishnaIyerEaswaran2 and you send him your EUI and the GW ID he can see if there is any associated activity at the server. Where did you buy it? You mentioned earlier it worked for a while….when and for how long? Was that on old TTN v2 or under TTS(CE) aka TTN V3?

Yes please. @NoHaWan please DM me the problematic EUI.

Hello Krishna, here are the information (sent before via Mail…not sure if arrived)
Gateway ID: biengarten02
Gateway EUI: 58A0CBFFFE800E04

Hello Krishna, here are again the information (sent before via Mail…not sure if arrived)
Gateway ID: biengarten02
Gateway EUI: 58A0CBFFFE800E04

Any news about this issue?

hey there,

I checked the server config for your gateway and I don’t see any obvious issues there.