TTIG : The Things Indoor Gateway


(Luiz H. Cassettari) #295

My TIG stopped working too, no longer connects to TTN.

I checked the serial debug

2019-02-11 23:06:17.375 [AIO:DEBU] ssl_tls.c:6546 MBEDTLS[1]: mbedtls_ssl_read_record() returned -30848 (-0x7880)
2019-02-11 23:06:17.379 [AIO:ERRO] Recv failed: SSL - The peer notified us that the connection is going to be closed
2019-02-11 23:06:17.385 [AIO:DEBU] [2] WS connection shutdown...
2019-02-11 23:06:17.396 [TCE:VERB] Connection to MUXS closed in state 4
2019-02-11 23:06:17.404 [TCE:INFO] MUXS reconnect backoff 2s (retry 1)

I tried to Factory reset but still the same problem.

Someone have some idea about how to solve this issue?!


(Rmarsolla) #296

My TIG stopped working too (915Mhz), no longer connects to TTN since Feb 11, @ 03:40AM BRT.
Same issue as previous described


(Scott Waller) #297

Seeing the same thing. TIG and another gateway stopped showing as connected on 915 here in Seattle about 24 hours ago. Reset the wifi config on the TIG and shows green light on the TIG but NOT connected on the console nor will it accept joins.


(Scott Waller) #298

I see packets (sniffed the wifi network) going out of the network from the TIG going out.


(Vtomanov) #299

Looks amazing where I can order one ?

More detailed technical spec ?
(I want to install my own software build on it)


(Danico) #300

And my TIG has stopped over 27 hours ago. Solid green LED, has IP address, replies to pings, but not connected to TTN, all same as previous.


(Arjan) #301

For those reporting problems with the TIG, please be specific about the region (router) and frequency plan? (So far, I’ve only seen US915 mentioned explicitly?) And whether or not data is still shown in the applications/devices in TTN Console?


(Rmarsolla) #302

Hi Arjanvanb, Thank you for your help.

In my case:
Country: Brazil
Frequency Plan: US915Mhz
Router: ttn-router-us-west.

No data is displayed by the gateway (TTN), nor applications. This same gateway has already received more than 6,000 messages. The green led is solid as expected.

I have tried to change the routers (ttn-router-brazil, ttn-router-us-west, switch-router), re assign, re configure the device, and it didn’t work…

ps> The ttn-router-brazil never worked for me in Brazil :frowning: I usually use ttn-router-us-west.


#303

This beautiful little thing kind of confuses me. It might have been asked before, but is anyone aware of the reason for the design choice not to add a connector for an external antenna?

It sounds counter intuitive that it’s not present. It’s a minor modification and it would drastically increase the capabilities. Or is the business model that every household buys one for their own?


(Plumbum - Robert Plum) #304

The TABS Gateway was designed as a more or less private Gateway for personal use. Now that the limitations were removed (will be removed for private LNS) the capabilities might get limited by the design with internal PCB-antenna, but it is somehow logical, that this ESP-driven Gateway was never designed for “professional” usage scenarios. TIG is to increase indoor coverage and for public outdoor coverage one should use the TOG Gateway with (I guess) more power.


(Luiz H. Cassettari) #305

Hello Arjanvanb

My TIG:
Country: Brazil
Frequency Plan: US915Mhz
Router: ttn-router-brazil.

In TTN Console the gateway status is not connected, It was working for some time but for some reason lost connection.

On the serial monitor, the TIG still receive uplinks message from the devices nearby.

And I receive this error message: ssl_tls.c:6546 MBEDTLS[1]: mbedtls_ssl_read_record() returned -30848 (-0x7880) look like a mbedtls error MBEDTLS_ERR_SSL_PEER_CLOSE_NOTIFY

The system closes the connection and tries to reconnect, in a continuous loop.

It was so easy to configure but it’s not working anymore…


(Krishna Iyer) #306

What’s your EUI and what’s the frequency of these disconnections/re-connections?


(Arjan) #308

I’ve no idea, and only based on the word “MUXS”, just in case it helps: do log lines before that refer to contacting the Configuration and Update Server (CUPS)? The example log on https://doc.sm.tc/station/quick.html shows:

2018-11-09 10:25:54.849 [AIO:INFO]
2018-11-09 10:25:54.893 [TCE:VERB] Connecting to MUXS...
2018-11-09 10:25:55.809 [CUP:INFO] Starting a CUPS session
2018-11-09 10:25:55.810 [CUP:INFO] Connecting to CUPS ... https://s2.sm.tc:7007 (try #1)
2018-11-09 10:25:55.812 [any:INFO] cert. version     : 1
...
2018-11-09 10:25:55.858 [CUP:VERB] Retrieving update-info from CUPS https://s2.sm.tc:7007...
2018-11-09 10:25:57.092 [TCE:VERB] Connected to MUXS.

So, maybe a bit more context of that (great!) log helps the team. Or maybe not. :slight_smile:


(bluesensing) #309

I just learned, that you are not allowed to de_register a TIG gateway and re_register it again, because Gateway ID will be blocked. Because of security reasons. You do not have a second chance. Must be resetted manually… so good luck… when millions of…

That’s a really pitfall for beginners and NON IT professionals, i guess.


(Scott Waller) #310

US915 and ttn-router-us-west. Showed the gateway as disconnected and no data in the application. I have a test device that was sending to a TIG and now my sensor fails a join.


(Danico) #311

I am in Australia, using the meshed-router (thethings.meshed.com.au).
Set to Australia 915MHz freq plan.
No data incoming on the applications/devices/data screen, it stopped the same time as the gateway stopped being seen. Up until then, it had receiver over 4500 messages.
Changed to different router (ttn-router-asia-se), still no data.
Gateway status remains as ‘not connected’, an no app data.


(Ibelinp) #312

My gateway no longer shows up on TTN. It was working great and stopped connecting about 2 days ago. It is the 915 MHz model and it is located in Atlanta, GA. One interesting thing is that it has always been solid green with sporadic blinks at 4Hz for about 20 seconds then back to solid.
I tried changing the SSID to my other network and it still does the same.

Pieter


(Scott Waller) #313

There is a thread in the TTN Slack #support channel on this as well.
Do you have any devices trying to connect? I am still seeing join fails from end devices that were working now two days ago when the TIG was working.


(Arjan) #314

@KrishnaIyerEaswaran2 can the team please document what is/is not possible, or should/should not be done? And if this also affects a factory reset of the TIG?


(Krishna Iyer) #315

This TTIG US 915 issue must be solved now. :partying_face: