TTN GATEWAY central 2


(Ttn Shizuoka) #277

Version 1.0.5
TELEC certification, with LBT, I want Japanese specifications too.


(Kosternet) #278

Am I the only one that still does not have a stable TTN Gateway? The gateway reboots every few hours. As I need a stable solution, the TTN Gateway does not seem the right solution.

I have tried the following:

  • Place the gateway in a temperature-controlled space
  • Update (and update, and update, and update, etc…)
  • Re-activate (also many times)
  • re-install firmware using SD-drive
  • Install latest versions of firmware (including beta)

Still it does not work as promised. I have tried contacting TTN to work towards a solution, but after months and months of waiting, there is still no solution.
At this moment I am trying to return the gateway and get my money back, as the gateway has not worked for more than 10 hours continuously since I have received it.

My other gateway (Lorank) works like a charm.

Anyone knows how to get in contact with someone that can actually solve my problem?


(Jac Kersing) #279

Have you bothered to read the posts above yours? Check this post from TTP for the latest official news.


(Kosternet) #280

Hi Jac, thanks for your reply. I have followed lots of topics and hundreds and hundreds of posts, but stopped as I only read the same thing over and over again; I read in this last ‘official’ post, is that an other try is planned to have things solved in an other month.

My current feeling of the TTN Gateway is:


(Grahame Horner) #281

Ok, it’s been a really long time since I looked at any forums with regards the gateway and the firmware, what is the process required to get my gateway working given that it has the original/unstable firmware and I’ve not got any ability to flash?! given the refusal to even boot to the point where it reads the sd card?

Is there an option of returning the gateway for a working unit ?


(Scottv H) #282

For some time my gateway was working great. Sometimes stopped after a couple of days. but after replugging the power it was doing well again.
After some busy time where there was no time to work on a ttn application, I started working on the project again. Because I wasn’t using the gateway i have been storing it at my studio. To work at the application i got it out again. For half a day the gateway was working GREAT. but after lunch it was in a bootloop again… i noticed the Gateway did automatically update itself.

Since I have the PicKit4 I downgraded the gateway to the previous version (may), this worked for 30 min and then got stuck in bootloop again.
Tried different versions, Stable & Beta from may and most current one. none with permanent fix (max 30 min)

Noticed in http://things-gateway.local/info after installing .hex with PicKit IPE and configuring Gateway via https://activate.thethingsnetwork.org, all works for max 30 min. Then a bootloop occurs and “Broker Connection” won’t change to true.

first log after new instal & config:
08

After reboot:
55

Can’t get it to work anymore… :sob:


(Smbunn) #283

My understanding is that no gateways are currently working and the development team are still working on a fix which might still be months away. I have shelved my unit and only check this forum occasionally to see if they have posted that it is fixed.

In the meantime you have bought an expensive brick, like the rest of us


#284

My gateway runs perfectly since my last post from 3 may.

I flashed the firmware with the stable firmware and an other bootloader. Maby it still run because i have pulled out the piggy backed board to look at it and placed it back.


(roland) #285

I have a TTN Gateway running. It does some community service :-). Sometimes I check if it is still active through the console and it reports “last seen xx hours” which seems strange as it is connected all the time. Also the LED #3 is slowly flashing so it is “activating”.

Rebooting will connect the gateway again.

So is this normal? Can I force checking the gateway existence from the console? Or will a device that finds the gateway trigger the activation again?


(Bborncr) #286

There is a known reboot issue with the TTN Gateway. Earlier in this thread is a post from the developers stating that a new firmware update is going to be released in “week 30”. Which I understand is at the end of this month.


(The Things Products Team) #287

Hi all

We have been working on the fix for this gateway and have come up with a pre-beta firmware version. It would be great if we can test this with 5-6 users for whom the gateway ends up in a reboot loop. Please drop a line to info@thethingsproducts.com if you have a programmer or a SD-card to flash this new firmware version and we will send you the instructions further.

Will post the updates for the rest later this week.

Thanks.


The Things Products Team


#289

Dropped a line. Would be great if GW reliablity is improved.


#290

So far so good. Did have to do my daily reboot so far.


#291

The gateway shows the same issue as before. How can I debug the pre-beta ?


(Grahame Horner) #293

@smbunn I personally have given up on the public LoRaWAN vision that was presented via Kickstarter, and I’ve started seeking legal advice on how to start a claim against TTN for release NOT FIT for purpose goods and the lack of support is simply a JOKE on all fronts. After as you quite rightly point out +2yrs of waiting and many many months of trying to get some real support; I think it time the team face up to this a start issues a recall/refund to those that have NON functioning gateways. So much promised, So much Hype, and failure to deliver on so many fronts.


(The Things Products Team) #294

Hi all

The new version of the firmware 1.0.5 has been pushed to beta. It fixes the failing LoRa module issue which resulted in an unexpected reboot. There was a variation between the module and the gateway board which created the time related problem. All gateways that have automatic updates on will be upgraded to this version.


The Things Products Team


#295

o boy … :sunglasses:


#296

would you mind post direct link on this firmware hex and checksum file so we can put on a SD according to this documentation we don’t know what version are on the different links on the page.

Because as you may know, rebooting gateways (including mine) have no time to connect and update to this firmware


(The Things Products Team) #297

Sure, here is the link to the beta version of the firmware - https://thethingsproducts.blob.core.windows.net/the-things-gateway/v1/beta/firmware.hex


#298

Thanks, and the according checksum file should be
https://thethingsproducts.blob.core.windows.net/the-things-gateway/v1/beta/checksums

And looks like got a gateway revival :wink:

image

Anyway, note that SD card with FAT works also, worth mentioning the doc not only FAT32, because you can temporarily use a Raspberry PI SD card and put the 2 files on boot partition (in a folder named update), works like a charm, once updated (gateway up with new firmware), shut down the GW, remove SD card and put back where it comes from and restart your GW