TTN GATEWAY central 2


(Bborncr) #299

So far so good! I was lazy and just let the auto-update do it’s thing.
image


(Dellekom) #300

I can understand your standpoint. I’ve bought 2 TTN Gateways (v1) and had problems for a long time until I totally resetted the device and started from scratch configuring them. The devices are still not using the LAN so it seems but I can handle that because we have several gateway locations and some do need Wifi.

I’m part of our community the rolls LoRaWAN out in Freiburg. No one of them will purchase a TTN gateway which I find sad for it had a nice price tag. Next generation Gateways should have GPS anyway for better triangulation so this seems to be a dead end anyway.


#301

NO … this is about backend V3 :

There has been long discussions about what to do with gateway locations. For now we won’t make any changes, but with our upcoming v3 stack, we will rely on the registered location only, and not on the location that the gateway may or may not send (we will just ignore it completely).


(Dellekom) #302

I don’t mean the location accuracy of the gateway but only with a GPS clock it should be possible to find distances to the nodes from three gateways that help to find the node location with some precision.


#303

yeah sure :sunglasses:


(Bborncr) #304

Had to restart…I guess there are still some issues.


(Awk) #305

Are there plans to allow disabling Wifi, as mentioned here?


#306

Does this have the new Harmony middleware ?


(The Things Products Team) #307

No, not at the moment. Still needs to be updated to the new version.


(The Things Products Team) #308

Hi all

After testing the beta firmware 1.0.5 version last week, many gateways have seen significant improvement in their overall stability due to improvements in communication with the LoRa module. This morning we pushed this version to the stable branch and are seeing the gateways getting updated around the world. As mentioned earlier, this update addresses the LoRa module issue which was causing the reboots and one of the main reason for gateways working properly. Next on the to-do list is WiFi/MQTT stability along with updating the harmony version. In case the firmware is not getting updated on your gateway, you can install it via SD card or a programmer, see instructions here.

Will keep you all posted on further developments next week.


The Things Products Team


(Joost Lambregts) #309

Hi,
I just tried both the latest stable and bèta version, but I’m still having problems activating the gateway. The first two leds eventually go on, which should mean the gateway is connected to the internet. Then the third led flashes for a while, until finally it fails and starts over. This repeats until I reset the gateway.
Any suggestions?
Best wishes,
Joost


#310

image
Have you checked this connection


#311

Yes, that daughterboard connector seems to be a real problem. One of my gateways wouldn’t boot properly, and thus couldn’t update firmware, until I reseated the daughterboard. I’ll hopefully be able to try this on my other gateway this weekend, because it also isn’t installing the update (and been off the air for 3 months).

The big question is whether the firmware update is enough to fix the issue, or this connector problem is just going to keep coming back with time (thermal cycling, vibration, etc).

I wonder if @TTP have identified the cause of the connector problems, and if there is a suggested DIY fix? e.g. shaving off a small amount of PCB on the plug-in edge so that it seats deeper…


#312

Well for me, 1.0.5 worked ok for less than 24 hours but then stopped responding to LoRa packets.
This message was appearing on the debug port: LORA: Kick LoRa module with ACK after not acked it for 60s
Started working ok again after a power cycle. I’ll monitor it over the weekend.


(Abaretta) #313

I was wondering about this as well. It does seem to be a separate issue and I haven’t seen/read about any investigation into this from the TTN team.

I just got my gateway online again and even upgraded, but not without fiddling with the daughterboard (putting pressure on it, attempting to wiggle it a bit in its socket).

It is now running v1.0.5-fa89b993, we’ll see.


(Reinier van der Lee) #314

Auto updated to Firmware v1.0.5-fa89b993 and looking good. So far > 100,000 successful uplinks and 1,200 downlinks.


#315

I managed to get my other gateway to update with just a power cycle, but it was getting UART ERROR until I reseated the daughterboard.

I didn’t have any nodes with me (Doh) so I couldn’t check uplinks, but it was (and still is) showing a connection to the backend - which it hasn’t done for months.


#316

Replying to my own message: I noted that I am on 1.05 now (did not do anything to go from the previous 1.0.4b) and the gateway seems rock solid. I cannot measure any packet loss (i.e. reboots), working via wifi, more than 10K messages sent over the past 6 weeks.:+1:


(Siso) #317

Here also since 1.05 not any unexpected reboot.


(Joost Lambregts) #318

Thank you, this was indeed the problem.