TTN GATEWAY central


(Zubairhamed) #415

ah yep my gw is playing reboot roulette during activation too.


(Francois Bayart) #416

you can complete the github issue if you have more details or just +1 on the issue.


(Arjan) #417

Today, I’ve been sent new firmware to create some more logging, which I returned to TTP just now.


(Zubairhamed) #418

yep was given a new FW and i’ve up-ed the logs out to the GH issue.


(Arjan) #419

…but it seems the new firmware does not really log much more, if anything, if that was its intention. Peeking into the code (especially in the configure... functions in src/app_lora.c) shows some disabled logging that would be very, very helpful, I’d say. Maybe it’s time to compile my own version, some day…


#420

This may not help many here, since it relates to firewall rules rather then any gateway rebooting problem.

I had successfully activated a TTN gateway at home and then took it to another location where a device running m0n0wall firewall software generally limited traffic except to specified permitted ports or IP addresses.

I did the five second reset button push, after first powering on, to clear the previous, locked activation.

And when I tried to then to activate the device, the process stalled with one steady light plus one blinking light (i.e., checking for Internet) on the gateway. That was fixed when I opened outgoing access via the LAN to all UDP ports. When I tried to just add UDP access to destination port 1700 that didn’t seem to fix the problem for purposes of initial device activation.

At that point, the first three LEDs became steadily lit, with the fourth one blinking (i.e., gateway not successfully connecting to router). That was fixed when I opened up TCP access from the LAN to destination port 1883 in order to permit MQTT communication, as per the instruction here: http://www.hivemq.com/blog/mqtt-security-fundamentals-securing-mqtt-systems.

Then the activation completed successfully, and I was able to send traffic via the gateway using a TTN node.

I’m no longer at that location, but wonder if I could have further limited the outgoing UDP traffic after the activation was complete.


(Onehorse) #421

I just want to relate my experiences over the last few days with gateways. I am in the process of testing some end nodes and using two gateways, the TTN-915 and a Multitech MTCAP-915.

It was very easy to set up the TTN gateway by following the instructions on the website. It worked the first time and in less than an hour I had data showing up in my console. As a dummy Arduino user this was very gratifying. Setting up the MTCAP took a lot more work and I had to have someone at Multitech help me figure out how to connect to my laptop via wifi and help from a colleague on how to set up the packet forwarder, etc.

Both work well except:

The TTN gateway attempts to re-boot at least once every day, sometimes multiple times in a day as documented above. In these cases the console data stops updating. This was frustrating at first since I didn’t know if I had reached my message limit on TTN or my edge node had stopped working, and when debugging edge nodes this matters. Now when I don’t get the data I expect I check the TTN gateway which is usually waiting for a power cycle to get it back up and running.

The MTCAP has been running continuously for 24 hours now, sending data to the SEMTECH console and then being forwarded on to Cayenne. I was pleasantly surprised to find a complete record of the sensor data on both sites while the edge node, and the gateway, continued to run overnight.

My hope is that the TTN gateway can be fixed via a firmware upgrade soon since there is no reason it can’t run continuously and reliably also. But for customer network applications I think I will stick with the MTCAP for the moment since the costs are comparable and now that I know how to set it up, the ease of use is also.


#422

Is your TTN gateway connected to the Internet via WiFi? If so, could you try switching to an Ethernet connection?


(Onehorse) #423

Might be an interesting experiment since the MTCAP is currently connected via ethernet.


#424

On the TTN slack channel “Support” there was this exchange on Monday morning:

b: “TTN gateway; i now need to cycle power 2-3 times every day to make it work again. Any ideas?”

j: “From what I heard people saying is that you should put it on ethernet. They are working on a new firmware version that addresses wifi stability.”


(Dolphin) #425

I know this. In my case, the ethernet connection is then missing. If I connect them, and the wirless is also available the loop restart…


(Dolphin) #426

My gateway still not works. If I switch of the wireless network, for a short time I see : 2018_02_07-WLAN-OFF-NETKrausrein-3LEDS|351x500… then reboot. The message broker never works…


(Dolphin) #427


(Dolphin) #428

If I activate the wireless network again:

.
Gateway Card: ND and Config is false ???


(Dolphin) #429

If WiFi and Ethernet are available, the gateway never reboot - but also config correct is false an Gateway Card is ND. For ever! After power on and off, the reboot start again, if wireless is off! But in this case for a short time Config correct: True…etc. then reboot.

My Wireless Gast-Lan is:Things-Gateway… and Login: thethings.


(Arjan) #430

Are you saying you created a guest account on your home WiFi, using the credentials from the activation documentation?

If yes, that’s not needed: the TTN Gateway itself will become an access point (AP) when it has no internet connection, and then that AP can be accessed using those details. That AP then allows you to do the configuration for the actual WiFi, allowing you to enter whatever password it needs.

(When connected using ethernet, you can access it using http://things-gateway.local, but I think you know that.)


Student badly needs help with the IC880A and RPi
(Dolphin) #431

Thanks, I know that, was only another trial. I asume there is a software (or hardware) error in the firmware with this gateway slot.


(Dolphin) #432

There is no Interface and Wifi SSID Section (after Connected:)? Is there a way to switch that off?


(Mrtn78) #433

My gateway has the same problem - stuck in a loop.
I tried setting it up 3 times without any luck. The current gateway id = katwijkaanzee01
Has anyone any suggestions how to get this working?


(Holtrop) #434

also stuck in a loop