TTN GATEWAY central


#1
  • this is the central topic for all questions and answers regarding the TTN GATEWAY

ttn -gwtopic

where to buy :

getting started :

part 2 is HERE


Activation of TTN gateway (backer edition) problematic
Trouble activating, accidentally did full serial flash; how to recover?
TTN Gateway Diagnostics
TTN Gateway activation
Where can I find the datasheet for TTN gateway?
Firmware versions
TTN Gateway - FAQ
TTN Gateway - FAQ
Gateway not registering
5 blue LED's blinking flash every 7 sec
TTN gateway keeps disconnecting
TTN GATEWAY central 2
TTN Gateway - FAQ
What is the internal USB socket?
No LED, no UART output on TTN Gateway after reset
TTN gateway restart after "activated" step
TTN Gateway - FAQ
Gateway not starting
TTN Gateway activation hangs
TTN Gateway connection lost (last seen n hours ago)
TTN Gateway - FAQ
FingBox log on TTN-Gateway behaviour
(Gfernandes) #3

I wanted to know the kind of GPS and other details used by the TTN gateway. Can anyone direct me to the link of the datasheet of TTN gateway that has all the details inorder to evaluate it before purchasing? Thank you.


#4

there is no GPS build in… here some more details, I don’t know if there is a enhanced tech document available at this moment.


#6


(Leondegeling) #7

Hi, today I received my TTN gateway and have spent over 2 hours trying to install it.
It seems stuck when it tries to connect to my wifi. It cycles from 1.5 leds trough to 2.5 leds but never connects. I am sitting a meter from the fritzbox so milage should not be a problem. Is there some reset button on the device or is there another way to really restart the installation? I have no idea how to proceed.

thanks for any help


TTN Gateway activation
(Jac Kersing) #8

There is a button inside the gateway. To open it, put it down with the antenna socket at the top and (gently) lift the left and right sides of the white shield. (To close align the lid and push firmly at the sides only you hear it snap in place)

To reset, power on while pressing the ‘Mode button’ shown in the picture above (it is the pink one in the middle of the PCB). All leds should flash for some time.

I haven’t succeeded in using wifi, after three (failed) attempts I just reset the unit and put a network cable in.

@johan Are there known issues with WiFi? Is there any way to debug it?

Did you order from Farnell/element14?


(Arjan) #9

I doubt it helps (and if it’s useless, then feel very free to delete this post), but there’s a February 2017 sneak preview on YouTube:


#10

Configuration

The gateway is configurable via the https://activate.thethingsnetwork.org.

Device information can be checked locally by the internal web server’s /info​ ​page. If all is well then the gateway registers with DNS name things-gateway or things-gateway.local, so once connected to your WiFi or ethernet network then http://things-gateway/info and/or http://things-gateway.local/info might work without the need to find its IP address.

Once activation is performed successfully, the configuration is locked and can be only
unlocked via an erase.

Reset Button

  • Pressing the button shortly while powered on restarts the gateway.
  • Holding the button for 2 seconds while powered on it erased the WiFi settings.
  • Holding the button for 5 seconds while powered on it erases the WiFi settings and activation settings.
  • Holding the button while powering on it will erase the full serial flash

LED Indication


LED State Reason Cause User Action
1 - Power Off No software is running No power; Incorrect firmware loaded. Make sure the device is powered and the correct firmware is loaded.
  On Software is loaded    
  Slow Software update in progress   Wait
2 - Internet Fast No Ethernet or
WiFi connection.
Only possible way
to connect is via
the Gateway’s
AP.
No Ethernet link and WiFi connection failed Connect to TTN gateway - AP
  Slow Checking for internet    
  On Has internet    
3 - Configuration Fast Bad configuration No ID Need to configure a gateway ID on the device
  Already activated Need to configure valid key on the device
  Invalid key Need to configure valid keey on the device
  No router Need to configure router in the TTN console
  Invalid URL Correct URL in the TTN console
  Slow Activating    
  On Activation successful    
4 - Connection Slow Connecting   MQTT
  On Connected   MQTT
5 - Activity Single Uplink/Downlink    

Note:

While on step 2 of the activation process - “Connect to the gateways WiFi access point Things-Gateway-XXXX”, make sure to forget the WiFi access point from your computer once you move to step 3. Otherwise it will keep interfering with the gateway.

We are working on releasing an extended version of the FAQ section for activating the gateway. Will be posted early next week.


(Leondegeling) #11

So today I resetted the device (power up holding the pink button). I went through the setup again, this time I connected an ethernetcable.
I am able to connect to the device using things-gateway-xxxx but as soon as I hit the configure button all leds turn of and on and it starts the following sequence

[No leds
Five leds
1.5 leds
2.5 leds
2 leds]
repeat

To me it sounds like some watchdog timer is going off that resets the device just before activation. When it resest all leds on the pcb also turn off for a moment. The units looks good and undamaged, I see the orangs led on the networkconnector flashing every now and then. All connector seem in order, there are no jumpers on the pcb.

When I browse to the device and go to the /info page I get

Version Info
Hardware: v1
Bootloader: r1-7167873a (2017-06-02T13:48:18Z)
Firmware: v1.0.0-917719b9 (2017-06-26T17:59:33Z)

Network Uptime:365
Connected: true
Interface: WIFI & Ethernet
Wifi SSID: wijkaanzee

Configuration
Activation locked:true
Config correct: false
Region:
Gateway Card:ND

Packet forwarding
Broker connection:false
Packets up: 0
Packets down: 0

Miscellaneous
External storage:false

I guess the config correct being false is not a good thing but i have clue how to correct this

Any help or ideas would be greatly apreciated, I can’t wait to get started.


(Arjan) #12

I guess so too… So, did you try the following?

(I’ve no idea; I’m just repeating what I read above.)


(Jac Kersing) #13

My gateways info page shows only Ethernet. When I tried to have the gateway connect to WIFI it would not work, to get it to connect to Ethernet I used the ‘push button while power on’ method where I held the button for over 10 seconds.

With regards to the ‘config correct’, take a look at the gateway information in the TTN console. (https://console.thethingsnetwork.org/), go to your gateway settings page.
Check the frequency plan is set to ‘Europe 868MHz’ and the router to ‘ttn-router-eu’. Please make a screen shot if these values are not set to these values and post it, next correct the values and save them. Then reboot the gateway.


(Jac Kersing) #15

Hi @rish

Thank you for the detailed information, very useful.

However I am looking for an option to debug why the gateway will not connect to my WiFi. During setup the SSID is shown as a choice once I type the first character so the gateway sees the router. However after entering the password and saving the configuration the gateway refuses to connect to WiFi.


(Leondegeling) #16

I resetted again and again and again but it will not send its first message, not in wifi mode, not with the ethernet cable. I did check the gateway information as you suggested, the router was set to [dev] instead of [ttn-router-eu]. I changed that but it did not help at all, I still get not further.


#17

how is the situation now… did you get it to work ?


(Leondegeling) #18

No, I tried everything I can think of, resetted numerous times, tried wifi and ethernet doublechecked everything but the device will not register and not send messages. I have not found any usable documentation and I have no idea how to get any support.


(Bsiege) #19

That gives a bad feeling about the first gateways out in the wild. Not another “WiFi-Gate”, please!!! Bluetooth is on board but not supported yet? Anyway, i do not need BT and WiFi. Hope at least LoRA and Ethernet works as intended.


(Arjan) #20

@kersing, @Leondegeling, I’d doubt it matters for the firmware, but just in case it helps TTN debugging:

Do you have any idea which of the many IEEE 802.11 versions (802.11b, 802.11g, 802.11n, 802.11ac, …) and frequency (2.4 or 5 GHz) your WiFi access point and your gateway have selected to use? Can you see some activity in the admin interface of your WiFi access point?

@rish, any requirements for the WiFi?


(Pfiadi) #21

I had a hard to configure my ttn backer edition gateway which I received from Farnell yesterday. Unfortunately it keeps rebooting for unknown reasons (Wifi or ethernet make no difference). Every now and then I can see it in my TTN console for a few seconds. Any idea what is going on?


(Leondegeling) #22

My ap is a fritzbox supporting a, b, g, n 2,4 ghz and 5ghz


(Siso) #23

Here the same, the gateway is working ( ethernet cable ) but rebooting often.