TTN GATEWAY central 3

  • this is the central topic for all questions and answers regarding the TTN GATEWAY

where to buy :

getting started :

part 1 is HERE
part 2 is HERE

I have found that this combination of bootloader and firmware at least works on TTN gateway’s of me and some colleagues:


I see a difference in the bootloader version.
The firmware + bootloader has been flashed with the PICKkit 3 programmer. We took the stable version

How do I set a static IP address and gateway if I don’t have DHCP in the network?

Same for me. It was a lot of money, and my gateway (The Things Gateway, backer edition) never worked so far.

On September 22nd, I updated the firmware to the stable version, available since July, via an SD-card. The update went well (gateway info screen shows the new firmware version), but still the gateway won’t activate / register. See my posting in topic “TTN GATEWAY central 2”. Without any response, by the way.

Looking at how the gateway behaves, nothing seems to be wrong, except that it can not activate over the network. To exclude the possibility that the netwok causes this, I have also linked the gateway to my phone’s hot spot for activation. Did not help.

Will try again shortly, because I have changed a defective switch in my home network recently.

With regard to receiving answers to your questions: on the forum, there are other users responding, depending on the question of course. But, regarding warranty, replacement, etc: I am not very optimistic about that, based on my own experience.

I don’t think that’s possible … but to be sure … @htdvisser ?

I don’t think our current builds can do that, but I do remember there being some kind of fallback IP if DHCP fails. You can probably bake a static IP into the firmware by making some changes with the Microchip Harmony Configurator. Maybe @KrishnaIyerEaswaran2 can answer this properly when he’s back from vacation.

Hello Martijn,

You could test at the first with a small switch, your laptop (with tftp32/64) and the TTN gateway.
But everything together. TTN-gteway >> Small switch >> Laptop

Make give your laptop a Ip adress ( (
Start tftpd64 (32) and activate DHCP with a small scope range til
Connect the TTN-gateway to the swich and powering up
Check in de tfpd on your laptop on distribute a ip adress but it should (the first off the range)
go with your browser to you should see something like

This is the view off a updated gatewat with version 1.05 on it. If not or even you don’t get this page something is get wrong with DHCP or with your gateway.

But if this work you have a working gateway, and you could go futher. to try to connect the gteway to the TTN network.



For Windows you can run a portable DHCP server with this: . Very user friendly and easy to understand. There’s a wizard included allowing you to set the address range, gateway, etc.
I used dhcpserver to get the Gateway running, which is fine during setup but not for a long-term unattended situation.

I bought an Gateway from Farnell tand now I am stuck in the registration process. It will not activate. LED 1 and 2 are steady and led 3 blinking slowly.
It seems like the gatway ends up in a rolling reboot after trying to initiate dhe LORA Module
I tried everything by now: Reset, flush reseeting the module es advised in recent posts and so on but no luck. The gateway is running on fw 1.0.5

Any help would be appreciated

  • The Things Network *
  •  G A T E W A Y     *

Firmware name: AmazingAckermann, type: 0, version: 1.0.5, commit: fa89b993, timestamp: 1531815112
Bootloader revision: 2, commit: c463e87e, timestamp: 1519396960
Build time: Jul 17 2018 08:12:51
Reboot reason: 0x03
BOOT: (persisted info) 6F 72 72 65 01 03 B1 60 AB 25 22 24 B5 73 D7 64
WIFI: Entering state 0
WIFI: Entering SCAN state 0

MAIN: Initialisation complete
LORA: Changing state from 0 to 0

MAIN: Leaving state 0
MAIN: Entering state 1
FLASH: Magic bytes found: wifi config present
FLASH: Magic bytes found: activation data present
FLASH: Magic bytes found: FOTA data present
FLASH: Loading Firmware Data
CNFG: (Firmware HASH (sha256)) 93 F4 C1 0E 77 81 3F 60 0D A8 A5 97 57 7C DD 9C 95 64 1F DF F4 8D 44 3F 92 9A 20 A9 2D B4 B9 F5
FLASH: Loading WiFi Data
CNFG: WiFi SSID: 1234
CNFG: WiFi key: ***
CNFG: WiFi conn_type: 1
CNFG: WiFi sec_type: 4
FLASH: Loading Activation Data
CNFG: Gateway ID: valaisia
CNFG: Gateway Key: ***
CNFG: Account Server URL:
CNFG: Locked: true
CNFG: Locked first time: false

MAIN: Leaving state 1
MAIN: Entering state 2
INET: State change to 0
LORA: Initialisation complete
LORA: Changing state from 0 to 1
WIFI: Entering state 1
ETH: IP Address:
WIFI: Entering state 2
WIFI: Disabling modules
Head magic match void: trying to free an already freed block, ignore
WIFI: Entering state 3
WIFI: Enabling modules for client
WIFI: Entering state 6

WIFI: IP Address:
SNTP: State change from 0 to 1
INET: Gateway has Ethernet
INET: State change to 2
INET: Connected to a network, waiting for DHCP lease, checking validity with ping
SNTP: State change from 1 to 2
ETH: IP Address:
INET: State change to 3
INET: Ping probe
INET: Error sending probe on WiFi
INET: Ping response from PIC32INT, set as default
INET: State change to 4
LORA: Wait init complete, waiting for application.
LORA: Changing state from 1 to 2
SNTP: State change from 2 to 3
MON: SYS Stack size: 3965
MON: TCPIP Stack size: 3815
MON: APP Stack size: 8008
MON: LoRa Stack size: 3913
MON: heap usage: 179KB (188KB), free: 160KB
SNTP: State change from 3 to 4
SNTP: State change from 4 to 5
SNTP: State change from 5 to 6
SNTP: State change from 6 to 7
INET: State change to 5

MAIN: Leaving state 2
MAIN: Entering state 3

CNFG: Load online user config state change to 4
HTTP: Close active socket 0
HTTP: Starting connection
HTTPS: Connection Opened: Starting TLS Negotiation
HTTP: Wait for TLS Connect
HTTP: TLS Connection Opened: Starting Clear Text Communication
HTTP: Got 1290 bytes
CB: Disconnect
HTTP: Connection Closed
HTTP: Close active socket 1
CONF: Parsing response token: HTTP/1.1 200 OK
CONF: ROUTER URL: mqtts://

CNFG: Load online user config state change to 6
HTTP: Starting connection
HTTPS: Connection Opened: Starting TLS Negotiation
HTTP: Wait for TLS Connect
HTTP: TLS Connection Opened: Starting Clear Text Communication
HTTP: Got 1232 bytes
HTTP: Connection Closed
HTTP: Close active socket 1

CNFG: Load online user config state change to 7

CNFG: Configuring LoRa module
LORA: Changing state from 2 to 3
LORA: Starting reconfiguration
LGMD:Command, cmd: 0x31, size: 0
MON: SYS Stack size: 2861
MON: TCPIP Stack size: 3815
MON: APP Stack size: 3294
MON: LoRa Stack size: 3887
MON: heap usage: 183KB (269KB), free: 156KB
LGMD:Timeout on cmd: 0x31
LORA: Configuration failed, retry
LORA: Starting reconfiguration
LGMD:Command, cmd: 0x31, size: 0
LGMD:Timeout on cmd: 0x31


Does anyone know where I can get the cct diagram of the ttn gateway?
I have it in my attic with an aerial mounted on a pole above my roof and I want to see what is going on from the uart port provided on the PCB of the gateway. Obviously I don’t want to run cables all round the house to the attic so I have RS232 to wifi kit set up ready so I can take a look from my PC.

In doing that I notice a bunch of other pins made available in the gateway too and it would be nice to know what I can / or might want to use. And that can only come from knowing what all the pinouts are.

Thanks in advance

1 Like

Thanks a lot for the links, I searched for days on the net and this just didn’t come up at all.
It is exactly what I was looking for.

Many Thanks again

1 Like

The firmware for The Things Gateway is open source and can be found on The latest release is version 1.0.5 from July, and there have not been notable changes since then. If you would like to be involved with firmware development, just use Github to open issues and submit pull requests.

In case anyone has the weird rebooting issue with the TTN gateway, here is a link to my post : TTN Gateway won't register, just reboots


My name is Ketil, I’m from Norway, and this is my first post here. Pleased to meet you all! :slight_smile:

After running The Things Gateway indoors for some weeks, I finally got around to mounting an outdoor antenna last weekend. I was delighted with the result: The gateway was now picking up packets from nodes almost 5 kilometers away. My delight was short-lived, however: After just a few hours of operation with the outdoor antenna, the gateway went deaf and is now only picking up transmissions from the weather station I have in my garden.

I examined the past transmissions (from my garden), and noticed that the RSSI before the range drop averaged to between -50 and -60, while the average after the drop is between -80 and -90. The SNR is more or less the same as before – between 9 and 12, approximately.

After some searching, I found a few similar issue reports on GitHub:

Are the above symptoms indicative of a defect LoRa card? Or are there other explanations for the sudden range drop?

Kind regards,

Have you checked for moisture penetration of antenna connectors and feed or if there is developing corrosion or temperature related issues. I guess where you are you have probably seen a decent average temp drop over recent weeks and your install will see this since going outdoors. I saw similar issue on different type of gateway at start of this year when we had a short sharp cold period - a previously good GW suddenly lost the plot! - and it turned out to be a connector on a 2m ant feed was ‘tight’ but not tight enough and as temp changed mechanical effects caused connection to loose a little integrity dropping 40-50db of signal…slight tightening solved for me…good luck :slight_smile:

1 Like

Thanks for your reply, @Jeff-UK! It’s appreciated.

The temperatures are indeed falling here, and condensation and freezing was one of my first concerns. I have tried changing cables, though, and have tested the equipment both inside and outside after the range drop. I also tried changing the pigtail connector. Alas, the problem is frustratingly consistent, and there is nothing more to swap except for the LoRa board itself.


what hardware version / bootloader / firmware have your TTN gateway

Hi @BoRRoZ,

Thanks for your help. The details are as follows:

Version Info
Hardware: v1
Bootloader: r2-c463e87e (2018-02-23T14:42:40Z)
Firmware: v1.0.5-fa89b993 (2018-07-17T08:11:52Z)

Kind regards,


I would like to change the network server that the The Things Gateway is forwarding to. Is it possible (like in other gateways where global_conf.json or local_conf.json are edited)? Specially, I would like to make it forward packets to our private network in The Things Industries (network server address:

I would also like to configure the gateway with a static IP on ethernet. Is that possible? Or can the gateway’s IP only be assigned by DHCP?

Thank you.