TTN UNO rn2483(A) questions


#1

moved from TTN support topic

Hi,

Short question : Is it possible to get the sketch (code or compiled) which is supposed to be pre-installed on the Things Uno (so it shows up on the map here https://ttn.fyi/activate)?

Background : I’ve just started for the first time my Uno, but I don’t get any serial output using “Serial monitor” of the Arduino IDE or putty. I’ve tried different baud rates, but nothing actually comes out from the Uno. Nothing shows up in the map either, here https://ttn.fyi/activate/ (I had good coverage there with my “Things Node” last week). It seems that nothing is pre-installed. I know I can compile and transfer my own sketch, but I wanted to use the pre-installed app before.

Thanks for helping.


#2

what type of computer and OS do you use ?


The Things Industries The Things UNO
(Didros) #3

I’m using Windows 10 to run Arduino IDE.


#4

The Things Uno is based on the Arduino Leonardo, yes I know a bad name choice , confusing because its totally different then an Arduino UNO.

Connecting should be done like you connect a Leonardo to your computer.
The TTN UNO uses a software UART while the original UNO uses a hardware UART.

So if you have the board connected and you goto Tools-> Serial Port -> you must be sure that the board is connected to the right port.
If you don’t see the port you can :

Upload a sketch (for example blink) and press the reset button of the board during compiling.


(Didros) #5

Thanks. I’ve checked the COM-port and I’m sure it is set correctly, as I can see it as well in device manager showing up with the name “Arduino Leonardo (COM11)”.


#6

that’s ok then.

and you have the TTN lib installed ?

ttn%20uno1

I have a TTN UNO on my desk now and also win 10 So we will find the problem.

-1 change USB cable (sounds stupid but it happend before)
-2


(Didros) #7

Yes I do.
image
But just to make it clear - I haven’t tried yet to compile and upload a sketch as I wanted to use this standard pre-installed app. But since it does not seem to be installed, I wonder if I can get it to upload it in my Things Uno.


#8

ah… well then compile/install device info from the examples and open the terminal… write down the info you get from the board because you’ll need it later

question: do you own a gateway ?


(Didros) #9

Thanks. But I suppose “device info” will not make my Uno appeared on https://ttn.fyi/activate ?
I don’t own a gateway (yet :slight_smile:).


#10

So you powered the new UNO and nothing happend ?
if there is no gateway listening in range you also won’t see it.


(Didros) #11

Yes, that’s right. New UNO, nothing happens.
If no one from TTN can share the app, I’ll do it the “Quick Start” way.
Thanks for trying to help @BoRRoZ :slight_smile: It’s much appreciated.


(Didros) #12

I think I found the issue : my Uno gets stuck in the function ttn.showStatus(). It never returns.
I can see that from the serial output, after uploading a new sketch (using DeviceInfo as a start point) and putting some delays so I get time to start the serial monitor.
Is that a known issue? I’ll do some research in the forum, perhaps I find an answer there.


#13

good idea… read and search a bit, and in your case its important to be sure that there is a gateway receiving your TTN UNO signal.


(Didros) #14

Do you mean that it is normal behavior that the function ttn.showStatus() does not return if there is no gateway?
I tested the Things Node last week, and it never got stuck, even though they was no gateway available.


(Didros) #15

After some hours in reading, understanding and testing, I found out that the issue is the RN2483, being mute, never answering to commands! Is it sleeping, dead?
I verified this with 2 sketches.
With DeviceInfo, the method ->readBytesUntil never returns a message (only 0).
With PassThrough, function loraSerial.available is never true -> nothing to read from RN2583, even though command “mac get deveui” is sent.
Any suggestion on what to do next? Any way to “wake up” the module, sending some control control char, hard reset, upload of new firmware (I doubt this will work).
Thanks.
Update : I downloaded the Microchip LoRa Dev utility, but it does not detect any device (PassTrough used, correct COM port detected).


(Didros) #16

Thanks, but cable is working fine (I have 2 and both works with a Things Node and other Wemos projects). Sending and receiving from the PC to the Things Uno works fine, the problem in receiving from the RN2483.
(I think it is USB 3.0 yes, but again, the problem is not between the PC and the Things Uno, but between the Uno and the RN2483).


#17

steps

  • in the arduino IDE under File / Preferences / Show check verbose output during upload

  • in the IDE under Sketch / Include Library / Manage Libraries / The Things Network Arduino Library / version 2.5.12 OR 2.5.13 (no lib problem)

  • reboot arduino IDE

  • remove USB cable and insert again

  • select Board ‘‘Arduino Leonardo’’

  • select Port ‘’ COM 1x Arduino Leonardo’’

  • Load sketch from File / Examples / TheThingsNetwork / DeviceInfo

  • Load File / Examples / TheThingsNetwork / DeviceInfo

  • change line 7 with the right plan #define freqPlan TTN_FP_EU868

  • verify (sketch uses 6268 bytes(21%)

  • press and hold reset button board

  • press upload sketch !

  • because you’ve set verbose output previous , its possible that you see the compiler searching for a port

leo2
the moment you see this… RELEASE resetbutton

now the sketch should upload , when done without errors:
start serial monitor… the board should respond like this after some time

leo3


(Didros) #18

Thanks, all this work fine, except that showStatus never returns :disappointed:
image
I actually tried a lot of things, like this one below, but no way to establish contact with the RN2483 chip.


(Didros) #19

Is the hardware documentation / wiring available somewhere? Can’t find it. Thanks.
PS: for the Things Node, not for the standard Leonardo nor the RN2483.


(Arjan) #20

See https://github.com/TheThingsProducts/uno, including a PDF.

For the The Things Uno, right?

(Worst name ever. Also, I guess you just got a faulty device; return/change it?)