Unable to register device with meshed-handler


By mistake (sort of) I’ve deleted my application in which I had 10 devices activated. I’ve created a new application under a new name. I then activated all the devices in that new application. This worked great for 8 out of 10 devices. For the other two I get the following error:


When using the CLI it returns the following error:

  INFO Using Application                        AppEUI=0059AC00000FFFFF AppID=binella_as2
  INFO Discovering Handler...                   Handler=meshed-handler
  INFO Connecting with Handler...               Handler=thethings.meshed.com.au:1904
 FATAL Could not register Device                error=Could not set device on Handler: permission denied: Broker did not set device: permission denied: NetworkServer did not set device: permission denied: No "devices" rights to Application "binella_as" source=Wrap: /builds/thethingsnetwork/ttn/utils/errors/errors.go:249

The devices that I’m trying to add have the following dev_eui:

  1. 4e084b97b997d5bd
  2. bab88701cbd87ed3

It appear as if my devices (or the old application) still exists somewhere and I can no longer make any modifications to it. Maybe someone from TTN can have a look at this?

Thank you!

I’ve never seen anyone get a database entry change due to issues with replication across the clusters that run TTN.

So whilst you wait for a response, I’d recommend starting a plan B & a plan C.

So if it is impossible to add those devices to an application, what other options do I have?

Nothing is deleted due to cluster propagation issues. Hence the warnings about deleting.

You’ll need to give the devices firmware new EUIs.

Hi @Farm21. Can you try changing the AppEUI on those devices? In some circumstances, it’s the DevEUI/AppEUI combination that is the problem, rather than the DevEUI itself.

I’ve tried to add the device with a different AppEui in the same application, that works. Only problem is, the device is already out in the field. Although we’ve build in an option to change this over the air, I’ll need an initial connection to do so. I guess we’ll have no other option than to get them back.