Unable to run latest ttn-lw.cli.exe on Windows 10. (Error Image Inside)


This is the issue now, on my private PC, outside the local authority.

I’m using the latest version, as far as I’m aware.

This happens after entering any command related the to ttn-lw-cli in cmd. I believe this started after the authorisation.

This topic follows after this one: Can't verify my email for access to CLI, please help! :) - #10 by pcciot-administrator


exe is not blocked in firewall:



This shows in cmd after windows error occurs.

Using 3.15.1

That looks very much like a Windows hasn’t cleared the app as being known good or generally OK to run - something I suffer on macOS, not so much on Windows (as fundamentally I don’t use Windows, so it’s harder to come up). But I do have a Windows 10 machine on my desk - let me give it a try.

1 Like

Thanks :slight_smile:

I tried running a command in admin cmd, with “run as admin” enabled in the properties on the .exe.

Still got exactly the same error as above.

Always worth starting a Command Line / Console as Administrator as another way to escalate privileges.

1 Like

Woke up my Windows PC - technically it woke me up as it did the Windows-update-auto-reboot thing.

Downloaded and ran the ttn-lw-cli v3.15.1 to setup for the TTS CE that I was logged in to from a standard command prompt.

No blocks, no issues, can use the CLI as I expect, which I am reasonably familiar with.

I’m running Win 10 Pro 20H2 OS build 19042.1237 with Windows Feature Experience Pack 120.2212.3530.0.

I use the built-in security / anti-virus etc as the machine doesn’t get a lot of use and I’m not inclined to opening up special zip files offered to me.

The next step we generally recommend is get hold of someone else’s machine - preferably a machine that’s definitely never passed through the hands of Mordac or gone anywhere near a corporate IT dept which may have turned on “settings”.

Thanks for trying to re-create the issue. I confirm that this error is taking place on a PC that is completely detached from the local authority IT dpt. It is my own personal PC. Standard windows defender is the only thing active, and the ttn.exe has been checked for any antiviral barring.

I’m going to attempt a fresh install on said home PC when I get the chance. It worked to begin with, something changed since then. I’m also wondering if my ip address may have been blocked from the other side, perhaps because of a typo-ed password. So I will try with a vpn, although that’s likely to raise fun little bugs of it’s own.

Not something I’m aware that TTI enforce / do. All the settings are in the yml file so if you delete that you can start afresh. The CLI is a statically compiled Go runtime so there are no dependencies on anything.

I’m on Virgin NO so the older CLI for v2 wouldn’t work. Virgin NO also block most VPN’s but thankfully the CLI for v3 works fine.

Before you put yourself through the long long slog of a Windows reinstall, I’d strongly urge you to kidnap someone else’s laptop or similar. Or try the VPN route first.

Managed to make connection with fresh download and reconfig.
Also used VPN, I think the fresh download was the resolution. Very odd.

I also found the below useful, for anyone else struggling with set up:


Remember to apply the below:

ttn-lw-cli use eu1.cloud.thethings.network --fetch-ca --user --overwrite
ttn-lw-cli login

Very worth noting…
Any reference to [application-id] or [device-id] should not be confused with individual sensor App/JoinEUI or DevEUI respectively. They refer directly to the application name given in the usual online gui. And the device id that is usually autogenerated during device adoption (this can be manually filled. You can find this in the GUI or using the below 2 commands in CLI:

ttn-lw-cli applications list
ttn-lw-cli end-devices list [application-id]

Good luck any fellow CLI noobs that find this! :slight_smile:

PS: My purpose for all this fun was changing an end device (sensor) to this: --mac-settings.desired-rx1-delay RX_DELAY_1

This is a common issue but I’ve run out of typeface sizes when I put ID <> EUI on the forum!


@descartes Haha, yes, I imagine that comes up a fair bit, at least I can help add that for you now :stuck_out_tongue:

Perhaps in some new fonts and colours?.. :slight_smile:

Thanks for all your replies!

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.