Unable to view gateway list

Dear sir,

When I clicked Gateways from the top manual bar, I cannot see the list of gateways (The Things Network Console). There is a message showing “There was an error and the list of gateways could not be displayed” (as shown below).

Under “Show details”, there is json showing:

  "code": 7,
  "message": "error:pkg/identityserver:insufficient_rights (insufficient rights)",
  "details": [
      "@type": "type.googleapis.com/ttn.lorawan.v3.ErrorDetails",
      "namespace": "pkg/identityserver",
      "name": "insufficient_rights",
      "message_format": "insufficient rights",
      "correlation_id": "c390bf49ca0545b6aedf8136949e433d",
      "code": 7

May I know what do I need to do to see gateway list?

Thank you very much.

We’re you previously able to view the list of gateways using the same account?

Are the gateways yours? Does anyone else have access to the gateways (and inadvertently modified your permissions)?

I am having the same issue on nam1 this morning, 11/26 11am EST. I am the owner of 4 gateways. No one else has permission to alter permissions. They were visible 11/24. Same error as above, except

"correlation_id": "d274f5bbc2704db1b134ae453baa423e"

Everything looks OK for me at The Things Network Console

I have the exact same issue.

I have admin permissions, and I have checked that these permissions have not changed. I could see our Gateways at some point 10 days ago, and late last week I got the same issue with the same error message as reported by kianpengyong.

One of my colleagues who also has access to the Gateways can see them just fine, and he can see my permissions are still associated with each Gateway.

what are the id or eui of the gateways

I too am having this issue. Now on two accounts.

I was unable to see the list of gateways starting a couple of days ago. Asked a colleague to check their view and they could see the list of gateways.

So I created a second ttn account and added it to my organization, which has rights for all my gateways. I logged into the new account and was able to view the gateway list. I was looking at the permissions on a few of the gateways and then when I went back to the list view I got the error on my new account.

Weird thing is, if I have the link to a specific gateway I can still access it. I even copied the link over to my other browser where I was logged into my original account and I was able to view the gateway. But still cannot see the gateway list due to the error. Seems like it’s an issue server side effecting the gateway overview list.

Observation 1: When a user (User A) being added into an existing Organization (Organization X), this user will not be able to see GatewayList. When this user is removed from that Organization, this user will be able to see GatewayList again because this user is also in another Organization which is also one of the collaborator of this Gateway.

Observation 2: When a NEW Organization (Organization Y) is created and add the same user (User A) into this new Organization and assign this new Organization into a Gateway, user will be able to see GatewayList with this Gateway as one of the entry.

So … I suspect it is something related to a specific Organization or Collaborator … maybe … ?

Because I am the owner of this Gateway, I cannot remove my user from the existing Organization. The above observation is relate to adding and removing Organization with other users.

Observation 3: Created New Organisation and added in users in and deleted Old Organization … but still cannot see GatewayList. So it might be related to my user when it comes to the owner of Gateway … maybe … ?


I’m having the same issue, I cannot set any of my gateways. I’m the owner of two organizations that are collaborators of that gateways. This was working before and I did not change any right or organizations.

Thank you!

Hi everyone,

Same issue here.
We did not made any changes regarding ownership, organizations or collaborators.

The TTI core team is aware of the issue and the cause and will be working on a fix tomorrow.


GatewayList is working again :+1:

Thank you :pray:

You are lucky.
I have the same problem since this morning (5.12.).
Please TTI to fix this error.

This is the community forum, if you want to talk to TTI, try Slack …