Uplink data works in V2, but shows uplink channel not found in V3


I recently moved to the community stack, and merged my gateway and end nodes. Today I tried an uplink from my RAK811 module (connected to RPi), and successfully received the data on the V2 stack. However, in my application on the V3 stack it says that the join request was dropped due to “uplink channel not found”.

Have anyone had a similar problem after merging to V3?

PS: Sorry in advance if this post lack necessary information or is badly formulated :smiley:

How is the RAK811 configured for joining?

You can have it setup on both v2 & v3 but if the gateway is on v2, it’s not going to pass on the details to v3 as it gets a match on v2. So you’d need to change one of the keys on v2, at which point the v2 network will forward the uplink to see if v3 can process it.

I am currently using The rak811v3 module for Python to join using appeui and appkey

So if you change the AppKey on v2 it will stop matching and then potentially allow a join to v3


I have now changed the AppKey in V2, and The Things Community Stack is able to receive the join request. HOWEVER, each join request is dropped, saying the same thing: “Uplink channel not found”

Make sure your frequency plan matches the frequencies used by the device for uplinks. In case of EU868 the device can only use the three default frequencies: 868.1, 868.3 and 868.5 during
OTAA join,

yes, I read about it in the regional parameters document, however I am unsure on how I select these channels for OTAA join. Is this selected in the console, or on my device?

On your device.

as far as I know, there are no possible way of selecting the join frequency of my device (rak811). It was connecting fine with ttn v2, so I don’t understand why it should not work

TTN V2 accepted join requests using any frequency. TTN V3 tries to be very LoRaWAN specification compliant. The standard specifies the 3 frequencies I mentioned earlier for join requests in EU868 so that is what V3 accepts.
What are the frequencies used by the device when you get those messages?

“frequency”: “867900000”, “frequency”: “867500000” to name a few of the received join-requests

I also get the following:

Type: Join-request to cluster-local join server failed
Data: No NwkKey specified

The error message above arrives only sometimes after I try to join from the end node. The common message is still uplink channel not found

Those are invalid join frequencies so TTN correctly drops the packets.

Which LoRaWAN version did you specify while creating the device? And did you change any settings that had be pre filled?

Which firmware of RAK811 are you running - recent firmware for other RAK modules is working for me but I haven’t tried an 811 on v3 yet.

I am using the V3.0.x firmware on the rak811 module.

I am using the one suggested in the migration tutorial: " MAC V1.0.2, PHY V1.0.2 REV B"

I tried to delete and reregister the end device, however the problem still occurs. It is weird because it seem like the end-node selects all other frequencies than the three used for joining (868.1, 868.3 and 868.5)

Can you be more specific?

Did you put in different settings?

RAK811 Version:

I noticed that the LoRaWAN version was set to 1.1, so I changed it back to 1.0.2.


I installed rak811v3 on another raspberry device, and after 6-7 join requests it worked. I was able to receive messages from it, however the command line in on the Pi gives me a timeout error.