Uplink messages not arriving anymore

Hi everybody,

I’m new in the Lora world. Recently, I bougth a Mikrotik wAP LR8 Kit, and I configure it to read data from six devices using ABP authentication method, in the TTN server.

It worked perfectly. Some days ago, but, the TTN application had stopped to receive the messages generated by some devices. However, TTN application, keeps on receiving messages from other devices correctly.

I talk with the technical service of the mikrotik gateway, and they tell me that
all the devices are generating the lora packet correcly.

I attach the gatewayTraffic.png file where it can be send that the gateway reads every device message, but in the TTNAplicationLiveData.png file, it can be send that the messages generated by the 65 C0 58 31 are correctly resend to the TTN server (the sensor5v3 ones), but the ones generated by the 62 C0 58 31 don’t arrive to the TTN server.

How is it possible? What am I doing wrong? I do not change any configuration parameter?

Any help would be appreciated.

Thanks in advanve

Best regards

Jaume Cañas

Obviously we can’t see the pictures …

So we know the gateway is working and what it’s model is.

But you’ve given us no detail on the devices.

Is the 62 C0 58 31 the DevAddr of one of your devices. And if so, where did you get it?


I don’t know how to upload any picture to the post. I had thought of the up arrow button above, but it’s obvious that doesn’t work!

How can I attach some screenshot, if i can?

Yes, 62 C0 58 31 (sensor2) are the DevAddr of one of my devices. I’m testing with five other ones, and for the moment, i also tried it with the 65 C0 58 31(sensor5).

These are own made devices. One firm on the group.

They send data, the mikrotik gateway capture the whole data. From any of the testing devices (sensor2 and sensor5 at this moment). I try to attach the screenshot where it can be saw.

These two devices were declared in the TTN application, and they received data for a while. A few days ago I stopped receiving data from sensor 2, and I don’t know why?

Best regards,


As you are using ABP you might have frame counter issues. The frame counter of newly received data must be > the ones previously received. Is that the case for your devices?
Oh, another thing, if you are using TTN, please use DevAddr within the TTN range. The console should assign you one when you add a ADR device.

Hi Jac,

Thank you. I reset this frame counter.

Then, the first sensor activation, it’s not received sure, because the frame counter<previously received, but the second message is suposed to be received, isn’t it? It doesn’t work! The gateway keep on receiving the messages generated by the sensor, but it doesn’t arrive to the application livedata.

Where can i find the frame counter information?

The DevAddr is defined so, and it could not be changed! I’m using the TTN server for test. The final destination is a private server. But, I receive data from the other sensors defined in this application. Can’t I use devaddr out of TTN range?

Only TTN addresses or the experimental addresses starting with 00/01 should be used. If anything else happens to work you are lucky but don’t count on it.

At the top of the device page there are two numbers, one with an up arrow (uplink) and one with a down arrow (downlink). Those numbers are the respective frame counters for the device. Is the one next to uplink set to zero? (or an empty field with just an up arrow)

Thank you Jac,

In the application end device, the uplink frame count is 3921, and the downlink frame count, is 38.

In the gateway live data, when I force the device to send new data, it appears a new line with a receive uplink message from the same devAddr, and there is a FCnt field with a 26.

Rigth… I reset again the device frame counter, and in the gateway livedata, when I force the device to send new data, the new line that appears with a receive uplink message from the same devAddr, has a 1 in the FCnt field.

Then, this field is smaller than both uplink and downlink frame counters in the application end device. I can not do it smaller? Is there any way to reset the application end device uplink/downlink frame counters?

Thanks in advance,

Jaume Cañas

That means the framecounter has not been reset.

Thank you, but the framecounter that I reset from the device, is the one that actually sends and receives for the gateway livedata FCnt: 1. How can I reset these framecounters (uplink frame count 3921, downlink frame count 38)?
I try to upload a picture where it can be seen that the gateway catch a message from the 62 C0 58 31 device, with its framecount 29, but in the application screenshot, sensor2v3 is last seen 8 days ago, and keeps the frame counts.

Please search the forum for the correct way to reset frame counters for a node in V3. You might need to use the command line tool to reset the ‘session’.
@descartes You are probably more experienced in reset ABP counters. Any hints?


I check the Enabled in the Resets Frame Counters: Advanced Settings:Network layer: General Settings: End devices.

Afterwards, I activate the device, and effectively sends a new message, and it could be seen in the application Live Data.
I uncheck the Enabled again, and one other activation is also received in the application Live Data.

It seems to work fine, again.

Thank you very much.

Best regards.


Ha, I only use ABP for firmware radio tests and only when I’m testing firmware communications states, I’ve got the radio off the rest of the time as that bit is mostly a given.

ttn-lw-cli end-devices reset [application-id] [device-id] --mac-settings.resets-f-cnt true

The CLI install instructions are here:


It is the only tool to provide total access to all the stack settings.

Easier to navigate but due for an update:


as I am asking for clarity about some of the options. Should be updated by end of month.