V3 console shows "drop join-request" when OTAA devices try to join

Hello

Just joined the V3 community with a private setup and cannot get any end device to join as it seems, data comes in from the sensor but the only thing we get in web console is “drop join-request”! are we missing some steps here… and what does this mean “drop join-request”?, cannot seem to find any list of responses from system

BR
/A

Hi @LMSystems, I am running a v3 system. I think that this means the system has received the join request but that it does not match any known combination of Dev EUI, App EUI and OTAA credentials so it “drops” the join request.

Hi Tim and thank´s for the reply
Yes i would think so to, however,whatever i try to connect it says the same thing, but if i try them on the public server, they all work fine…
one suspicion i have is that the V3 system doesent accept the App Eui that is fixed within the manufactured sensors, in the public console you have to “manage” the EUI and put in the sensors APP one for it to work, but in the private one you dont seem to have that option, or at least i cant find it… how do you join the OTAA sensors… from the beginning i mean with starting a Application?

BR
/A

In V3, the LoRaWAN 1.1 terminology is used. For LoRaWAN 1.0.x devices, you need to enter the AppEUI in the field for JoinEUI, which in V3 is not in the application, but in the device settings.

As it’s mandatory: what did you fill in there? And any other configuration that you did not understand? (Leave the NwkKey blank for 1.0.x devices.)

2 Likes

Hi Arjanvanb

Got it to join by not entering the NwkKey due to that it is a 1.0.2 device, thanks :slight_smile: however there is much to explore in this since we cannot find any documentation for the console in detail
Can you possibly explain a few things

-What is the definition of Reset join Nonces?

  • Is there a way to send downlink messages from console like the public one?
  • Will the uplink decoder accept the same code as in the public one?
    fx: will below work

Would be nice to know. We plan to use integration to AWS in the future, but the public console is a very nice tool to monitor and test end-nodes with.

BR

/A

ps. tried below code and got ->> decode uplink data message failure

Code below

function Decoder(bytes, port) {
 var value=(bytes[0]<<8 | bytes[1]) & 0x3FFF;
 var batV=value/1000;//Battery,units:V
 value=bytes[2]<<8 | bytes[3];
 if(bytes[2] & 0x80)
 {value |= 0xFFFF0000;}
 var temp_SHT=(value/100).toFixed(2);
 value=bytes[4]<<8 | bytes[5];
 var hum_SHT=(value/10).toFixed(1);
 value=bytes[7]<<8 | bytes[8];
 if(bytes[7] & 0x80)
 {value |= 0xFFFF0000;}
 var temp_ds=(value/100).toFixed(2);
 return {
 BatV:batV,
 TempC_DS:temp_ds,
 TempC_SHT:temp_SHT,
 Hum_SHT:hum_SHT
 };

I’m not using V3, but indeed it seems there’s no “Simulate uplink” in the web interface, nor any test input for decoders. I’d say the decoders would be the same, but your decoder above would not be valid in V2 either; it’s missing the closing }. Indenting your code helps a lot to see that, but also the editor will show you these errors, in both V2 and V3.

(Also note that toFixed gives you text, not a number.)

As for:

Note that it says “Resets Join Nonces”. So, I’d say it’s something that the Join Server may, or may not, do. That said, I’ve no idea.

Ok, Thanks Arjan, and yes of course the closing }, dident get copied :slight_smile:
Ill have a discussion with them regarding this, to be able to decode and send data is really vital for the system in order to do an easy hands on testing…

Thank you for all help, have a nice day

BR
/A

LoRaWAN prohibits join nonce re-use, so a proper node has to keep track of values it has already used and not try to use them again, ever.

The ability to reset them server side would be for situations such as developing the part of the firmware that keeps track of that, or finding a bug in it, or loosing the EEPROM where the used value state is stored or something like that.

Hi and thanks, that solved that question, do you know how to within console to send a message to a joined device?

So “Resets Join Nonces: enabled” below could translate to “Join Nonce Security: disabled”?

And why is this option only available when not using “External Join Server”? (Below, all configuration after “External Join Server” is only enabled when that option is not checked.)

V3 Join Server settings

Because it would be the join server’s decision what to accept or not