Webhook suddenly not working

I have recently migrated my devices (home-brew nodes) and one gateway to V3. I have a webapp (self-made) which receives the data - I have modified it to (also) use the new JSON format. All was going fine for a couple of days until suddenly (around 10:30) the webhook stopped sending data. In the console I can see that uplinks are being sent, but no data arrives at my application. Any ideas what might be wrong ? I have made no changes in my setup in the last 24 hrs as far as I know.

Can you access your web server logs to check if they are coming in?

There was some system maintenance / updates from 10:00 CEST onwards but I can’t tell if this has been performed or completed.

FWIW, my webhook(s) are receiving data and did between 10:00 and 11:00 and since.

Hi Nick - thanks for the fast response !. On my webserver I have a number of projects - a few are still running on V2. I can see in the logging (or did you mean some other logging ?) that the V2 projects data is coming in fine, but no sound from the V3 project I have migrated. It is now 13:20 (I am in Holland by the way) and I still am receiving no data.

I meant the Apache/Nginx/Webserver logs

You can have as many webhooks as you like so you can add another one to see if there is a config issue

My app is written with ASP.Net and runs on a providers system (mijnhostingpartner.nl). The logs I can see are my own logs, written during the process of receiving a ‘POST’. I will add another webhook, although there is not that much to configure !

So no access or error logs from IIS?

I just tried to look in the providers console to see if I could access the IIS logs, and there seems to be a problem with logging in at the moment. I am assuming that this has to do with the root cause of the problem. I will check again this evening to see if it is solved. Thanks for your help !

I take it there’s an issue at your hosting provider then?

Thats what I am thinking. The delivery of the packet via webhooks uses basic authentication, and the account that I use does not seem to work at the moment. I will get back to you when I can log in in the prviders console.

Looks like hosting provider trouble - they tell me they had some kind of update around the time it went wrong. Sorry that I didn’t check that out before worrying you guys ! As far as I am concerned issue closed.


1 Like