All Things talk Integration - LoraWan


(Yamaha) #1

Hello Guys,

I have LoraWan setup ( Ardunio with some sensors connected to Multitech mlinux Lora Gatway connected to thethingsnetwork using OTT) i am receiving the data here but i want to virtualization the data ( location on map and vibration …ect) on backend app. I am am trying to visualizer my data on All Things talk but i can’t find much information.

Anyone have done a project throught All things talk ? Can any one help me with that please ?


The LIBRARY basement part 3
#2

source : https://www.facebook.com/thethingsnetwork/

- http://docs.allthingstalk.com/networks/use-the-things-network/
- AllThingsTalk Binary Conversion Language (pdf)


(Mark Stanley) #3

This is great! I have just run through the connection process with my Things Node. Once you’ve added your device on AllThingsTalk you need to add assets - one for battery, one for light, one for temperature - if you are using the Things Node basic sketch. Then you need to add a small bit of code to tell their binary converter thing what to do. To save you time, the code that works nicely is:

{
  "sense": [
    {
      "asset": "battery",
      "value": {
        "byte": 0,
        "bytelength": 2,
        "type": "integer"
      }
    },
    {
      "asset": "light",
      "value": {
        "byte": 2,
        "bytelength": 2,
        "type": "integer"
      }
    },
    {
      "asset": "temperature",
      "value": {
        "byte": 4,
        "bytelength": 2,
        "type": "integer",
        "calculation": "val/100"
      }
    }
  ]
}

(Tuftec) #4

I am struggling to get All Things Talk working with TTN.
I have read over the documentation but can not seem to get any data through to ATT.

The details earlier in this topic look simple enough, but buggered if I can get it to work.

I have devices on my TTN setup that have been previously sending data through to Cayenne without any major issue.

I have now removed the Cayenne integration from my application and replaced it with a ATT one.
I have also removed the LPP payload conversion (now set to custom).

I have a node that sends LPP style data (byte format) and I have added payload conversion stuff to my ATT ground (ABCL JSON conversion code to just pick up the bytes I need from the data).

I can see the data in the application console at the TTN but absolutely nothing seems to make its way to the ATT end.

I believe I have entered all the required TTN info correctly (dev_eui, app_eui, appskey, app-id, etc).

I am located in Australia but using the asia-se handler for my application. Not sure whether this has any bearing on the data not being seen. Maybe I have to use the eu-handler.

Any help would be most appreciated.

Cheers

Peter.